Re: WAV file audio

David Cameron - IRLP
 

Well the issue I run into is some of the nodes are running software so old that the new versions of the same software don't even use the same syntax. sox is a great example of this. Then I need to make the scripts recognize this, and that is where it starts to fall apart.

To be honest, if the node is running software that is no longer maintained (which is anything older than Debian 8), it really is a risk to the network that it is on, as they can likely be easily compromised (or are already compromised) and can be used to sniff/snoop on traffic on your network, or be used to launch attacks on other systems (Denial of Service).

With the advent of Pi-based systems, there is not a real reason not to upgrade to something newer. I imagine with the cost of electricity, you will recoup your up front cost in a matter of a year or two.

David Cameron

On 2019-11-27 10:11, Phil Zocco wrote:
" I updated the script this morning and was able to find a node old
enough to test on :)"
An old node?! You western Canadians have a warped sense of humor...HI.
The script worked.
Thanks....I think.
73,
Phil N1BOW
-----Original Message-----
From: IRLP@irlp.groups.io [mailto:IRLP@irlp.groups.io] On Behalf Of
David Cameron - IRLP
Sent: Wednesday, November 27, 2019 12:39 PM
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] WAV file audio
Try a reboot again, OR, log in as repeater and run
/home/irlp/scripts/update files
I updated the script this morning and was able to find a node old enough
to test on :)
Dave Cameron
On 2019-11-27 9:19 a.m., Phil Zocco wrote:
Greetings.
For some strange reason this morning, any of the WAV files that have
personally recorded are all coming out with loud distorted audio.
These files announce control functions and various other customized
recordings.
BUT...any of the original WAV files that Dave C included in the IRLP
package play back normally. Like when he says, "IRLP Node enabled",
it's sound just fine. Any announcements for a reflector are distorted
If I play back my custom On-the Hour announcement with my voice, it is
distorted. I checked the alsamixer and the controls are where they
normally are.
Any ideas? I have rebooted the node and still the same issues.
Thanks in advance.
73,
Phil N1BOW
Node 5960
AMT MP 113.6
Niantic, CT USA Earth

Join IRLP@irlp.groups.io to automatically receive all group messages.