Re: Networking failing using openvpn


David Cameron - IRLP
 

To me it is a bit of a "hang"... The VPN drops, but the gateway is not returned to the local LAN. It gets stuck on the VPN, but can not reconnect.

I think the only solution is to have an external script that tries to ping the private IP of the VPN server you are connected to, and if fails a few times in a row, then restart the VPN.

It appears to be a bug in the older openvpn, as it does not seem to recover from certain situations. You should be able to adjust some of the keepalive parameters, etc.

Dave Cameron

On 2020-06-10 9:53 a.m., Klaus Rung via groups.io wrote:
Ok thanks for the dns info to use the router dns and see if that fixes the problem.
Klaus
On Wednesday, June 10, 2020, 10:27:41 a.m. EDT, k9dc <dave@...> wrote:
This is probably because your DNS 1.1.1.1 is not accessible after the tunnel drops. With DNS dead, your node will not be able to lookup vpn01.irlp.net.  I would suggest using your local router for DNS (not 1.1.1.1 or other outside nameserver).  The reason is that your local router will always work regardless of the VPN being there or not.
I would also recommend upgrading to Debian 9 Stretch.  The version of OpenVPN that comes with 9, is much more robust than Debian 7.
-k9dc

> On Jun 10, 2020, at 10:14, Klaus Rung via groups.io
<k_rung=yahoo.com@groups.io <mailto:yahoo.com@groups.io>> wrote:
>
> I have a deb 7 jessie node that has the openvpn installed. The
openvpn work fine when booted and gets the 44. ip and works normally for a day or so. When the provider releases the wan ip it appears that the node cannot reconnect to get the 44 ip and the message in the log is
>
> Jun 09 2020 12:07:47 -0400 ipupdate: WARNING - Comms error to server
142.103.194.4. Cant obtain current IP.
> Jun 09 2020 12:15:31 -0400 ipupdate: WARNING - Comms error to server
142.103.194.4. Cant obtain current IP.
> Jun 09 2020 12:41:36 -0400 ipupdate: WARNING - Comms error to server
142.103.194.4. Cant obtain current IP.
> Jun 09 2020 12:43:46 -0400 WARNING - DNS is not setup correctly
> Jun 09 2020 12:47:57 -0400 ipupdate: WARNING - Comms error to server
142.103.194.4. Cant obtain current IP.
>
> The resolv.conf is set up to use 1.1.1.1, the same is set up in the
networking file.
>
> Once you reboot the pc all is good again. Is there anything I should
check or is there a solution to this. It only happens when using the vpn.
>
> Klaus
> ve3kr
> node 7371

Join IRLP@irlp.groups.io to automatically receive all group messages.