Re: How do I change or force the HP T5730 to use the dongle?


David Cameron - IRLP
 

You have to determine what module is being used first. Use the command

lsmod

to list the modules. There will be one called snd, with all the associated modules loaded:

snd_pcm_oss 45056 0
snd_mixer_oss 24576 1 snd_pcm_oss
snd_pcm 81920 3 snd_pcm_oss,snd_via82xx,snd_ac97_codec
snd_timer 28672 2 snd_seq,snd_pcm
snd 61440 10 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_via82xx,snd_ac97_codec,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device,snd_pcm
soundcore 16384 1 snd

The ones here that jump out at me are snd_via82xx and snd_ac97_codec. In order to blacklist them, I make a file called:

/etc/modprobe.d/my-blacklist.conf

and in it put something like

# Blacklists the via sound module
blacklist snd_via82xx
blacklist snd_ac97_codec

You may have to try to blacklist some others to get it right. Be careful what you blacklist, as if you do something like blacklist the USB controller, your keyboard wont work, etc.

Alternately, you can also set the USB sound card as the FIRST card, and demote the others. Make a file called:

/etc/modprobe.d/my-usb-first.conf

# Keep snd-usb-audio loaded as first soundcard
options snd-usb-audio index=0
# Demotes other sound cards below it
options snd_via82xx index=-2
options snd_ac97_codec index=-2

Dave Cameron

On 2020-09-09 9:49 a.m., kd1yh wrote:
where do you black list it?
root@stn8581:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC262 Analog [ALC262 Analog]
 Subdevices: 1/1
 Subdevice #0: subdevice #0
card 1: Device [C-Media USB Audio Device], device 0: USB Audio [USB Audio]
 Subdevices: 1/1
 Subdevice #0: subdevice #0
root@stn8581:~# alsactl init
Found hardware: "HDA-Intel" "Realtek ALC262" "HDA:10ec0262,103c302f,00100202" "0x103c" "0x302f"
Hardware is initialized using a generic method
root@stn8581:~# alsactl init 1
Found hardware: "USB-Audio" "USB Mixer" "USB0d8c:0008" "" ""
Hardware is initialized using a generic method
root@stn8581:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC262 Analog [ALC262 Analog]
 Subdevices: 1/1
 Subdevice #0: subdevice #0
card 1: Device [C-Media USB Audio Device], device 0: USB Audio [USB Audio]
 Subdevices: 1/1
 Subdevice #0: subdevice #0
root@stn8581:~#
-----Original Message----- From: David Cameron - IRLP
Sent: Wednesday, September 09, 2020 12:06 PM
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] How do I change or force the HP T5730 to use the dongle?
After booting, have a look for the sound module loaded in the
/var/log/kern.log file. Then you can blacklist it, and/or force the USB
sound card to be primary. You want the USB card to show as "card 0".
Some other tools are:
alsactl init
aplay -l
Here is the result from a Pi node (1010):
root@stn1010:~# alsactl init
Found hardware: "USB-Audio" "USB Mixer" "USB0d8c:0008" "" ""
Hardware is initialized using a generic method
root@stn1010:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Device [C-Media USB Audio Device], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Here are the results from a PC node (1000):
root@stn100:~# alsactl init
Found hardware: "VIA8237" "VIA Technologies id 83" "AC97a:56494183"
"0x1106" "0xaa08"
Hardware is initialized using a generic method
root@stn100:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: V8237 [VIA 8237], device 0: VIA 8237 [VIA 8237]
  Subdevices: 4/4
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
card 0: V8237 [VIA 8237], device 1: VIA 8237 [VIA 8237]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
David Cameron
On 2020-09-09 7:21 a.m., kd1yh wrote:
FG-UAUDVI-C119 Sound dongle
It does seem to see this on boot up when internal bios is turned off
. is there a get file to fix?
export USE_AOSS=YES
export USE_APLAY=YES
*From:* kd1yh
*Sent:* Tuesday, September 01, 2020 8:10 PM
*To:* IRLP@irlp.groups.io
*Subject:* Re: [IRLP] How do I change or force the HP T5730 to use the dongle?
I tried to shut off in bios nothing worked.
It is the voice coming from the internet that is garbled.
Have to find where how to blacklist in boot configure file.
When I talk it is fine but when others come back it is garbled.
Paul KD1YH 8581
*From:* David Cameron - IRLP
*Sent:* Tuesday, September 01, 2020 10:41 AM
*To:* IRLP@irlp.groups.io
*Subject:* Re: [IRLP] How do I change or force the HP T5730 to use the dongle?
You need to turn off the onboard sound device in the bios. If that doesn't work, you need to blacklist the module in linux.
Is the irlp audio garbled, or are the transmitted messages garbled? It could be that you don't have USE_AOSS=YES and USE_APLAY=YES set in the environment file.
Dave Cameron
-------- Original message --------
From: kd1yh <kd1yh@...>
Date: 9/1/20 2:28 AM (GMT-08:00)
To: IRLP@irlp.groups.io
Subject: [IRLP] How do I change or force the HP T5730 to use the dongle?
HP t5730  to FG-UAUDVI-C119 Sound dongle
I try to use Alsamixer to use the dongle, but it won’t cannot save to use.
Where do  I find in boot configure to correct?
My Audio is garbled coming from the internet and think internal sound is bad.
Paul node 8581

Join IRLP@irlp.groups.io to automatically receive all group messages.