Topics

dtmfdial

Klaus Rung
 

Yes that is what was happening the script kept reverting after each restart. I will try your suggestion.

On May 8, 2020, at 5:04 PM, k9dc <dave@...> wrote:

Are you directly editing scripts/dtmfdial? That script is replaced every time the node restarts, or an update files happens (nightly). If you want to use it, you need to make a copy of it the into the custom directory and call it from there.

Sorry, I didn’t realize that might be what you are doing. the scripts directory (and all the others) are identical on all nodes, and forced back to the identical set of scripts every night.

-k9dc


On May 8, 2020, at 16:34, Klaus Rung via groups.io <k_rung=yahoo.com@groups.io> wrote:

I put the export TXDELAY=500000 into the environment file and restarted and it seems to work and the first digit is able to be heard and decoded more reliably but I went to 1500000 and I did not see a difference. the values in the dtmfdial file I should be able to change the values in but it keeps going back to the same original settings.

I would think I should be able to change the txdelay and dial volume in this file.


${BIN}/coscheck
${BIN}/key
usleep ${TXDELAY:-250000}

if [ -z "$DIAL_OPTIONS" ] ; then
${DIAL} --volume 25 ${1}p
else
${DIAL} ${DIAL_OPTIONS} ${1}p


On Friday, May 8, 2020, 4:01:16 p.m. EDT, k9dc <dave@...> wrote:



I’ve never used it myself, but the reference to $TXDELAY pulls the value set in the environment file. So perhaps you could increase it there. Perhaps it is not defined.

export TXDELAY=500000

But if you have a specific interval you want to use, just remove the reference and place a discrete value in your script.

usleep 500000

-k9dc


On May 8, 2020, at 15:42, Klaus Rung via groups.io <k_rung=yahoo.com@groups.io> wrote:

I am trying to send dtmf to the remote repeater so I am trying to increase the wait time of dtmf after keying before sending digits.

${BIN}/key
usleep ${TXDELAY:-250000}

if [ -z "$DIAL_OPTIONS" ] ; then
${DIAL} --volume 25 ${1}p

When I change txdelay to 500000 it changes back after the irlp software is restarted. How do I get to keep my new settings in this file?

Klaus
ve3kr
2450











k9dc
 

Are you directly editing scripts/dtmfdial? That script is replaced every time the node restarts, or an update files happens (nightly). If you want to use it, you need to make a copy of it the into the custom directory and call it from there.

Sorry, I didn’t realize that might be what you are doing. the scripts directory (and all the others) are identical on all nodes, and forced back to the identical set of scripts every night.

-k9dc

On May 8, 2020, at 16:34, Klaus Rung via groups.io <k_rung=yahoo.com@groups.io> wrote:

I put the export TXDELAY=500000 into the environment file and restarted and it seems to work and the first digit is able to be heard and decoded more reliably but I went to 1500000 and I did not see a difference. the values in the dtmfdial file I should be able to change the values in but it keeps going back to the same original settings.

I would think I should be able to change the txdelay and dial volume in this file.


${BIN}/coscheck
${BIN}/key
usleep ${TXDELAY:-250000}

if [ -z "$DIAL_OPTIONS" ] ; then
${DIAL} --volume 25 ${1}p
else
${DIAL} ${DIAL_OPTIONS} ${1}p


On Friday, May 8, 2020, 4:01:16 p.m. EDT, k9dc <dave@...> wrote:



I’ve never used it myself, but the reference to $TXDELAY pulls the value set in the environment file. So perhaps you could increase it there. Perhaps it is not defined.

export TXDELAY=500000

But if you have a specific interval you want to use, just remove the reference and place a discrete value in your script.

usleep 500000

-k9dc


On May 8, 2020, at 15:42, Klaus Rung via groups.io <k_rung=yahoo.com@groups.io> wrote:

I am trying to send dtmf to the remote repeater so I am trying to increase the wait time of dtmf after keying before sending digits.

${BIN}/key
usleep ${TXDELAY:-250000}

if [ -z "$DIAL_OPTIONS" ] ; then
${DIAL} --volume 25 ${1}p

When I change txdelay to 500000 it changes back after the irlp software is restarted. How do I get to keep my new settings in this file?

Klaus
ve3kr
2450





Klaus Rung
 

I put the export TXDELAY=500000 into the environment file and restarted and it seems to work and the first digit is able to be heard and decoded more reliably but I went to 1500000 and I did not see a difference. the values in the dtmfdial file I should be able to change the values in but it keeps going back to the same original settings.

I would think I should be able to change the txdelay and dial volume in this file.


${BIN}/coscheck
${BIN}/key
usleep ${TXDELAY:-250000}

if [ -z "$DIAL_OPTIONS" ] ; then
  ${DIAL} --volume 25 ${1}p
else
  ${DIAL} ${DIAL_OPTIONS} ${1}p


On Friday, May 8, 2020, 4:01:16 p.m. EDT, k9dc <dave@...> wrote:



I’ve never used it myself, but the reference to $TXDELAY pulls the value set in the environment file. So perhaps you could increase it there. Perhaps it is not defined.

export TXDELAY=500000

But if you have a specific interval you want to use, just remove the reference and place a discrete value in your script.

usleep 500000

-k9dc


> On May 8, 2020, at 15:42, Klaus Rung via groups.io <k_rung=yahoo.com@groups.io> wrote:
>
> I am trying to send dtmf to the remote repeater so I am trying to increase the wait time of dtmf after keying before sending digits.
>
> ${BIN}/key
> usleep ${TXDELAY:-250000}
>
> if [ -z "$DIAL_OPTIONS" ] ; then
>  ${DIAL} --volume 25 ${1}p
>
> When I change txdelay to 500000 it changes back after the irlp software is restarted. How do I get to keep my new settings in this file?
>
> Klaus
> ve3kr
> 2450






k9dc
 

I’ve never used it myself, but the reference to $TXDELAY pulls the value set in the environment file. So perhaps you could increase it there. Perhaps it is not defined.

export TXDELAY=500000

But if you have a specific interval you want to use, just remove the reference and place a discrete value in your script.

usleep 500000

-k9dc

On May 8, 2020, at 15:42, Klaus Rung via groups.io <k_rung=yahoo.com@groups.io> wrote:

I am trying to send dtmf to the remote repeater so I am trying to increase the wait time of dtmf after keying before sending digits.

${BIN}/key
usleep ${TXDELAY:-250000}

if [ -z "$DIAL_OPTIONS" ] ; then
${DIAL} --volume 25 ${1}p

When I change txdelay to 500000 it changes back after the irlp software is restarted. How do I get to keep my new settings in this file?

Klaus
ve3kr
2450

Klaus Rung
 

I am trying to send dtmf to the remote repeater so I am trying to increase the wait time of dtmf after keying before sending digits.

${BIN}/key
usleep ${TXDELAY:-250000}

if [ -z "$DIAL_OPTIONS" ] ; then
  ${DIAL} --volume 25 ${1}p

When I change txdelay to 500000 it changes back after the irlp software is restarted. How do I get to keep my new settings in this file?

Klaus
ve3kr
2450