Topics

adding WiFi to a PiRLP node with openVPN


Tom
 

I have a friend's PiRLP (with openVPN) hardware. He is NB7C with node 3407. I just built a simplex node for him with a HT and DC to DC converters. It works great on eth0. There is no wlan0 installed. I saved the microSD image; so I can go back. I've tried installing wicd-curses and have run into a wall connecting to my WiFi router (WPA2 with passphrase). The setup in wicd-curses insists on using the HEX rather than text passphrase. My router is seen in the SSID list. My friend wants to use this node with a WiFi hotspot when traveling.

I see nothing defined in /etc/wpa_supplicant/wpa_supplicant.conf or /etc/dhcpcd.conf as I would in an allstarlink WiFi installation.

The hardware is a Pi4 running Debian 10 (Buster).

Are there known issues getting WiFi to work on an EchoIRLP Pi4 - Debian10 - openVPN PiRLP node?

Thanks,
Tom / K5TRA


Fred
 

Tom. Debian 10 doesn’t used WICD.

On Apr 12, 2020, at 4:10 PM, Tom <tom@...> wrote:

I have a friend's PiRLP (with openVPN) hardware. He is NB7C with node 3407. I just built a simplex node for him with a HT and DC to DC converters. It works great on eth0. There is no wlan0 installed. I saved the microSD image; so I can go back. I've tried installing wicd-curses and have run into a wall connecting to my WiFi router (WPA2 with passphrase). The setup in wicd-curses insists on using the HEX rather than text passphrase. My router is seen in the SSID list. My friend wants to use this node with a WiFi hotspot when traveling.

I see nothing defined in /etc/wpa_supplicant/wpa_supplicant.conf or /etc/dhcpcd.conf as I would in an allstarlink WiFi installation.

The hardware is a Pi4 running Debian 10 (Buster).

Are there known issues getting WiFi to work on an EchoIRLP Pi4 - Debian10 - openVPN PiRLP node?

Thanks,
Tom / K5TRA


David Cameron - IRLP
 

First of all, if you CAN run wired to an ethernet cable, do. If you can't the wifi can work fine, but expect sub-optimal performance. If it is truly a PiRLP nodes I built, check in the file:

/etc/network/interfaces

There is an example for making it work on wifi. The lines you need to add are:

allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-ssid NETWORK-NAME
wpa-psk NETWORK-PASSOWORD

If you want a static IP, instead of iface wlan0 inet dhcp, put the following:

iface wlan0 inet static
address 192.168.1.10
netmask 255.255.255.0
gateway 192.168.1.1

You should comment out the eth0 entries.

First, go back to the old image without wicd-curses.... That program is not supported on Debian 9 or 10 and causes problems.

David Cameron
VE7LTD

On 12/04/2020 2:09 p.m., Tom wrote:
I have a friend's PiRLP (with openVPN) hardware. He is NB7C with node 3407. I just built a simplex node for him with a HT and DC to DC converters. It works great on eth0. There is no wlan0 installed. I saved the microSD image; so I can go back. I've tried installing wicd-curses and have run into a wall connecting to my WiFi router (WPA2 with passphrase). The setup in wicd-curses insists on using the HEX rather than text passphrase. My router is seen in the SSID list. My friend wants to use this node with a WiFi hotspot when traveling.

I see nothing defined in /etc/wpa_supplicant/wpa_supplicant.conf or /etc/dhcpcd.conf as I would in an allstarlink WiFi installation.

The hardware is a Pi4 running Debian 10 (Buster).

Are there known issues getting WiFi to work on an EchoIRLP Pi4 - Debian10 - openVPN PiRLP node?

Thanks,
Tom / K5TRA


Tom
 

Thanks David, I'll try that. I tried it last night; but didn't comment out the eth0 references (ethernet wasn't plugged in) and that didn't work. Is /etc/network/interfaces the only plave to comment out eth0 references?

Thanks again,
Tom / K5TRA


Tom
 

David,
I tried that (/etc/network/interfaces)  with DHCP and then again with static. ifconfignow lists wlan0 and not eth0; but no connection. I can't ping my wifi router. I have google fiber and wifi has worked well with RPi3B (Debian9) allstarlink nodes.

I assume the wpa-psk entry is simply the ASCII passphrase string. This is the PiRLP box that you built for Carl (NB7C).

Any ideas what I'm missing?

Thanks,
Tom / K5TRA


Tom
 

David, it is behaving as though the passphrase is not being accepted. 

I am working with the original image.

Tom / K5TRA


David Cameron - IRLP
 

Well, I am not sure why it is not working with your system, as it works fine with mine. Do you have details on what encryption your system is using (WPA vs WPA2, TKIP vs AES)?

Dave Cameron

On 2020-04-12 8:06 p.m., Tom wrote:
David, it is behaving as though the passphrase is not being accepted.
I am working with the original image.
Tom / K5TRA


Tom
 

It is WPA2. It also has the capability of running in a legacy mode that supports WPA; but that is currently turned off. I don't understand why the same passphrase works fine on my allstarlink Pi's. Is the syntax for wpa-psk any different for WPA2 ?
Tom


David Cameron - IRLP
 

Not that I am aware. I seldom use wifi - only on a Raspberry Zero W where Ethernet is not an option.

This is a Debian setup - IRLP does nothing special.

There is an option to put the 64 character HEX value in instead of the plain-text using the wpa_passphrase command.

Dave Cameron

On 2020-04-12 9:26 p.m., Tom wrote:
It is WPA2. It also has the capability of running in a legacy mode that supports WPA; but that is currently turned off. I don't understand why the same passphrase works fine on my allstarlink Pi's. Is the syntax for wpa-psk any different for WPA2 ?
Tom


Tom
 

David,
Well, I just got it working. It was cockpit issues here. I had set the SSID, for testing purposes here, to k5tra_fiber. It should have been K5TRA_fiber. My Bad. 'Sorry to take up the BW here for that.
Thanks again,
Tom / K5TRA