Topics

CentOS and Debian Not installing

Chris Pitre
 
Edited

Please Help.

Tried to install Debian on a newer computer for IRLP,  DUO CORE , Sata HDD, I get to the Start/Menu screen on Debian, hit enter for text install, screen goes black and nothing happens.

Next for the heck of it I tried CentOS, freezes during the install at:

PCI: Probing PCI hardware (bus 00)

Anyone have a solution to this, 
Thanks

David Cameron - IRLP
 

Did you try the no framebuffer option?

It's likely an issue with the video card not being fully compatible. 

The debian install is the same as the one that ships with debian, so best to look on forums for debian than to ask here. 

Dave Cameron 

-------- Original message --------
From: Chris Pitre <ve3ctp@...>
Date: 5/23/20 9:10 PM (GMT-08:00)
To: IRLP@irlp.groups.io
Subject: [IRLP] CentOS and Debian Not installing

[Edited Message Follows]

Please Help.

Tried to install Debian on a newer computer for IRLP,  DUO CORE , Sata HDD, I get to the Start/Menu screen on Debian, hit enter for text install, screen goes black and nothing happens.

Next for the heck of it I tried CentOS, freezes during the install at:

PCI: Probing PCI hardware (bus 00)

Anyone have a solution to this, 
Thanks

Chris Pitre
 

Yes I did 

I was able to get some text this time, however the end result still is not good.

last line is:

end kernel panic- not syncing: Attempted to kill init! exit 
code 0x00000009
[  0.377311]     ]---

Nosey Nick VA3NNW
 

Chris Pitre wrote:
I was able to get some text this time, however the end result still is
not good.
last line is:
end kernel panic- not syncing: Attempted to kill init! exit 
code 0x00000009
[  0.377311]     ]---
Yeah, no, the FIRST few lines of the kernel panic are far more likely to
be useful than the last few.

I think I have to assume there's something strange / unsupported /
possibly broken about your hardware.

Do any other OSes work OK, do you know?

73, Nick VA3NNW

--
"Nosey" Nick Waterman, VA3NNW/G7RZQ, K2 #5209.
use Std::Disclaimer; sig@...
The Universe knows what it's doing -- Ambasador Delenn, B5

David Cameron - IRLP
 

Often a Kernel Panic right off the start is a sign of bad hardware, such as failing RAM. I always try to remove half the RAM chips, try again, if the problem is the same, try the other half, if still the same, I start looking for options in the BIOS that change the panic behaviour.

You should also make sure your motherboard has the latest firmware for the BIOS.

If you can't get past the panic, Linux was just not meant to be on this motherboard.

David Cameron

On 24/05/2020 6:40 p.m., Nosey Nick VA3NNW wrote:
Chris Pitre wrote:
I was able to get some text this time, however the end result still is
not good.
last line is:
end kernel panic- not syncing: Attempted to kill init! exit
code 0x00000009
[  0.377311]     ]---
Yeah, no, the FIRST few lines of the kernel panic are far more likely to
be useful than the last few.

I think I have to assume there's something strange / unsupported /
possibly broken about your hardware.

Do any other OSes work OK, do you know?

73, Nick VA3NNW

Nosey Nick VA3NNW
 

David Cameron - IRLP wrote:
Often a Kernel Panic right off the start is a sign of bad hardware,
such as failing RAM. I always try to remove half the RAM chips, try
again, if the problem is the same, try the other half, if still the
same, I start looking for options in the BIOS that change the panic
behaviour.
True 'nuff.
If you can't get past the panic, Linux was just not meant to be on
this motherboard.
Well, there's also a few things you can do to make Linux deliberately
avoid treading on dubious/unsupported/broken bits of hardware. Most
distros use the grub bootloader, and many have a "failsafe" boot option
in the grub menu which will try disabling a bunch of things. If your
distro doesn't have that grub menu option, it might still have an option
"e to edit the commands before booting" and you can find the line that
says "kernel /blahblah" and add on the end some stuff like "kernel
/blahblah root=/dev/blah nosplash apm=off noresume edd=off
powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset 
x11failsafe acpi=off noapic nolapic "

Each of these options will disable stuff, often make Linux FAR less
efficient, far slower, use far more electricity, miss a bunch of
features... but MIGHT help it boot (or indeed might make it worse). This
is where the lines just before+after the START of the kernel panic is
often helpful - likely to tell us what subsystem is panicking.

Raspberry pi is a bit different, but you can get into a boot menu that
will let you edit "/boot/cmdline.txt" which is somewhat similar.

UEFI-based systems might be a bit different too, but sometimes have an
option to put them into a BIOS-compatible boot mode.

--
"Nosey" Nick Waterman, VA3NNW/G7RZQ, K2 #5209.
use Std::Disclaimer; sig@...
Kirk to Enterprise - beam down yeoman Rand and a six-pack.

Chris Pitre
 

I was doing some further reading, apparently I had to do a BIOS update.  I updated from 1.53 to 1.60 and it installed Debian.

The computer is a dc5800.

However I will keep an eye on the memory.. perhaps swap  it out in the future

David Cameron - IRLP
 

It was likely the BIOS issue. I find that RAM is usually the culprit if some issue doesn't exist with the BIOS or framebuffer issues.

Dave Cameron

On 2020-05-25 7:09 p.m., Chris Pitre wrote:
I was doing some further reading, apparently I had to do a BIOS update. I updated from 1.53 to 1.60 and it installed Debian.
The computer is a dc5800.
However I will keep an eye on the memory.. perhaps swap  it out in the future