Topics

How do I change or force the HP T5730 to use the dongle?


kd1yh
 

HP t5730  to FG-UAUDVI-C119 Sound dongle
 
I try to use Alsamixer to use the dongle, but it won’t cannot save to use.
Where do  I find in boot configure to correct?
 
My Audio is garbled coming from the internet and think internal sound is bad.
Paul node 8581


David Cameron - IRLP
 

You need to turn off the onboard sound device in the bios. If that doesn't work, you need to blacklist the module in linux. 

Is the irlp audio garbled, or are the transmitted messages garbled? It could be that you don't have USE_AOSS=YES and USE_APLAY=YES set in the environment file. 

Dave Cameron 

-------- Original message --------
From: kd1yh <kd1yh@...>
Date: 9/1/20 2:28 AM (GMT-08:00)
To: IRLP@irlp.groups.io
Subject: [IRLP] How do I change or force the HP T5730 to use the dongle?

HP t5730  to FG-UAUDVI-C119 Sound dongle
 
I try to use Alsamixer to use the dongle, but it won’t cannot save to use.
Where do  I find in boot configure to correct?
 
My Audio is garbled coming from the internet and think internal sound is bad.
Paul node 8581


kd1yh
 

I tried to shut off in bios nothing worked.
It is the voice coming from the internet that is garbled.
Have to find where how to blacklist in boot configure file.
 
When I talk it is fine but when others come back it is garbled.
Paul KD1YH 8581
 

From: David Cameron - IRLP
Sent: Tuesday, September 01, 2020 10:41 AM
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] How do I change or force the HP T5730 to use the dongle?
 
You need to turn off the onboard sound device in the bios. If that doesn't work, you need to blacklist the module in linux. 
 
Is the irlp audio garbled, or are the transmitted messages garbled? It could be that you don't have USE_AOSS=YES and USE_APLAY=YES set in the environment file.
 
Dave Cameron
 
-------- Original message --------
From: kd1yh <kd1yh@...>
Date: 9/1/20 2:28 AM (GMT-08:00)
To: IRLP@irlp.groups.io
Subject: [IRLP] How do I change or force the HP T5730 to use the dongle?
 
HP t5730  to FG-UAUDVI-C119 Sound dongle
 
I try to use Alsamixer to use the dongle, but it won’t cannot save to use.
Where do  I find in boot configure to correct?
 
My Audio is garbled coming from the internet and think internal sound is bad.
Paul node 8581


kd1yh
 

FG-UAUDVI-C119 Sound dongle
It does seem to see this on boot up when internal bios is turned off  . is there a get file to fix?
export USE_AOSS=YES
export USE_APLAY=YES
 
 

From: kd1yh
Sent: Tuesday, September 01, 2020 8:10 PM
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] How do I change or force the HP T5730 to use the dongle?
 
I tried to shut off in bios nothing worked.
It is the voice coming from the internet that is garbled.
Have to find where how to blacklist in boot configure file.
 
When I talk it is fine but when others come back it is garbled.
Paul KD1YH 8581
 
From: David Cameron - IRLP
Sent: Tuesday, September 01, 2020 10:41 AM
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] How do I change or force the HP T5730 to use the dongle?
 
You need to turn off the onboard sound device in the bios. If that doesn't work, you need to blacklist the module in linux. 
 
Is the irlp audio garbled, or are the transmitted messages garbled? It could be that you don't have USE_AOSS=YES and USE_APLAY=YES set in the environment file.
 
Dave Cameron
 
-------- Original message --------
From: kd1yh <kd1yh@...>
Date: 9/1/20 2:28 AM (GMT-08:00)
To: IRLP@irlp.groups.io
Subject: [IRLP] How do I change or force the HP T5730 to use the dongle?
 
HP t5730  to FG-UAUDVI-C119 Sound dongle
 
I try to use Alsamixer to use the dongle, but it won’t cannot save to use.
Where do  I find in boot configure to correct?
 
My Audio is garbled coming from the internet and think internal sound is bad.
Paul node 8581


David Cameron - IRLP
 

After booting, have a look for the sound module loaded in the /var/log/kern.log file. Then you can blacklist it, and/or force the USB sound card to be primary. You want the USB card to show as "card 0".

Some other tools are:
alsactl init
aplay -l

Here is the result from a Pi node (1010):

root@stn1010:~# alsactl init
Found hardware: "USB-Audio" "USB Mixer" "USB0d8c:0008" "" ""
Hardware is initialized using a generic method

root@stn1010:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Device [C-Media USB Audio Device], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

Here are the results from a PC node (1000):

root@stn100:~# alsactl init
Found hardware: "VIA8237" "VIA Technologies id 83" "AC97a:56494183" "0x1106" "0xaa08"
Hardware is initialized using a generic method

root@stn100:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: V8237 [VIA 8237], device 0: VIA 8237 [VIA 8237]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 0: V8237 [VIA 8237], device 1: VIA 8237 [VIA 8237]
Subdevices: 1/1
Subdevice #0: subdevice #0



David Cameron

On 2020-09-09 7:21 a.m., kd1yh wrote:
FG-UAUDVI-C119 Sound dongle
It does seem to see this on boot up when internal bios is turned off  . is there a get file to fix?
export USE_AOSS=YES
export USE_APLAY=YES
*From:* kd1yh
*Sent:* Tuesday, September 01, 2020 8:10 PM
*To:* IRLP@irlp.groups.io
*Subject:* Re: [IRLP] How do I change or force the HP T5730 to use the dongle?
I tried to shut off in bios nothing worked.
It is the voice coming from the internet that is garbled.
Have to find where how to blacklist in boot configure file.
When I talk it is fine but when others come back it is garbled.
Paul KD1YH 8581
*From:* David Cameron - IRLP
*Sent:* Tuesday, September 01, 2020 10:41 AM
*To:* IRLP@irlp.groups.io
*Subject:* Re: [IRLP] How do I change or force the HP T5730 to use the dongle?
You need to turn off the onboard sound device in the bios. If that doesn't work, you need to blacklist the module in linux.
Is the irlp audio garbled, or are the transmitted messages garbled? It could be that you don't have USE_AOSS=YES and USE_APLAY=YES set in the environment file.
Dave Cameron
-------- Original message --------
From: kd1yh <kd1yh@...>
Date: 9/1/20 2:28 AM (GMT-08:00)
To: IRLP@irlp.groups.io
Subject: [IRLP] How do I change or force the HP T5730 to use the dongle?
HP t5730  to FG-UAUDVI-C119 Sound dongle
I try to use Alsamixer to use the dongle, but it won’t cannot save to use.
Where do  I find in boot configure to correct?
My Audio is garbled coming from the internet and think internal sound is bad.
Paul node 8581


kd1yh
 

where do you black list it?
root@stn8581:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC262 Analog [ALC262 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Device [C-Media USB Audio Device], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
root@stn8581:~# alsactl init
Found hardware: "HDA-Intel" "Realtek ALC262" "HDA:10ec0262,103c302f,00100202" "0x103c" "0x302f"
Hardware is initialized using a generic method
root@stn8581:~# alsactl init 1
Found hardware: "USB-Audio" "USB Mixer" "USB0d8c:0008" "" ""
Hardware is initialized using a generic method
root@stn8581:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC262 Analog [ALC262 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Device [C-Media USB Audio Device], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
root@stn8581:~#

-----Original Message-----
From: David Cameron - IRLP
Sent: Wednesday, September 09, 2020 12:06 PM
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] How do I change or force the HP T5730 to use the dongle?

After booting, have a look for the sound module loaded in the
/var/log/kern.log file. Then you can blacklist it, and/or force the USB
sound card to be primary. You want the USB card to show as "card 0".

Some other tools are:
alsactl init
aplay -l

Here is the result from a Pi node (1010):

root@stn1010:~# alsactl init
Found hardware: "USB-Audio" "USB Mixer" "USB0d8c:0008" "" ""
Hardware is initialized using a generic method

root@stn1010:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Device [C-Media USB Audio Device], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

Here are the results from a PC node (1000):

root@stn100:~# alsactl init
Found hardware: "VIA8237" "VIA Technologies id 83" "AC97a:56494183"
"0x1106" "0xaa08"
Hardware is initialized using a generic method

root@stn100:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: V8237 [VIA 8237], device 0: VIA 8237 [VIA 8237]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 0: V8237 [VIA 8237], device 1: VIA 8237 [VIA 8237]
Subdevices: 1/1
Subdevice #0: subdevice #0



David Cameron


On 2020-09-09 7:21 a.m., kd1yh wrote:
FG-UAUDVI-C119 Sound dongle
It does seem to see this on boot up when internal bios is turned off . is there a get file to fix?
export USE_AOSS=YES
export USE_APLAY=YES
*From:* kd1yh
*Sent:* Tuesday, September 01, 2020 8:10 PM
*To:* IRLP@irlp.groups.io
*Subject:* Re: [IRLP] How do I change or force the HP T5730 to use the dongle?
I tried to shut off in bios nothing worked.
It is the voice coming from the internet that is garbled.
Have to find where how to blacklist in boot configure file.
When I talk it is fine but when others come back it is garbled.
Paul KD1YH 8581
*From:* David Cameron - IRLP
*Sent:* Tuesday, September 01, 2020 10:41 AM
*To:* IRLP@irlp.groups.io
*Subject:* Re: [IRLP] How do I change or force the HP T5730 to use the dongle?
You need to turn off the onboard sound device in the bios. If that doesn't work, you need to blacklist the module in linux.
Is the irlp audio garbled, or are the transmitted messages garbled? It could be that you don't have USE_AOSS=YES and USE_APLAY=YES set in the environment file.
Dave Cameron
-------- Original message --------
From: kd1yh <kd1yh@...>
Date: 9/1/20 2:28 AM (GMT-08:00)
To: IRLP@irlp.groups.io
Subject: [IRLP] How do I change or force the HP T5730 to use the dongle?
HP t5730 to FG-UAUDVI-C119 Sound dongle
I try to use Alsamixer to use the dongle, but it won’t cannot save to use.
Where do I find in boot configure to correct?
My Audio is garbled coming from the internet and think internal sound is bad.
Paul node 8581


David Cameron - IRLP
 

You have to determine what module is being used first. Use the command

lsmod

to list the modules. There will be one called snd, with all the associated modules loaded:

snd_pcm_oss 45056 0
snd_mixer_oss 24576 1 snd_pcm_oss
snd_pcm 81920 3 snd_pcm_oss,snd_via82xx,snd_ac97_codec
snd_timer 28672 2 snd_seq,snd_pcm
snd 61440 10 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_via82xx,snd_ac97_codec,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device,snd_pcm
soundcore 16384 1 snd

The ones here that jump out at me are snd_via82xx and snd_ac97_codec. In order to blacklist them, I make a file called:

/etc/modprobe.d/my-blacklist.conf

and in it put something like

# Blacklists the via sound module
blacklist snd_via82xx
blacklist snd_ac97_codec

You may have to try to blacklist some others to get it right. Be careful what you blacklist, as if you do something like blacklist the USB controller, your keyboard wont work, etc.

Alternately, you can also set the USB sound card as the FIRST card, and demote the others. Make a file called:

/etc/modprobe.d/my-usb-first.conf

# Keep snd-usb-audio loaded as first soundcard
options snd-usb-audio index=0
# Demotes other sound cards below it
options snd_via82xx index=-2
options snd_ac97_codec index=-2

Dave Cameron

On 2020-09-09 9:49 a.m., kd1yh wrote:
where do you black list it?
root@stn8581:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC262 Analog [ALC262 Analog]
 Subdevices: 1/1
 Subdevice #0: subdevice #0
card 1: Device [C-Media USB Audio Device], device 0: USB Audio [USB Audio]
 Subdevices: 1/1
 Subdevice #0: subdevice #0
root@stn8581:~# alsactl init
Found hardware: "HDA-Intel" "Realtek ALC262" "HDA:10ec0262,103c302f,00100202" "0x103c" "0x302f"
Hardware is initialized using a generic method
root@stn8581:~# alsactl init 1
Found hardware: "USB-Audio" "USB Mixer" "USB0d8c:0008" "" ""
Hardware is initialized using a generic method
root@stn8581:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC262 Analog [ALC262 Analog]
 Subdevices: 1/1
 Subdevice #0: subdevice #0
card 1: Device [C-Media USB Audio Device], device 0: USB Audio [USB Audio]
 Subdevices: 1/1
 Subdevice #0: subdevice #0
root@stn8581:~#
-----Original Message----- From: David Cameron - IRLP
Sent: Wednesday, September 09, 2020 12:06 PM
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] How do I change or force the HP T5730 to use the dongle?
After booting, have a look for the sound module loaded in the
/var/log/kern.log file. Then you can blacklist it, and/or force the USB
sound card to be primary. You want the USB card to show as "card 0".
Some other tools are:
alsactl init
aplay -l
Here is the result from a Pi node (1010):
root@stn1010:~# alsactl init
Found hardware: "USB-Audio" "USB Mixer" "USB0d8c:0008" "" ""
Hardware is initialized using a generic method
root@stn1010:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Device [C-Media USB Audio Device], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Here are the results from a PC node (1000):
root@stn100:~# alsactl init
Found hardware: "VIA8237" "VIA Technologies id 83" "AC97a:56494183"
"0x1106" "0xaa08"
Hardware is initialized using a generic method
root@stn100:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: V8237 [VIA 8237], device 0: VIA 8237 [VIA 8237]
  Subdevices: 4/4
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
card 0: V8237 [VIA 8237], device 1: VIA 8237 [VIA 8237]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
David Cameron
On 2020-09-09 7:21 a.m., kd1yh wrote:
FG-UAUDVI-C119 Sound dongle
It does seem to see this on boot up when internal bios is turned off
. is there a get file to fix?
export USE_AOSS=YES
export USE_APLAY=YES
*From:* kd1yh
*Sent:* Tuesday, September 01, 2020 8:10 PM
*To:* IRLP@irlp.groups.io
*Subject:* Re: [IRLP] How do I change or force the HP T5730 to use the dongle?
I tried to shut off in bios nothing worked.
It is the voice coming from the internet that is garbled.
Have to find where how to blacklist in boot configure file.
When I talk it is fine but when others come back it is garbled.
Paul KD1YH 8581
*From:* David Cameron - IRLP
*Sent:* Tuesday, September 01, 2020 10:41 AM
*To:* IRLP@irlp.groups.io
*Subject:* Re: [IRLP] How do I change or force the HP T5730 to use the dongle?
You need to turn off the onboard sound device in the bios. If that doesn't work, you need to blacklist the module in linux.
Is the irlp audio garbled, or are the transmitted messages garbled? It could be that you don't have USE_AOSS=YES and USE_APLAY=YES set in the environment file.
Dave Cameron
-------- Original message --------
From: kd1yh <kd1yh@...>
Date: 9/1/20 2:28 AM (GMT-08:00)
To: IRLP@irlp.groups.io
Subject: [IRLP] How do I change or force the HP T5730 to use the dongle?
HP t5730  to FG-UAUDVI-C119 Sound dongle
I try to use Alsamixer to use the dongle, but it won’t cannot save to use.
Where do  I find in boot configure to correct?
My Audio is garbled coming from the internet and think internal sound is bad.
Paul node 8581


kd1yh
 

root@stn8581:~# lsmod
Module Size Used by
brd 16384 0
radeon 1359872 1
snd_hda_codec_realtek 86016 1
snd_hda_codec_generic 65536 1 snd_hda_codec_realtek
snd_usb_audio 155648 0
snd_hda_intel 32768 0
ppdev 20480 6
ttm 86016 1 radeon
snd_hda_codec 94208 3 snd_hda_intel,snd_hda_codec_generic,snd_hda_codec_realtek
snd_usbmidi_lib 24576 1 snd_usb_audio
drm_kms_helper 135168 1 radeon
snd_rawmidi 24576 1 snd_usbmidi_lib
snd_hda_core 57344 4 snd_hda_intel,snd_hda_codec,snd_hda_codec_generic,snd_hda_codec_realtek
snd_seq_device 16384 1 snd_rawmidi
snd_hwdep 16384 2 snd_hda_codec,snd_usb_audio
snd_pcm 81920 4 snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_hda_core
edac_mce_amd 28672 0
drm 323584 4 radeon,ttm,drm_kms_helper
snd_timer 28672 1 snd_pcm
pcspkr 16384 0
serio_raw 16384 0
k8temp 16384 0
evdev 20480 3
snd 61440 11 snd_hda_intel,snd_hwdep,snd_hda_codec,snd_usb_audio,snd_timer,snd_rawmidi,snd_hda_codec_generic,snd_usbmidi_lib,snd_seq_device,snd_hda_codec_realtek,snd_pcm
soundcore 16384 1 snd
sg 28672 0
i2c_algo_bit 16384 1 radeon
sp5100_tco 16384 0
parport_pc 28672 3
parport 40960 2 parport_pc,ppdev
button 16384 0
ip_tables 20480 0
x_tables 24576 1 ip_tables
autofs4 36864 2
ext4 532480 1
crc16 16384 1 ext4
mbcache 16384 1 ext4
jbd2 86016 1 ext4
crc32c_generic 16384 2
fscrypto 24576 1 ext4
ecb 16384 0
crypto_simd 16384 0
cryptd 20480 1 crypto_simd
aes_i586 20480 0
hid_generic 16384 0
usbhid 45056 0
hid 102400 2 hid_generic,usbhid
sd_mod 49152 3
ata_generic 16384 0
pata_atiixp 16384 2
libata 192512 2 pata_atiixp,ata_generic
ohci_pci 16384 0
tg3 159744 0
ehci_pci 16384 0
ohci_hcd 45056 1 ohci_pci
scsi_mod 172032 3 sd_mod,libata,sg
ehci_hcd 65536 1 ehci_pci
psmouse 126976 0
usbcore 188416 7 usbhid,snd_usb_audio,ehci_hcd,ohci_pci,snd_usbmidi_lib,ohci_hcd,ehci_pci
libphy 45056 1 tg3
ptp 20480 1 tg3
pps_core 16384 1 ptp
i2c_piix4 24576 0
usb_common 16384 1 usbcore
thermal 20480 0
root@stn8581:~#

-----Original Message-----
From: David Cameron - IRLP
Sent: Wednesday, September 09, 2020 1:29 PM
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] How do I change or force the HP T5730 to use the dongle?

You have to determine what module is being used first. Use the command

lsmod

to list the modules. There will be one called snd, with all the
associated modules loaded:

snd_pcm_oss 45056 0
snd_mixer_oss 24576 1 snd_pcm_oss
snd_pcm 81920 3 snd_pcm_oss,snd_via82xx,snd_ac97_codec
snd_timer 28672 2 snd_seq,snd_pcm
snd 61440 10
snd_pcm_oss,snd_mixer_oss,snd_seq,snd_via82xx,snd_ac97_codec,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device,snd_pcm
soundcore 16384 1 snd

The ones here that jump out at me are snd_via82xx and snd_ac97_codec. In
order to blacklist them, I make a file called:

/etc/modprobe.d/my-blacklist.conf

and in it put something like

# Blacklists the via sound module
blacklist snd_via82xx
blacklist snd_ac97_codec

You may have to try to blacklist some others to get it right. Be careful
what you blacklist, as if you do something like blacklist the USB
controller, your keyboard wont work, etc.

Alternately, you can also set the USB sound card as the FIRST card, and
demote the others. Make a file called:

/etc/modprobe.d/my-usb-first.conf

# Keep snd-usb-audio loaded as first soundcard
options snd-usb-audio index=0
# Demotes other sound cards below it
options snd_via82xx index=-2
options snd_ac97_codec index=-2

Dave Cameron






On 2020-09-09 9:49 a.m., kd1yh wrote:
where do you black list it?
root@stn8581:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC262 Analog [ALC262 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Device [C-Media USB Audio Device], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
root@stn8581:~# alsactl init
Found hardware: "HDA-Intel" "Realtek ALC262" "HDA:10ec0262,103c302f,00100202" "0x103c" "0x302f"
Hardware is initialized using a generic method
root@stn8581:~# alsactl init 1
Found hardware: "USB-Audio" "USB Mixer" "USB0d8c:0008" "" ""
Hardware is initialized using a generic method
root@stn8581:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC262 Analog [ALC262 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Device [C-Media USB Audio Device], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
root@stn8581:~#

-----Original Message----- From: David Cameron - IRLP
Sent: Wednesday, September 09, 2020 12:06 PM
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] How do I change or force the HP T5730 to use the dongle?

After booting, have a look for the sound module loaded in the
/var/log/kern.log file. Then you can blacklist it, and/or force the USB
sound card to be primary. You want the USB card to show as "card 0".

Some other tools are:
alsactl init
aplay -l

Here is the result from a Pi node (1010):

root@stn1010:~# alsactl init
Found hardware: "USB-Audio" "USB Mixer" "USB0d8c:0008" "" ""
Hardware is initialized using a generic method

root@stn1010:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Device [C-Media USB Audio Device], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

Here are the results from a PC node (1000):

root@stn100:~# alsactl init
Found hardware: "VIA8237" "VIA Technologies id 83" "AC97a:56494183"
"0x1106" "0xaa08"
Hardware is initialized using a generic method

root@stn100:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: V8237 [VIA 8237], device 0: VIA 8237 [VIA 8237]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 0: V8237 [VIA 8237], device 1: VIA 8237 [VIA 8237]
Subdevices: 1/1
Subdevice #0: subdevice #0



David Cameron


On 2020-09-09 7:21 a.m., kd1yh wrote:
FG-UAUDVI-C119 Sound dongle
It does seem to see this on boot up when internal bios is turned off
. is there a get file to fix?
export USE_AOSS=YES
export USE_APLAY=YES
*From:* kd1yh
*Sent:* Tuesday, September 01, 2020 8:10 PM
*To:* IRLP@irlp.groups.io
*Subject:* Re: [IRLP] How do I change or force the HP T5730 to use the dongle?
I tried to shut off in bios nothing worked.
It is the voice coming from the internet that is garbled.
Have to find where how to blacklist in boot configure file.
When I talk it is fine but when others come back it is garbled.
Paul KD1YH 8581
*From:* David Cameron - IRLP
*Sent:* Tuesday, September 01, 2020 10:41 AM
*To:* IRLP@irlp.groups.io
*Subject:* Re: [IRLP] How do I change or force the HP T5730 to use the dongle?
You need to turn off the onboard sound device in the bios. If that doesn't work, you need to blacklist the module in linux.
Is the irlp audio garbled, or are the transmitted messages garbled? It could be that you don't have USE_AOSS=YES and USE_APLAY=YES set in the environment file.
Dave Cameron
-------- Original message --------
From: kd1yh <kd1yh@...>
Date: 9/1/20 2:28 AM (GMT-08:00)
To: IRLP@irlp.groups.io
Subject: [IRLP] How do I change or force the HP T5730 to use the dongle?
HP t5730 to FG-UAUDVI-C119 Sound dongle
I try to use Alsamixer to use the dongle, but it won’t cannot save to use.
Where do I find in boot configure to correct?
My Audio is garbled coming from the internet and think internal sound is bad.
Paul node 8581




David Cameron - IRLP
 

Start blacklisting snd_hda_???? modules until the sound card is no longer seen in alsactl init.

Dave Cameron

On 2020-09-09 5:15 p.m., kd1yh wrote:
root@stn8581:~# lsmod
Module                  Size  Used by
brd                    16384  0
radeon               1359872  1
snd_hda_codec_realtek    86016  1
snd_hda_codec_generic    65536  1 snd_hda_codec_realtek
snd_usb_audio         155648  0
snd_hda_intel          32768  0
ppdev                  20480  6
ttm                    86016  1 radeon
snd_hda_codec          94208  3 snd_hda_intel,snd_hda_codec_generic,snd_hda_codec_realtek
snd_usbmidi_lib        24576  1 snd_usb_audio
drm_kms_helper        135168  1 radeon
snd_rawmidi            24576  1 snd_usbmidi_lib
snd_hda_core           57344  4 snd_hda_intel,snd_hda_codec,snd_hda_codec_generic,snd_hda_codec_realtek
snd_seq_device         16384  1 snd_rawmidi
snd_hwdep              16384  2 snd_hda_codec,snd_usb_audio
snd_pcm                81920  4 snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_hda_core
edac_mce_amd           28672  0
drm                   323584  4 radeon,ttm,drm_kms_helper
snd_timer              28672  1 snd_pcm
pcspkr                 16384  0
serio_raw              16384  0
k8temp                 16384  0
evdev                  20480  3
snd                    61440  11 snd_hda_intel,snd_hwdep,snd_hda_codec,snd_usb_audio,snd_timer,snd_rawmidi,snd_hda_codec_generic,snd_usbmidi_lib,snd_seq_device,snd_hda_codec_realtek,snd_pcm soundcore              16384  1 snd
sg                     28672  0
i2c_algo_bit           16384  1 radeon
sp5100_tco             16384  0
parport_pc             28672  3
parport                40960  2 parport_pc,ppdev
button                 16384  0
ip_tables              20480  0
x_tables               24576  1 ip_tables
autofs4                36864  2
ext4                  532480  1
crc16                  16384  1 ext4
mbcache                16384  1 ext4
jbd2                   86016  1 ext4
crc32c_generic         16384  2
fscrypto               24576  1 ext4
ecb                    16384  0
crypto_simd            16384  0
cryptd                 20480  1 crypto_simd
aes_i586               20480  0
hid_generic            16384  0
usbhid                 45056  0
hid                   102400  2 hid_generic,usbhid
sd_mod                 49152  3
ata_generic            16384  0
pata_atiixp            16384  2
libata                192512  2 pata_atiixp,ata_generic
ohci_pci               16384  0
tg3                   159744  0
ehci_pci               16384  0
ohci_hcd               45056  1 ohci_pci
scsi_mod              172032  3 sd_mod,libata,sg
ehci_hcd               65536  1 ehci_pci
psmouse               126976  0
usbcore               188416  7 usbhid,snd_usb_audio,ehci_hcd,ohci_pci,snd_usbmidi_lib,ohci_hcd,ehci_pci
libphy                 45056  1 tg3
ptp                    20480  1 tg3
pps_core               16384  1 ptp
i2c_piix4              24576  0
usb_common             16384  1 usbcore
thermal                20480  0
root@stn8581:~#
-----Original Message----- From: David Cameron - IRLP
Sent: Wednesday, September 09, 2020 1:29 PM
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] How do I change or force the HP T5730 to use the dongle?
You have to determine what module is being used first. Use the command
lsmod
to list the modules. There will be one called snd, with all the
associated modules loaded:
snd_pcm_oss            45056  0
snd_mixer_oss          24576  1 snd_pcm_oss
snd_pcm                81920  3 snd_pcm_oss,snd_via82xx,snd_ac97_codec
snd_timer              28672  2 snd_seq,snd_pcm
snd                    61440  10
snd_pcm_oss,snd_mixer_oss,snd_seq,snd_via82xx,snd_ac97_codec,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device,snd_pcm soundcore              16384  1 snd
The ones here that jump out at me are snd_via82xx and snd_ac97_codec. In
order to blacklist them, I make a file called:
/etc/modprobe.d/my-blacklist.conf
and in it put something like
# Blacklists the via sound module
blacklist snd_via82xx
blacklist snd_ac97_codec
You may have to try to blacklist some others to get it right. Be careful
what you blacklist, as if you do something like blacklist the USB
controller, your keyboard wont work, etc.
Alternately, you can also set the USB sound card as the FIRST card, and
demote the others. Make a file called:
/etc/modprobe.d/my-usb-first.conf
# Keep snd-usb-audio loaded as first soundcard
options snd-usb-audio index=0
# Demotes other sound cards below it
options snd_via82xx index=-2
options snd_ac97_codec index=-2
Dave Cameron
On 2020-09-09 9:49 a.m., kd1yh wrote:
where do you black list it?
root@stn8581:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC262 Analog [ALC262 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Device [C-Media USB Audio Device], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
root@stn8581:~# alsactl init
Found hardware: "HDA-Intel" "Realtek ALC262" "HDA:10ec0262,103c302f,00100202" "0x103c" "0x302f"
Hardware is initialized using a generic method
root@stn8581:~# alsactl init 1
Found hardware: "USB-Audio" "USB Mixer" "USB0d8c:0008" "" ""
Hardware is initialized using a generic method
root@stn8581:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC262 Analog [ALC262 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Device [C-Media USB Audio Device], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
root@stn8581:~#

-----Original Message----- From: David Cameron - IRLP
Sent: Wednesday, September 09, 2020 12:06 PM
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] How do I change or force the HP T5730 to use the dongle?

After booting, have a look for the sound module loaded in the
/var/log/kern.log file. Then you can blacklist it, and/or force the USB
sound card to be primary. You want the USB card to show as "card 0".

Some other tools are:
alsactl init
aplay -l

Here is the result from a Pi node (1010):

root@stn1010:~# alsactl init
Found hardware: "USB-Audio" "USB Mixer" "USB0d8c:0008" "" ""
Hardware is initialized using a generic method

root@stn1010:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Device [C-Media USB Audio Device], device 0: USB Audio [USB Audio]
   Subdevices: 1/1
   Subdevice #0: subdevice #0

Here are the results from a PC node (1000):

root@stn100:~# alsactl init
Found hardware: "VIA8237" "VIA Technologies id 83" "AC97a:56494183"
"0x1106" "0xaa08"
Hardware is initialized using a generic method

root@stn100:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: V8237 [VIA 8237], device 0: VIA 8237 [VIA 8237]
   Subdevices: 4/4
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
   Subdevice #2: subdevice #2
   Subdevice #3: subdevice #3
card 0: V8237 [VIA 8237], device 1: VIA 8237 [VIA 8237]
   Subdevices: 1/1
   Subdevice #0: subdevice #0



David Cameron


On 2020-09-09 7:21 a.m., kd1yh wrote:
FG-UAUDVI-C119 Sound dongle
It does seem to see this on boot up when internal bios is turned off
. is there a get file to fix?
export USE_AOSS=YES
export USE_APLAY=YES
*From:* kd1yh
*Sent:* Tuesday, September 01, 2020 8:10 PM
*To:* IRLP@irlp.groups.io
*Subject:* Re: [IRLP] How do I change or force the HP T5730 to use the dongle?
I tried to shut off in bios nothing worked.
It is the voice coming from the internet that is garbled.
Have to find where how to blacklist in boot configure file.
When I talk it is fine but when others come back it is garbled.
Paul KD1YH 8581
*From:* David Cameron - IRLP
*Sent:* Tuesday, September 01, 2020 10:41 AM
*To:* IRLP@irlp.groups.io
*Subject:* Re: [IRLP] How do I change or force the HP T5730 to use the dongle?
You need to turn off the onboard sound device in the bios. If that doesn't work, you need to blacklist the module in linux.
Is the irlp audio garbled, or are the transmitted messages garbled? It could be that you don't have USE_AOSS=YES and USE_APLAY=YES set in the environment file.
Dave Cameron
-------- Original message --------
From: kd1yh <kd1yh@...>
Date: 9/1/20 2:28 AM (GMT-08:00)
To: IRLP@irlp.groups.io
Subject: [IRLP] How do I change or force the HP T5730 to use the dongle?
HP t5730  to FG-UAUDVI-C119 Sound dongle
I try to use Alsamixer to use the dongle, but it won’t cannot save to use.
Where do  I find in boot configure to correct?
My Audio is garbled coming from the internet and think internal sound is bad.
Paul node 8581