IRLPvCon version error


K1IMD
 

Evening all,

I am running IRLP on RPi SDCard was created by VE7LTD running wheezy and every year I create a new copy from an image I keep ready.  I also keep a spare on site BUT the site is 1800 miles from home.

I use the node to remotely control a radio at the remote site and partcipate in the local nets.  Last week it worked perfectly this week it does not.  IRLPvCon is only needed to help confirm what channel the radio is on and if the channel is active so I do cause QRM.

On the IRLPvCon window I get this message:
### irlpvcon_put Program Version Does Not Match This Program.
### Install Correct Version "vCON 4.00" Of irlpvcon_put.

The version of vCon IS version 4.0.   Was there some sort of update that broke the older nodes?

Since it will be a few months before I get to the site, I would like to get it working again.  Any assistance would be appreciated.  The RPi can still be accessed with ssh with no issue noted.  I have tried a warm reboot and a power shutdown and restart neither seemed to make any difference.

73
Jon
K1IMD


David Cameron - IRLP
 

No updates have been done to the system. The author is a SK and nobody has the code.

I would check for corruption on your SD card, and possibly reinstall IRLPvCON to try to solve the issue.

Dave Cameron

On 2021-06-08 6:21 p.m., K1IMD wrote:
Evening all,
I am running IRLP on RPi SDCard was created by VE7LTD running wheezy and every year I create a new copy from an image I keep ready.  I also keep a spare on site BUT the site is 1800 miles from home.
I use the node to remotely control a radio at the remote site and partcipate in the local nets.  Last week it worked perfectly this week it does not.  IRLPvCon is only needed to help confirm what channel the radio is on and if the channel is active so I do cause QRM.
On the IRLPvCon window I get this message:
### irlpvcon_put Program Version Does Not Match This Program.
### Install Correct Version "vCON 4.00" Of irlpvcon_put.
The version of vCon IS version 4.0.   Was there some sort of update that broke the older nodes?
Since it will be a few months before I get to the site, I would like to get it working again.  Any assistance would be appreciated.  The RPi can still be accessed with ssh with no issue noted.  I have tried a warm reboot and a power shutdown and restart neither seemed to make any difference.
73
Jon
K1IMD


K1IMD
 

HI Dave,
I looked and did not see any updates either but was just checking.  The good thing is I believe the node is still operating OK it is just IRLPvxxx that is broken.  But if there is some sort of corruption eventually the node too will die.  Not likely to be able to fix anything without a site visit in the fall. 

This is a RPi node with patches by you to make IRLPvxxx run I believe so their is no "install" for that is there?

I really need to upgrade it to Buster from Wheezy anyway.  Although I still have a couple CentOS IRLP 4.06 running on hardware that can't run anything newer.

I suspect that you are right the card is corrupted.

Thanks Dave
73
Jon
K1IMD


On 6/9/2021 12:19, David Cameron - IRLP wrote:
No updates have been done to the system. The author is a SK and nobody has the code.

I would check for corruption on your SD card, and possibly reinstall IRLPvCON to try to solve the issue.

Dave Cameron

On 2021-06-08 6:21 p.m., K1IMD wrote:
Evening all,

I am running IRLP on RPi SDCard was created by VE7LTD running wheezy and every year I create a new copy from an image I keep ready.  I also keep a spare on site BUT the site is 1800 miles from home.

I use the node to remotely control a radio at the remote site and partcipate in the local nets.  Last week it worked perfectly this week it does not.  IRLPvCon is only needed to help confirm what channel the radio is on and if the channel is active so I do cause QRM.

On the IRLPvCon window I get this message:
### irlpvcon_put Program Version Does Not Match This Program.
### Install Correct Version "vCON 4.00" Of irlpvcon_put.

The version of vCon IS version 4.0.   Was there some sort of update that broke the older nodes?

Since it will be a few months before I get to the site, I would like to get it working again.  Any assistance would be appreciated.  The RPi can still be accessed with ssh with no issue noted.  I have tried a warm reboot and a power shutdown and restart neither seemed to make any difference.

73
Jon
K1IMD














David Cameron - IRLP
 

You can try just running the irlpvcon binaries it is complaining about by hand. They are mainly perl scripts, and the only compiled binary has been replaced with a version for the Pi (the one that reads the parallel/GPIO port).

Dave Cameron

On 2021-06-09 10:17 a.m., K1IMD wrote:
HI Dave,
I looked and did not see any updates either but was just checking. The good thing is I believe the node is still operating OK it is just IRLPvxxx that is broken.  But if there is some sort of corruption eventually the node too will die.  Not likely to be able to fix anything without a site visit in the fall.
This is a RPi node with patches by you to make IRLPvxxx run I believe so their is no "install" for that is there?
I really need to upgrade it to Buster from Wheezy anyway.  Although I still have a couple CentOS IRLP 4.06 running on hardware that can't run anything newer.
I suspect that you are right the card is corrupted.
Thanks Dave
73
Jon
K1IMD
On 6/9/2021 12:19, David Cameron - IRLP wrote:
No updates have been done to the system. The author is a SK and nobody has the code.

I would check for corruption on your SD card, and possibly reinstall IRLPvCON to try to solve the issue.

Dave Cameron

On 2021-06-08 6:21 p.m., K1IMD wrote:
Evening all,

I am running IRLP on RPi SDCard was created by VE7LTD running wheezy and every year I create a new copy from an image I keep ready.  I also keep a spare on site BUT the site is 1800 miles from home.

I use the node to remotely control a radio at the remote site and partcipate in the local nets.  Last week it worked perfectly this week it does not.  IRLPvCon is only needed to help confirm what channel the radio is on and if the channel is active so I do cause QRM.

On the IRLPvCon window I get this message:
### irlpvcon_put Program Version Does Not Match This Program.
### Install Correct Version "vCON 4.00" Of irlpvcon_put.

The version of vCon IS version 4.0.   Was there some sort of update that broke the older nodes?

Since it will be a few months before I get to the site, I would like to get it working again.  Any assistance would be appreciated.  The RPi can still be accessed with ssh with no issue noted.  I have tried a warm reboot and a power shutdown and restart neither seemed to make any difference.

73
Jon
K1IMD