Topics

loosing wifi on my node


Scott Anderson
 

Hi to the Group.
My node is sick. I have a node that I ordered from Dave C. number is 3247 it has been running great for months. The node is connected to a Raspberry pi 2 with a wifi adaptor. The software was Debian 9 stretch witch had a problem and I had to reinstall after the reinstall I lost the wifi. I did a new card with Debian 10 Buster the pi works just fine with the wifi adaptor before the IRLP software after the install and a reboot the wifi adaptor shuts off. I have done this a dozen times and dose the same thing. I have tried to go into raspi-config and reset the ssid and password but I get a message could not communicate with wpa_supplicant. I hope someone can help with this. Thanks Scott.


k9dc
 

Did you include all of your WiFi information directly in the /etc/network/interfaces file? You should have a stanza in it for interface wlan0 that looks something like this (if you are not using DHCP, yours may have static IP information as well)

auto wlan0
iface wlan0 inet dhcp
wpa-ssid Inside-230_nomap
wpa-psk 0000000000

We no longer support or use wicd-curses for WiFi information. In fact that package is removed when you run the command ./get-irlp-files. Which might explain why you lost wifi upon installation.

-k9dc

On Feb 15, 2020, at 17:55, Scott Anderson via Groups.Io <hemicougar70=yahoo.com@groups.io> wrote:

Hi to the Group.
My node is sick. I have a node that I ordered from Dave C. number is 3247 it has been running great for months. The node is connected to a Raspberry pi 2 with a wifi adaptor. The software was Debian 9 stretch witch had a problem and I had to reinstall after the reinstall I lost the wifi. I did a new card with Debian 10 Buster the pi works just fine with the wifi adaptor before the IRLP software after the install and a reboot the wifi adaptor shuts off. I have done this a dozen times and dose the same thing. I have tried to go into raspi-config and reset the ssid and password but I get a message could not communicate with wpa_supplicant. I hope someone can help with this. Thanks Scott.


Klaus Rung
 

This one is using the network wired interface only, not wifi so it is working well.

Thanks for the info.

On Feb 16, 2020, at 8:45 AM, k9dc <dave@...> wrote:

Did you include all of your WiFi information directly in the /etc/network/interfaces file? You should have a stanza in it for interface wlan0 that looks something like this (if you are not using DHCP, yours may have static IP information as well)

auto wlan0
iface wlan0 inet dhcp
wpa-ssid Inside-230_nomap
wpa-psk 0000000000

We no longer support or use wicd-curses for WiFi information. In fact that package is removed when you run the command ./get-irlp-files. Which might explain why you lost wifi upon installation.

-k9dc


On Feb 15, 2020, at 17:55, Scott Anderson via Groups.Io <hemicougar70=yahoo.com@groups.io> wrote:

Hi to the Group.
My node is sick. I have a node that I ordered from Dave C. number is 3247 it has been running great for months. The node is connected to a Raspberry pi 2 with a wifi adaptor. The software was Debian 9 stretch witch had a problem and I had to reinstall after the reinstall I lost the wifi. I did a new card with Debian 10 Buster the pi works just fine with the wifi adaptor before the IRLP software after the install and a reboot the wifi adaptor shuts off. I have done this a dozen times and dose the same thing. I have tried to go into raspi-config and reset the ssid and password but I get a message could not communicate with wpa_supplicant. I hope someone can help with this. Thanks Scott.






Klaus Rung
 

Sorry wrong email.

On Feb 16, 2020, at 12:30 PM, "Klaus Rung via Groups.Io" <yahoo.com@groups.io target=_blank>k_rung=yahoo.com@groups.io> wrote:
This one is using the network wired interface only, not wifi so it is working well.

Thanks for the info.

On Feb 16, 2020, at 8:45 AM, k9dc < dave@...> wrote:

Did you include all of your WiFi information directly in the /etc/network/interfaces file? You should have a stanza in it for interface wlan0 that looks something like this (if you are not using DHCP, yours may have static IP information as well)

auto wlan0
iface wlan0 inet dhcp
wpa-ssid Inside-230_nomap
wpa-psk 0000000000

We no longer support or use wicd-curses for WiFi information. In fact that package is removed when you run the command ./get-irlp-files. Which might explain why you lost wifi upon installation.

-k9dc


On Feb 15, 2020, at 17:55, Scott Anderson via Groups.Io <hemicougar70= yahoo.com@groups.io> wrote:

Hi to the Group.
My node is sick. I have a node that I ordered from Dave C. number is 3247 it has been running great for months. The node is connected to a Raspberry pi 2 with a wifi adaptor. The software was Debian 9 stretch witch had a problem and I had to reinstall after the reinstall I lost the wifi. I did a new card with Debian 10 Buster the pi works just fine with the wifi adaptor before the IRLP software after the install and a reboot the wifi adaptor shuts off. I have done this a dozen times and dose the same thing. I have tried to go into raspi-config and reset the ssid and password but I get a message could not communicate with wpa_supplicant. I hope someone can help with this. Thanks Scott.






Scott Anderson
 

Thanks David, I tried to put in the ssid and psk in the etc/network/interfaces. The network adaptor dose not turn on. By the way the ssid and psk were not in there.
Thanks Scott.


Scott Anderson
 

I can get the network adaptor to turn on by entering this sudo wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -d 
it turns on right away. I do not know what this means. I hope this helps to figure out might be the problem.
Thanks Scott


Nosey Nick VA3NNW
 

Scott Anderson via Groups.Io wrote:
I can get the network adaptor to turn on by entering this sudo
wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -d 
it turns on right away. I do not know what this means. I hope this
helps to figure out might be the problem.
My /etc/network/interfaces includes:

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

... which does indeed start wpa_supplicant [...] -i wlan0 [...] -c
/etc/wpa_supplicant/wpa_supplicant.conf, which strongly resembles your
above cmdline.

NN

--
"Nosey" Nick Waterman, VA3NNW/G7RZQ, K2 #5209.
use Std::Disclaimer; sig@...
This place is so weird that the cockroaches have moved next door.


Scott Anderson
 

Thanks Nick, that got the network adaptor to turn on but i still can not get the ip address and the router dose not find the node . 
Thanks Scott.


Scott Anderson
 

I forgot to add at boot it has a txt that s says FAILED Failed to start Rise network interfaces .


Scott Anderson
 

Ok it appears that the network adaptor is now working but now the ssh is not.
Thanks Scott.