Topics

Node Time Out

Albert Febraro
 

Can I get an explanation on how to disable the node time out timer in the software?  My node disconnects from other nodes and reflectors after approximately  thirty minutes of being idle.  I understand that the environment file has to updated. How can I get to that directory and file after log in from Putty. And then what value needs to be changed?  
Thank you and 73,
Al
W6AAX

k9dc
 

There are two inactivity timeouts. One for node to node, the other for Reflector calls. Default values are 240 seconds and 1200 seconds respectively. Node to node is set in the file custom/timeoutvalue. The reflector timeout is set in the environment file.

export REFLECT_TIMEOUT_VALUE=43200

Set it to the value you want. Although I would NOT suggest disabling it completely, rather set it to a value long enough for your requirements.

An even better option is if you have a particular reflector you hang out on and want that destination to never time out. Simply add an entry in custom_decode such that a particular destination is configured with the “notimeout" flag set, to not time out.

For example, I have three reflectors set to not time out, all others time out normally. custom/custom_decode entries below.

if [ "$1" = "9200" ] ; then "$SCRIPT"/connect_to_reflector ref9200 notimeout ; exit 1 ; fi
if [ "$1" = "9600" ] ; then "$SCRIPT"/connect_to_reflector ref9600 notimeout ; exit 1 ; fi
if [ "$1" = "9735" ] ; then "$SCRIPT"/connect_to_reflector ref9735 notimeout ; exit 1 ; fi


pico -w custom/custom_decode
pico -w custom/environment

You need to be root to edit the environment file. Just be very careful, a single keystroke mistake can render your node totally inoperative.

-k9dc

On Apr 30, 2020, at 12:19, Albert Febraro <w6aax@...> wrote:

Can I get an explanation on how to disable the node time out timer in the software? My node disconnects from other nodes and reflectors after approximately thirty minutes of being idle. I understand that the environment file has to updated. How can I get to that directory and file after log in from Putty. And then what value needs to be changed?
Thank you and 73,
Al
W6AAX

Albert Febraro
 

Thank you
I’ll go the route where I will leave the default time out for nodes and disable the time out for reflectors.
Al

On Apr 30, 2020, at 9:41 AM, k9dc <Dave@...> wrote:


There are two inactivity timeouts. One for node to node, the other for Reflector calls. Default values are 240 seconds and 1200 seconds respectively. Node to node is set in the file custom/timeoutvalue. The reflector timeout is set in the environment file.

export REFLECT_TIMEOUT_VALUE=43200

Set it to the value you want. Although I would NOT suggest disabling it completely, rather set it to a value long enough for your requirements.

An even better option is if you have a particular reflector you hang out on and want that destination to never time out. Simply add an entry in custom_decode such that a particular destination is configured with the “notimeout" flag set, to not time out.

For example, I have three reflectors set to not time out, all others time out normally. custom/custom_decode entries below.

if [ "$1" = "9200" ] ; then "$SCRIPT"/connect_to_reflector ref9200 notimeout ; exit 1 ; fi
if [ "$1" = "9600" ] ; then "$SCRIPT"/connect_to_reflector ref9600 notimeout ; exit 1 ; fi
if [ "$1" = "9735" ] ; then "$SCRIPT"/connect_to_reflector ref9735 notimeout ; exit 1 ; fi


pico -w custom/custom_decode
pico -w custom/environment

You need to be root to edit the environment file. Just be very careful, a single keystroke mistake can render your node totally inoperative.

-k9dc


On Apr 30, 2020, at 12:19, Albert Febraro <w6aax@...> wrote:

Can I get an explanation on how to disable the node time out timer in the software? My node disconnects from other nodes and reflectors after approximately thirty minutes of being idle. I understand that the environment file has to updated. How can I get to that directory and file after log in from Putty. And then what value needs to be changed?
Thank you and 73,
Al
W6AAX



Albert Febraro
 

I want to thank everyone who responded to my question on node timeout.
I was able to edit the file for Repeater timeout in Environment, using Putty,  however when I  try to save the change using ^O in Nano editor I get the message: "Error writing custom/environment: Permission denied"  I'm wondering if I have to save this change in some other fashion.
Al
W6AAX


From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> on behalf of Albert Febraro <w6aax@...>
Sent: Thursday, April 30, 2020 10:14 AM
To: IRLP@irlp.groups.io <IRLP@irlp.groups.io>
Subject: Re: [IRLP] Node Time Out
 
Thank you
I’ll go the route where I will leave the default time out  for nodes and disable the time out for reflectors.
Al
> On Apr 30, 2020, at 9:41 AM, k9dc <Dave@...> wrote:
>
> 
> There are two inactivity timeouts. One for node to node, the other for Reflector calls.  Default values are 240 seconds and 1200 seconds respectively.  Node to node is set in the file custom/timeoutvalue. The reflector timeout is set in the environment file.
>
> export REFLECT_TIMEOUT_VALUE=43200
>
> Set it to the value you want. Although I would NOT suggest disabling it completely, rather set it to a value long enough for your requirements. 
>
> An even better option is if you have a particular reflector you hang out on and want that destination to never time out. Simply add an entry in custom_decode such that a particular destination is configured with the “notimeout" flag set, to not time out.
>
> For example, I have three reflectors set to not time out, all others time out normally. custom/custom_decode entries below.
>
> if [ "$1" = "9200" ] ; then "$SCRIPT"/connect_to_reflector ref9200 notimeout ; exit 1 ; fi
> if [ "$1" = "9600" ] ; then "$SCRIPT"/connect_to_reflector ref9600 notimeout ; exit 1 ; fi
> if [ "$1" = "9735" ] ; then "$SCRIPT"/connect_to_reflector ref9735 notimeout ; exit 1 ; fi
>
>
> pico -w custom/custom_decode
> pico -w custom/environment
>
> You need to be root to edit the environment file.  Just be very careful, a single keystroke mistake can render your node totally inoperative. 
>
> -k9dc
>
>
>> On Apr 30, 2020, at 12:19, Albert Febraro <w6aax@...> wrote:
>>
>> Can I get an explanation on how to disable the node time out timer in the software?  My node disconnects from other nodes and reflectors after approximately  thirty minutes of being idle.  I understand that the environment file has to updated. How can I get to that directory and file after log in from Putty. And then what value needs to be changed? 
>> Thank you and 73,
>> Al
>> W6AAX
>
>
>
>
>



k9dc
 


As I said below, you must be root to edit the environment file.  

su  -
<password>
cd /home/irlp/custom
pico -w environment

-k9dc

On May 5, 2020, at 19:09, Albert Febraro <w6aax@...> wrote:


I want to thank everyone who responded to my question on node timeout.
I was able to edit the file for Repeater timeout in Environment, using Putty,  however when I  try to save the change using ^O in Nano editor I get the message: "Error writing custom/environment: Permission denied"  I'm wondering if I have to save this change in some other fashion.
Al
W6AAX


From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> on behalf of Albert Febraro <w6aax@...>
Sent: Thursday, April 30, 2020 10:14 AM
To: IRLP@irlp.groups.io <IRLP@irlp.groups.io>
Subject: Re: [IRLP] Node Time Out
 
Thank you
I’ll go the route where I will leave the default time out  for nodes and disable the time out for reflectors.
Al
> On Apr 30, 2020, at 9:41 AM, k9dc <Dave@...> wrote:
>
> 
> There are two inactivity timeouts. One for node to node, the other for Reflector calls.  Default values are 240 seconds and 1200 seconds respectively.  Node to node is set in the file custom/timeoutvalue. The reflector timeout is set in the environment file.
>
> export REFLECT_TIMEOUT_VALUE=43200
>
> Set it to the value you want. Although I would NOT suggest disabling it completely, rather set it to a value long enough for your requirements. 
>
> An even better option is if you have a particular reflector you hang out on and want that destination to never time out. Simply add an entry in custom_decode such that a particular destination is configured with the “notimeout" flag set, to not time out.
>
> For example, I have three reflectors set to not time out, all others time out normally. custom/custom_decode entries below.
>
> if [ "$1" = "9200" ] ; then "$SCRIPT"/connect_to_reflector ref9200 notimeout ; exit 1 ; fi
> if [ "$1" = "9600" ] ; then "$SCRIPT"/connect_to_reflector ref9600 notimeout ; exit 1 ; fi
> if [ "$1" = "9735" ] ; then "$SCRIPT"/connect_to_reflector ref9735 notimeout ; exit 1 ; fi
>
>
> pico -w custom/custom_decode
> pico -w custom/environment
>
> You need to be root to edit the environment file.  Just be very careful, a single keystroke mistake can render your node totally inoperative. 
>
> -k9dc
>
>
>> On Apr 30, 2020, at 12:19, Albert Febraro <w6aax@...> wrote:
>>
>> Can I get an explanation on how to disable the node time out timer in the software?  My node disconnects from other nodes and reflectors after approximately  thirty minutes of being idle.  I understand that the environment file has to updated. How can I get to that directory and file after log in from Putty. And then what value needs to be changed? 
>> Thank you and 73,
>> Al
>> W6AAX
>
>
>
>
>



Milt Duquette
 

Pico /home/irlp/custom/environment

Scroll down to:

# Sets the reflector timeout value in seconds
# If you do not want the reflectors to timeout at all, just enter 0
export REFLECTOR_TIMEOUT_VALUE=10200



Then you have exit. Ctrl x, it asks you to save  y for yes, hit enter and then ctrl x for exit and reboot modem. 10200 is 170 minutes that is what mine is set for long nets


On May 5, 2020, at 5:56 PM, k9dc <Dave@...> wrote:


As I said below, you must be root to edit the environment file.  

su  -
<password>
cd /home/irlp/custom
pico -w environment

-k9dc

On May 5, 2020, at 19:09, Albert Febraro <w6aax@...> wrote:


I want to thank everyone who responded to my question on node timeout.
I was able to edit the file for Repeater timeout in Environment, using Putty,  however when I  try to save the change using ^O in Nano editor I get the message: "Error writing custom/environment: Permission denied"  I'm wondering if I have to save this change in some other fashion.
Al
W6AAX


From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> on behalf of Albert Febraro <w6aax@...>
Sent: Thursday, April 30, 2020 10:14 AM
To: IRLP@irlp.groups.io <IRLP@irlp.groups.io>
Subject: Re: [IRLP] Node Time Out
 
Thank you
I’ll go the route where I will leave the default time out  for nodes and disable the time out for reflectors.
Al
> On Apr 30, 2020, at 9:41 AM, k9dc <Dave@...> wrote:
>
> 
> There are two inactivity timeouts. One for node to node, the other for Reflector calls.  Default values are 240 seconds and 1200 seconds respectively.  Node to node is set in the file custom/timeoutvalue. The reflector timeout is set in the environment file.
>
> export REFLECT_TIMEOUT_VALUE=43200
>
> Set it to the value you want. Although I would NOT suggest disabling it completely, rather set it to a value long enough for your requirements. 
>
> An even better option is if you have a particular reflector you hang out on and want that destination to never time out. Simply add an entry in custom_decode such that a particular destination is configured with the “notimeout" flag set, to not time out.
>
> For example, I have three reflectors set to not time out, all others time out normally. custom/custom_decode entries below.
>
> if [ "$1" = "9200" ] ; then "$SCRIPT"/connect_to_reflector ref9200 notimeout ; exit 1 ; fi
> if [ "$1" = "9600" ] ; then "$SCRIPT"/connect_to_reflector ref9600 notimeout ; exit 1 ; fi
> if [ "$1" = "9735" ] ; then "$SCRIPT"/connect_to_reflector ref9735 notimeout ; exit 1 ; fi
>
>
> pico -w custom/custom_decode
> pico -w custom/environment
>
> You need to be root to edit the environment file.  Just be very careful, a single keystroke mistake can render your node totally inoperative. 
>
> -k9dc
>
>
>> On Apr 30, 2020, at 12:19, Albert Febraro <w6aax@...> wrote:
>>
>> Can I get an explanation on how to disable the node time out timer in the software?  My node disconnects from other nodes and reflectors after approximately  thirty minutes of being idle.  I understand that the environment file has to updated. How can I get to that directory and file after log in from Putty. And then what value needs to be changed? 
>> Thank you and 73,
>> Al
>> W6AAX
>
>
>
>
>



Albert Febraro
 

David, thank you, that got it!
Al


On May 5, 2020, at 4:56 PM, k9dc <Dave@...> wrote:


As I said below, you must be root to edit the environment file.  

su  -
<password>
cd /home/irlp/custom
pico -w environment

-k9dc

On May 5, 2020, at 19:09, Albert Febraro <w6aax@...> wrote:


I want to thank everyone who responded to my question on node timeout.
I was able to edit the file for Repeater timeout in Environment, using Putty,  however when I  try to save the change using ^O in Nano editor I get the message: "Error writing custom/environment: Permission denied"  I'm wondering if I have to save this change in some other fashion.
Al
W6AAX


From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> on behalf of Albert Febraro <w6aax@...>
Sent: Thursday, April 30, 2020 10:14 AM
To: IRLP@irlp.groups.io <IRLP@irlp.groups.io>
Subject: Re: [IRLP] Node Time Out
 
Thank you
I’ll go the route where I will leave the default time out  for nodes and disable the time out for reflectors.
Al
> On Apr 30, 2020, at 9:41 AM, k9dc <Dave@...> wrote:
>
> 
> There are two inactivity timeouts. One for node to node, the other for Reflector calls.  Default values are 240 seconds and 1200 seconds respectively.  Node to node is set in the file custom/timeoutvalue. The reflector timeout is set in the environment file.
>
> export REFLECT_TIMEOUT_VALUE=43200
>
> Set it to the value you want. Although I would NOT suggest disabling it completely, rather set it to a value long enough for your requirements. 
>
> An even better option is if you have a particular reflector you hang out on and want that destination to never time out. Simply add an entry in custom_decode such that a particular destination is configured with the “notimeout" flag set, to not time out.
>
> For example, I have three reflectors set to not time out, all others time out normally. custom/custom_decode entries below.
>
> if [ "$1" = "9200" ] ; then "$SCRIPT"/connect_to_reflector ref9200 notimeout ; exit 1 ; fi
> if [ "$1" = "9600" ] ; then "$SCRIPT"/connect_to_reflector ref9600 notimeout ; exit 1 ; fi
> if [ "$1" = "9735" ] ; then "$SCRIPT"/connect_to_reflector ref9735 notimeout ; exit 1 ; fi
>
>
> pico -w custom/custom_decode
> pico -w custom/environment
>
> You need to be root to edit the environment file.  Just be very careful, a single keystroke mistake can render your node totally inoperative. 
>
> -k9dc
>
>
>> On Apr 30, 2020, at 12:19, Albert Febraro <w6aax@...> wrote:
>>
>> Can I get an explanation on how to disable the node time out timer in the software?  My node disconnects from other nodes and reflectors after approximately  thirty minutes of being idle.  I understand that the environment file has to updated. How can I get to that directory and file after log in from Putty. And then what value needs to be changed? 
>> Thank you and 73,
>> Al
>> W6AAX
>
>
>
>
>