Topics

Redirecting EchoIRLP incoming connections??


Timothy Mc Bain - VK3MIT
 

Hello Group;

I'm looking after (insert here - trying!!) a club EchoIRLP Pi based node - one of Dave Camerons pre-built units.

Somehow, perhaps via its own internal poltergeist, when the node receives an incoming connection request, it "diverts" - or something like that - and tries to connect to my own personal node.

Each node is set up on its own ID number and different email address as normal. Each node is geographically separated, on its own internet connection, etc, but I can putty in to both.

As far as I know, nothing has been done to cause this behaviour.

Can someone assist with pointing me in the correct direction to fix this please? Perplexed here as to why and how this is happening!

Many thanks - Tim.
VK3MIT


k9dc
 

How about including the node numbers and the call symptoms, “If Node XXXX calls me, this happens.” Your report is a little vague. Also includes details about how the node is connected to the Internet. Do you have separate internet connections for each one?

-k9dc

On Jan 9, 2020, at 18:07, Timothy Mc Bain - VK3MIT <irlp.lists.vk3mit@...> wrote:

Hello Group;

I'm looking after (insert here - trying!!) a club EchoIRLP Pi based node - one of Dave Camerons pre-built units.

Somehow, perhaps via its own internal poltergeist, when the node receives an incoming connection request, it "diverts" - or something like that - and tries to connect to my own personal node.

Each node is set up on its own ID number and different email address as normal. Each node is geographically separated, on its own internet connection, etc, but I can putty in to both.

As far as I know, nothing has been done to cause this behaviour.

Can someone assist with pointing me in the correct direction to fix this please? Perplexed here as to why and how this is happening!

Many thanks - Tim.
VK3MIT


Timothy Mc Bain - VK3MIT
 

Apologies, vague is about as good as I get at this hour!! I may have asked this on the wrong list - IRLP is working beautifully. Its on the EchoLink side of the node that the issue is occurring.

Its node 6364 / 290314 that is mis-behaving.

When a call is initiated to that node from either the iPhone EL app, or via an RF connection, it doesn't trigger node 6364 / 290314 at all, but connects straight away onto mine - 6363 / 350851. Nothing is heard on 6364. There is the usual connection message that comes out onto 6363 (instead of where it should on 6364) It is an immediate "divert".

I don’t know if I've stuffed something up - I did have to unfortunately block an IRLP node that was causing ongoing interference and other issues for us - I may have broken something with that process? I have just cleared out all the node blocking data for both IRLP and EchoLink. (Was only one station that was blocked, but had IRLP and EchoLink running, so both systems for that one station were blocked - now completely un-blocked)

I have re-booted the Pi several times.

The nodes are 300 kms apart, on their own internet connections, both are wired connections (as distinct from wi-fi) and are on a DSL type connection via a modem all of which has, until recently, been behaving flawlessly. Dunno what I've done....

Many thanks - Tim.
VK3MIT

-----Original Message-----
From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of k9dc
Sent: Friday, 10 January 2020 10:12 AM
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] Redirecting EchoIRLP incoming connections??

How about including the node numbers and the call symptoms, “If Node XXXX calls me, this happens.” Your report is a little vague. Also includes details about how the node is connected to the Internet. Do you have separate internet connections for each one?

-k9dc

On Jan 9, 2020, at 18:07, Timothy Mc Bain - VK3MIT <irlp.lists.vk3mit@...> wrote:

Hello Group;

I'm looking after (insert here - trying!!) a club EchoIRLP Pi based node - one of Dave Camerons pre-built units.

Somehow, perhaps via its own internal poltergeist, when the node receives an incoming connection request, it "diverts" - or something like that - and tries to connect to my own personal node.

Each node is set up on its own ID number and different email address as normal. Each node is geographically separated, on its own internet connection, etc, but I can putty in to both.

As far as I know, nothing has been done to cause this behaviour.

Can someone assist with pointing me in the correct direction to fix this please? Perplexed here as to why and how this is happening!

Many thanks - Tim.
VK3MIT


James Hall
 

Had this happen when 2 nodes on same router. Ports are forwarded to one computer so when you call in to the other, audio is automatically steered to the one with the forwarded ports. Don't know if this your problem, but it sounds exactly like this scenario.

aloha
Jim wh7cd

Sent from the Cold Duck


On Thursday, January 9, 2020, 06:00:00 PM PST, Timothy Mc Bain - VK3MIT <irlp.lists.vk3mit@...> wrote:


Apologies, vague is about as good as I get at this hour!! I may have asked this on the wrong list - IRLP is working beautifully. Its on the EchoLink side of the node that the issue is occurring.

Its node 6364 / 290314 that is mis-behaving.

When a call is initiated to that node from either the iPhone EL app, or via an RF connection, it doesn't trigger node 6364 / 290314 at all, but connects straight away onto mine - 6363 / 350851. Nothing is heard on 6364. There is the usual connection message that comes out onto 6363 (instead of where it should on 6364) It is an immediate "divert".

I don’t know if I've stuffed something up - I did have to unfortunately block an IRLP node that was causing ongoing interference and other issues for us - I may have broken something with that process? I have just cleared out all the node blocking data for both IRLP and EchoLink. (Was only one station that was blocked, but had IRLP and EchoLink running, so both systems for that one station were blocked - now completely un-blocked)

I have re-booted the Pi several times.

The nodes are 300 kms apart, on their own internet connections, both are wired connections (as distinct from wi-fi) and are on a DSL type connection via a modem all of which has, until recently, been behaving flawlessly. Dunno what I've done....

Many thanks - Tim.
VK3MIT

-----Original Message-----
From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of k9dc
Sent: Friday, 10 January 2020 10:12 AM
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] Redirecting EchoIRLP incoming connections??

How about including the node numbers and the call symptoms, “If Node XXXX calls me, this happens.”  Your report is a little vague.  Also includes details about how the node is connected to the Internet. Do you have separate internet connections for each one?

-k9dc

> On Jan 9, 2020, at 18:07, Timothy Mc Bain - VK3MIT <irlp.lists.vk3mit@...> wrote:
>
> Hello Group;
>
> I'm looking after (insert here - trying!!) a club EchoIRLP Pi based node - one of Dave Camerons pre-built units.
>
> Somehow, perhaps via its own internal poltergeist, when the node receives an incoming connection request, it "diverts" - or something like that - and tries to connect to my own personal node.
>
> Each node is set up on its own ID number and different email address as normal. Each node is geographically separated, on its own internet connection, etc, but I can putty in to both.
>
> As far as I know, nothing has been done to cause this behaviour.
>
> Can someone assist with pointing me in the correct direction to fix this please? Perplexed here as to why and how this is happening!
>
> Many thanks - Tim.
> VK3MIT











Timothy Mc Bain - VK3MIT
 

No, the nodes are many many miles apart, quite independent of each other. I think its something that I may have stuffed up unknowingly. Still got the big sign out front saying “LEARNING” !!

 

Thanks heaps – Tim.

VK3MIT

 

From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of James Hall
Sent: Friday, 10 January 2020 1:13 PM
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] Redirecting EchoIRLP incoming connections??

 

Had this happen when 2 nodes on same router. Ports are forwarded to one computer so when you call in to the other, audio is automatically steered to the one with the forwarded ports. Don't know if this your problem, but it sounds exactly like this scenario.

 

aloha

Jim wh7cd

 

Sent from the Cold Duck

 

 

On Thursday, January 9, 2020, 06:00:00 PM PST, Timothy Mc Bain - VK3MIT <irlp.lists.vk3mit@...> wrote:

 

 

Apologies, vague is about as good as I get at this hour!! I may have asked this on the wrong list - IRLP is working beautifully. Its on the EchoLink side of the node that the issue is occurring.

Its node 6364 / 290314 that is mis-behaving.

When a call is initiated to that node from either the iPhone EL app, or via an RF connection, it doesn't trigger node 6364 / 290314 at all, but connects straight away onto mine - 6363 / 350851. Nothing is heard on 6364. There is the usual connection message that comes out onto 6363 (instead of where it should on 6364) It is an immediate "divert".

I don’t know if I've stuffed something up - I did have to unfortunately block an IRLP node that was causing ongoing interference and other issues for us - I may have broken something with that process? I have just cleared out all the node blocking data for both IRLP and EchoLink. (Was only one station that was blocked, but had IRLP and EchoLink running, so both systems for that one station were blocked - now completely un-blocked)

I have re-booted the Pi several times.

The nodes are 300 kms apart, on their own internet connections, both are wired connections (as distinct from wi-fi) and are on a DSL type connection via a modem all of which has, until recently, been behaving flawlessly. Dunno what I've done....

Many thanks - Tim.
VK3MIT

-----Original Message-----
From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of k9dc
Sent: Friday, 10 January 2020 10:12 AM
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] Redirecting EchoIRLP incoming connections??

How about including the node numbers and the call symptoms, “If Node XXXX calls me, this happens.”  Your report is a little vague.  Also includes details about how the node is connected to the Internet. Do you have separate internet connections for each one?

-k9dc

> On Jan 9, 2020, at 18:07, Timothy Mc Bain - VK3MIT <irlp.lists.vk3mit@...> wrote:
>
> Hello Group;
>
> I'm looking after (insert here - trying!!) a club EchoIRLP Pi based node - one of Dave Camerons pre-built units.
>
> Somehow, perhaps via its own internal poltergeist, when the node receives an incoming connection request, it "diverts" - or something like that - and tries to connect to my own personal node.
>
> Each node is set up on its own ID number and different email address as normal. Each node is geographically separated, on its own internet connection, etc, but I can putty in to both.
>
> As far as I know, nothing has been done to cause this behaviour.
>
> Can someone assist with pointing me in the correct direction to fix this please? Perplexed here as to why and how this is happening!
>
> Many thanks - Tim.
> VK3MIT










John VK4JJW
 

On 10/01/2020 12:15 pm, Timothy Mc Bain - VK3MIT wrote:
No, the nodes are many many miles apart, quite independent of each other. I think its something that I may have stuffed up unknowingly. Still got the big sign out front saying “LEARNING” !!
Thanks heaps – Tim.
VK3MIT

Reckon it may have something to do with the PGP keys Tim.
For each node, do a troubleshoot-irlp while not connected to anything.

The section about the PGP Key tests should look like this:

*PGP Key Tests*
***************

Updating pgp keyring ... done.
------------------------------------------------------------------------------
TEST No. 5 REPORT - PASS - Your Public PGP key exists in the keyring.
------------------------------------------------------------------------------

------------------------------------------------------------------------------
TEST No. 6 REPORT - PASS - Your secret keyring only contains one secret
PGP key.
------------------------------------------------------------------------------

------------------------------------------------------------------------------
TEST No. 7 REPORT - PASS - Your Secret PGP key matches your node's stationID.
------------------------------------------------------------------------------

------------------------------------------------------------------------------
TEST No. 8 REPORT - PASS - Your Secret PGP Hash matches the key in the public
keyring.
------------------------------------------------------------------------------



Have a go at that and see what happens!


HTH

JW
--

EchoIRLP
IRLP Node 6527
EchoLink Node 96527

DMR 5054314


http://www.vk4jjw.info


John
 

Tim,

Have a look at the IP address for echolink stns 290314 & 350851.
You'll find that info in /home/EchoIRLP/echo_hosts

On my stn 6163 they both are listed with the same IP address,
and my listings are updated for today.

73 John

On 10/01/2020 11:59:48 AM, Timothy Mc Bain - VK3MIT (irlp.lists.vk3mit@...) wrote:
Apologies, vague is about as good as I get at this hour!! I may have asked this on the wrong list - IRLP is working beautifully. Its on the EchoLink side of the node that the issue is occurring.
Its node 6364 / 290314 that is mis-behaving.
When a call is initiated to that node from either the iPhone EL app, or via an RF connection, it doesn't trigger node 6364 / 290314 at all, but connects straight away onto mine - 6363 / 350851. Nothing is heard on 6364. There is the usual connection message that comes out onto 6363 (instead of where it should on 6364) It is an immediate "divert".
I don’t know if I've stuffed something up - I did have to unfortunately block an IRLP node that was causing ongoing interference and other issues for us - I may have broken something with that process? I have just cleared out all the node blocking data for both IRLP and EchoLink. (Was only one station that was blocked, but had IRLP and EchoLink running, so both systems for that one station were blocked - now completely un-blocked)
I have re-booted the Pi several times.
The nodes are 300 kms apart, on their own internet connections, both are wired connections (as distinct from wi-fi) and are on a DSL type connection via


David McAnally
 

Could you have multiple EchoLink systems with the same call-L or call-R setup? Be sure each node is configured with it's own unique EchoLink call/node number. You cannot have multiple EchoLink nodes with the same call-L, or with the same call-R, configuration. In other words, I can only have one WD5M-R Echolink system active. Normal EchoIRLP systems have the configuration files in /home/EchoIRLP/custom/ directory. I believe you said this was Dave's implementation, in which case it may differ.

David M.
WD5M


Timothy Mc Bain - VK3MIT
 

Many thanks John VK4JJW and John G.;

I have run the "update files" script on both nodes successfully, and, other than a very old "rsync" warning on node 6363 - which is an "embedded" node, several years old, also from Dave C. - all was ok.

I then ran troubleshoot on both machines, and apart from the usual EchoIRLP corruption warning, everything was good on both nodes.

I'm perplexed by your IP address information, John (G); on the assumption that the IP addressing is the problem - and heavens knows how that was changed - where would I find the IP address setting so I can check it / FIX it? (Both nodes are on static IP's from iIINET)

Many thanks - Tim.
VK3MIT

-----Original Message-----
From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of John
Sent: Friday, 10 January 2020 1:36 PM
To: IRLP <IRLP@irlp.groups.io>
Subject: Re: [IRLP] Redirecting EchoIRLP incoming connections??

Tim,

Have a look at the IP address for echolink stns 290314 & 350851.
You'll find that info in /home/EchoIRLP/echo_hosts

On my stn 6163 they both are listed with the same IP address, and my listings are updated for today.

73 John

On 10/01/2020 11:59:48 AM, Timothy Mc Bain - VK3MIT (irlp.lists.vk3mit@...) wrote:
Apologies, vague is about as good as I get at this hour!! I may have asked this on the wrong list - IRLP is working beautifully. Its on the EchoLink side of the node that the issue is occurring.
Its node 6364 / 290314 that is mis-behaving.

When a call is initiated to that node from either the iPhone EL app, or via an RF connection, it doesn't trigger node 6364 / 290314 at all, but connects straight away onto mine - 6363 / 350851. Nothing is heard on 6364. There is the usual connection message that comes out onto 6363 (instead of where it should on 6364) It is an immediate "divert".

I don’t know if I've stuffed something up - I did have to
unfortunately block an IRLP node that was causing ongoing interference
and other issues for us - I may have broken something with that
process? I have just cleared out all the node blocking data for both
IRLP and EchoLink. (Was only one station that was blocked, but had
IRLP and EchoLink running, so both systems for that one station were
blocked - now completely un-blocked)

I have re-booted the Pi several times.

The nodes are 300 kms apart, on their own internet connections, both
are wired connections (as distinct from wi-fi) and are on a DSL type
connection via


John
 

FIX it?
Arrr.. I'm not sure at the mo, but if you did see the same address as I did,
by searching for the IP address listed in /home/EchoIRLP/echo_hosts
of both systems, that *might* be the issue.
Can I place $10 each way?

Note that data down with the date/time of those files,
then run as repeater: /home/EchoIRLP/echo_update_hosts
from each stn, and see if the data changes?

HTH
John

On 10/01/2020 1:44 pm, Timothy Mc Bain - VK3MIT wrote:
Many thanks John VK4JJW and John G.;
I have run the "update files" script on both nodes successfully, and, other than a very old "rsync" warning on node 6363 - which is an "embedded" node, several years old, also from Dave C. - all was ok.
I then ran troubleshoot on both machines, and apart from the usual EchoIRLP corruption warning, everything was good on both nodes.
I'm perplexed by your IP address information, John (G); on the assumption that the IP addressing is the problem - and heavens knows how that was changed - where would I find the IP address setting so I can check it / FIX it? (Both nodes are on static IP's from iIINET)
Many thanks - Tim.
VK3MIT
-----Original Message-----
From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of John
Sent: Friday, 10 January 2020 1:36 PM
To: IRLP <IRLP@irlp.groups.io>
Subject: Re: [IRLP] Redirecting EchoIRLP incoming connections??
Tim,
Have a look at the IP address for echolink stns 290314 & 350851.
You'll find that info in /home/EchoIRLP/echo_hosts
On my stn 6163 they both are listed with the same IP address, and my listings are updated for today.
73 John

On 10/01/2020 11:59:48 AM, Timothy Mc Bain - VK3MIT (irlp.lists.vk3mit@...) wrote:
Apologies, vague is about as good as I get at this hour!! I may have asked this on the wrong list - IRLP is working beautifully. Its on the EchoLink side of the node that the issue is occurring.
Its node 6364 / 290314 that is mis-behaving.

When a call is initiated to that node from either the iPhone EL app, or via an RF connection, it doesn't trigger node 6364 / 290314 at all, but connects straight away onto mine - 6363 / 350851. Nothing is heard on 6364. There is the usual connection message that comes out onto 6363 (instead of where it should on 6364) It is an immediate "divert".

I don’t know if I've stuffed something up - I did have to
unfortunately block an IRLP node that was causing ongoing interference
and other issues for us - I may have broken something with that
process? I have just cleared out all the node blocking data for both
IRLP and EchoLink. (Was only one station that was blocked, but had
IRLP and EchoLink running, so both systems for that one station were
blocked - now completely un-blocked)

I have re-booted the Pi several times.

The nodes are 300 kms apart, on their own internet connections, both
are wired connections (as distinct from wi-fi) and are on a DSL type
connection via


Timothy Mc Bain - VK3MIT
 

Thank you John - there seems to be a problem with the path for that command - I'm getting a "no such file or directory" warning. Definitely running as repeater.

Tim.

-----Original Message-----
From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of John
Sent: Friday, 10 January 2020 3:21 PM
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] Redirecting EchoIRLP incoming connections??


>FIX it?

Arrr.. I'm not sure at the mo, but if you did see the same address as I did, by searching for the IP address listed in /home/EchoIRLP/echo_hosts of both systems, that *might* be the issue.
Can I place $10 each way?

Note that data down with the date/time of those files, then run as repeater: /home/EchoIRLP/echo_update_hosts from each stn, and see if the data changes?

HTH
John

On 10/01/2020 1:44 pm, Timothy Mc Bain - VK3MIT wrote:
Many thanks John VK4JJW and John G.;

I have run the "update files" script on both nodes successfully, and, other than a very old "rsync" warning on node 6363 - which is an "embedded" node, several years old, also from Dave C. - all was ok.

I then ran troubleshoot on both machines, and apart from the usual EchoIRLP corruption warning, everything was good on both nodes.

I'm perplexed by your IP address information, John (G); on the
assumption that the IP addressing is the problem - and heavens knows
how that was changed - where would I find the IP address setting so I
can check it / FIX it? (Both nodes are on static IP's from iIINET)

Many thanks - Tim.
VK3MIT

-----Original Message-----
From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of John
Sent: Friday, 10 January 2020 1:36 PM
To: IRLP <IRLP@irlp.groups.io>
Subject: Re: [IRLP] Redirecting EchoIRLP incoming connections??

Tim,

Have a look at the IP address for echolink stns 290314 & 350851.
You'll find that info in /home/EchoIRLP/echo_hosts

On my stn 6163 they both are listed with the same IP address, and my listings are updated for today.

73 John

On 10/01/2020 11:59:48 AM, Timothy Mc Bain - VK3MIT (irlp.lists.vk3mit@...) wrote:
Apologies, vague is about as good as I get at this hour!! I may have asked this on the wrong list - IRLP is working beautifully. Its on the EchoLink side of the node that the issue is occurring.
Its node 6364 / 290314 that is mis-behaving.

When a call is initiated to that node from either the iPhone EL app, or via an RF connection, it doesn't trigger node 6364 / 290314 at all, but connects straight away onto mine - 6363 / 350851. Nothing is heard on 6364. There is the usual connection message that comes out onto 6363 (instead of where it should on 6364) It is an immediate "divert".

I don’t know if I've stuffed something up - I did have to
unfortunately block an IRLP node that was causing ongoing
interference and other issues for us - I may have broken something
with that process? I have just cleared out all the node blocking data
for both IRLP and EchoLink. (Was only one station that was blocked,
but had IRLP and EchoLink running, so both systems for that one
station were blocked - now completely un-blocked)

I have re-booted the Pi several times.

The nodes are 300 kms apart, on their own internet connections, both
are wired connections (as distinct from wi-fi) and are on a DSL type
connection via







John
 

My bad, Tim

try /home/EchoIRLP/scripts/echo_update_hosts

NB: the command line IS case sensitive !!

Even then, if this is Dave's node config, that might be wrong too.
The file you need to run to update the Echolink hosts is called
echo_update_hosts and it should be found in the EchoIRLP/scripts folder.

What are you seeing listed as the Echolink IP address for your two systems?
That's what I am pointing at, but if there's a problem with your porting,
the script above will not fix it.


73 John

On 10/01/2020 4:17:36 PM, Timothy Mc Bain - VK3MIT (irlp.lists.vk3mit@...) wrote:
Thank you John - there seems to be a problem with the path for that command - I'm getting a "no such file or directory" warning. Definitely running as repeater.
Tim.
-----Original Message-----
From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of John
Sent: Friday, 10 January 2020 3:21 PM
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] Redirecting EchoIRLP incoming connections??

>FIX it?
Arrr.. I'm not sure at the mo, but if you did see the same address as I did, by searching for the IP address listed in /home/EchoIRLP/echo_hosts of both systems, that *might* be the issue.
Can I place $10 each way?
Note that data down with the date/time of those files, then run as repeater: /home/EchoIRLP/echo_update_hosts from each stn, and see if the data changes?
HTH
John
On 10/01/2020 1:44 pm, Timothy Mc Bain - VK3MIT wrote:
Many thanks John VK4JJW and John G.;
I have run the "update files" script on both nodes successfully, and, other than a very old "rsync" warning on node 6363 - which is an "embedded" node, several years old, also from Dave C. - all was ok.
I then ran troubleshoot on both machines, and apart from


Timothy Mc Bain - VK3MIT
 

 

Hello Group;

 

Following on from the below responses, I've been doing a bit of research, and this is the current state of play, listed in order of processes done:

 

  1. Ran "echo_hosts" in Node 6364/290314 via putty remotely from my machine here in Wangaratta, both VK3RIT and VK3RSP show correct IP addresses (RIT 203.206.138.49; RSP 203.173.40.238)

 

  1. Ran "update_echo_hosts" in Node 6364/290314 via putty remotely from my machine here in Wangaratta

 

  1. Ran "echo_hosts" again in Node 6364/290314 remotely from my machine here in Wangaratta, both RIT and RSP still show correct IP addresses as above – i.e. no change before or after, note that I did not re-start the node at any point.

 

At this point, one would assume that everything should connect up correctly - however....

 

I logged in to Echolink using the standard single user interface on Win 10 to see what it reported - screen shots are attached, which show both RSP and RIT reporting the same address - RSP of course is wrong - it SHOULD be 203.173.40.238

 

To short-cut possible requests for this info, I have attached:

  • A screen shot of the current 6364/290314 if config file.
  • A screen shot of the current 6364/290314 wicd-curses screen

 

The node is on a fixed external IP address into the modem; the correct ports for all services (Echolink and IRLP) are then forwarded via a wired connection direct from the modem to the Raspberry Pi.

 

Note that this is a combined EchoIRLP node box (Pi), on which IRLP works perfectly, even while the Echolink side of things is reporting incorrectly.

 

Any thoughts?

 

Many thanks – Tim.

0428 387 599

VK3MIT - Wangaratta

 

 

-----Original Message-----
From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of John
Sent: Friday, 10 January 2020 7:39 PM
To: IRLP <IRLP@irlp.groups.io>
Subject: Re: [IRLP] Redirecting EchoIRLP incoming connections??

 

 

My bad, Tim

 

try /home/EchoIRLP/scripts/echo_update_hosts

 

NB: the command line IS case sensitive !!

 

Even then, if this is Dave's node config, that might be wrong too.

The file you need to run to update the Echolink hosts is called echo_update_hosts and it should be found in the EchoIRLP/scripts folder.

 

What are you seeing listed as the Echolink IP address for your two systems?

That's what I am pointing at, but if there's a problem with your porting, the script above will not fix it.

 

 

73 John

 

> On 10/01/2020 4:17:36 PM, Timothy Mc Bain - VK3MIT (irlp.lists.vk3mit@...) wrote:

> > Thank you John - there seems to be a problem with the path for that command - I'm getting a "no such file or directory" warning. Definitely running as repeater.

>

> Tim.

>

> -----Original Message-----

> From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of John

> Sent: Friday, 10 January 2020 3:21 PM

> To: IRLP@irlp.groups.io

> Subject: Re: [IRLP] Redirecting EchoIRLP incoming connections??

>

>

>  >FIX it?

>

> Arrr.. I'm not sure at the mo, but if you did see the same address as I did, by searching for the IP address listed in /home/EchoIRLP/echo_hosts of both systems, that *might* be the issue.

> Can I place $10 each way?

>

> Note that data down with the date/time of those files, then run as repeater: /home/EchoIRLP/echo_update_hosts from each stn, and see if the data changes?

>

> HTH

> John

>

> On 10/01/2020 1:44 pm, Timothy Mc Bain - VK3MIT wrote:

> > Many thanks John VK4JJW and John G.;

> >

> > I have run the "update files" script on both nodes successfully, and, other than a very old "rsync" warning on node 6363 - which is an "embedded" node, several years old, also from Dave C. - all was ok.

> >

> > I then ran troubleshoot on both machines, and apart from

 

 


k9dc
 

Why is this a problem? You would never make an echolink call between these systems, nor would any other EchoIRLP based machine call you using Echolink. I am thinking it would only matter if your nodes were appearing incorrectly to native Echolink clients, which appears to not be the case.

-k9dc

On Jan 25, 2020, at 22:57, Timothy Mc Bain - VK3MIT <irlp.lists.vk3mit@...> wrote:


Hello Group;

Following on from the below responses, I've been doing a bit of research, and this is the current state of play, listed in order of processes done:

• Ran "echo_hosts" in Node 6364/290314 via putty remotely from my machine here in Wangaratta, both VK3RIT and VK3RSP show correct IP addresses (RIT 203.206.138.49; RSP 203.173.40.238)

• Ran "update_echo_hosts" in Node 6364/290314 via putty remotely from my machine here in Wangaratta

• Ran "echo_hosts" again in Node 6364/290314 remotely from my machine here in Wangaratta, both RIT and RSP still show correct IP addresses as above – i.e. no change before or after, note that I did not re-start the node at any point.

At this point, one would assume that everything should connect up correctly - however....

I logged in to Echolink using the standard single user interface on Win 10 to see what it reported - screen shots are attached, which show both RSP and RIT reporting the same address - RSP of course is wrong - it SHOULD be 203.173.40.238

To short-cut possible requests for this info, I have attached:
• A screen shot of the current 6364/290314 if config file.
• A screen shot of the current 6364/290314 wicd-curses screen

The node is on a fixed external IP address into the modem; the correct ports for all services (Echolink and IRLP) are then forwarded via a wired connection direct from the modem to the Raspberry Pi.

Note that this is a combined EchoIRLP node box (Pi), on which IRLP works perfectly, even while the Echolink side of things is reporting incorrectly.

Any thoughts?

Many thanks – Tim.
0428 387 599
VK3MIT - Wangaratta


Timothy Mc Bain - VK3MIT
 

Hi Dave; thank you for your input to my difficulty.

You've actually hit right on the issue - The two systems DO need to connect to each other - they are 300 Kms apart! The only thing that is common between the two nodes is that I own both, and pay for the internet connection for both! Other than that, they are completely separate - location, internet connection, call signs, registered email addresses, etc etc.

I suppose I could re-name this thread "incorrect reporting of node IP address" - but it is NOT affecting the IRLP side of things - only the Echolink area.

When you say "native Echolink clients" do you mean the standard Windows Echolink software? If so, I've just had that running here, and a right-click on each of the node callsigns, then selecting "station info" shows the same IP address for both nodes! Something, somewhere, is reporting or advising the Echolink system that node 6364/290314 is on the same IP address as another node 300 Kms distant....

I do not know / understand what could be causing this; both nodes are on their own fixed IP address.

Any ideas or suggestions of where I should look?

Many thanks;

Tim.
VK3MIT

-----Original Message-----
From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of k9dc
Sent: Monday, 27 January 2020 12:31 AM
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] Redirecting EchoIRLP incoming connections??


Why is this a problem? You would never make an echolink call between these systems, nor would any other EchoIRLP based machine call you using Echolink. I am thinking it would only matter if your nodes were appearing incorrectly to native Echolink clients, which appears to not be the case.

-k9dc

On Jan 25, 2020, at 22:57, Timothy Mc Bain - VK3MIT <irlp.lists.vk3mit@...> wrote:


Hello Group;

Following on from the below responses, I've been doing a bit of research, and this is the current state of play, listed in order of processes done:

• Ran "echo_hosts" in Node 6364/290314 via putty remotely from my machine here in Wangaratta, both VK3RIT and VK3RSP show correct IP addresses (RIT 203.206.138.49; RSP 203.173.40.238)

• Ran "update_echo_hosts" in Node 6364/290314 via putty remotely from my machine here in Wangaratta

• Ran "echo_hosts" again in Node 6364/290314 remotely from my machine here in Wangaratta, both RIT and RSP still show correct IP addresses as above – i.e. no change before or after, note that I did not re-start the node at any point.

At this point, one would assume that everything should connect up correctly - however....

I logged in to Echolink using the standard single user interface on Win 10 to see what it reported - screen shots are attached, which show both RSP and RIT reporting the same address - RSP of course is wrong - it SHOULD be 203.173.40.238

To short-cut possible requests for this info, I have attached:
• A screen shot of the current 6364/290314 if config file.
• A screen shot of the current 6364/290314 wicd-curses screen

The node is on a fixed external IP address into the modem; the correct ports for all services (Echolink and IRLP) are then forwarded via a wired connection direct from the modem to the Raspberry Pi.

Note that this is a combined EchoIRLP node box (Pi), on which IRLP works perfectly, even while the Echolink side of things is reporting incorrectly.

Any thoughts?

Many thanks – Tim.
0428 387 599
VK3MIT - Wangaratta


k9dc
 

I checked the echo_hosts file one of my systems and found the error you reported. But when I checked on a windows Echolink client both nodes were correct (w different IPs). The point of my question was, why would you ever need to make an echolink call between your installations. use IRLP for all those comms, the IRLP audio codec is always superior. If you need more than two nodes, nail a connection up to a reflector channel, like 9605. Then you can have as many participants as you might need.

EchoIRLP is a script allowing your IRLP node to play in the Echolink network, when idle. We have no inside knowledge of the workings of the Echolink network. I don’t even know how long Echolink nodes need to be present to stabilize their reported address.

If you need a reliable Echolink operation you should probably use a true Echolink sysop installation and not try to get there with EchoIRLP. It is definitely a secondary function to IRLP. It also looks like a conference bridge to Echolink (because it actually is). In fact that may be part of the problem. Did you happen to configure your EchoIRLP to allow more than 2 parties in to your bridge? That is not allowed by Echolink, without paying them US$40 per year.

-k9dc

On Jan 29, 2020, at 04:53, Timothy Mc Bain - VK3MIT <irlp.lists.vk3mit@...> wrote:

Hi Dave; thank you for your input to my difficulty.

You've actually hit right on the issue - The two systems DO need to connect to each other - they are 300 Kms apart! The only thing that is common between the two nodes is that I own both, and pay for the internet connection for both! Other than that, they are completely separate - location, internet connection, call signs, registered email addresses, etc etc.

I suppose I could re-name this thread "incorrect reporting of node IP address" - but it is NOT affecting the IRLP side of things - only the Echolink area.

When you say "native Echolink clients" do you mean the standard Windows Echolink software? If so, I've just had that running here, and a right-click on each of the node callsigns, then selecting "station info" shows the same IP address for both nodes! Something, somewhere, is reporting or advising the Echolink system that node 6364/290314 is on the same IP address as another node 300 Kms distant....

I do not know / understand what could be causing this; both nodes are on their own fixed IP address.

Any ideas or suggestions of where I should look?

Many thanks;

Tim.
VK3MIT