Topics

Remote Admin Install on CentOS 4.9 Problems

Marshall Oldham
 

Trying to  install remote admin on an old IRLP  test node that I have running Centos 4.9 and I am having problems.

 

I know I should upgrade the OS but  it is an old VIA motherboard and I have tried to upgrade to something newer and no luck.

 

Latest IRLP Debian 10 freezes and will not install. Tried Debian 9 and 8 with no luck either.

 

Anyways, to my problem with the  install-ra script, here is what happens when I run the script.

 

Looks like some of the items are not getting installed.

 

How can I tell if the remote admin script installed correctly?

 

Below is what is shown during the install.

 

Thanks

 

Marshall - ke6pcv

 

 

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

 

The script has detected you are running CentOS.

 

Press ENTER to continue, or CTRL-C to exit.

 

FTP Client NCFTPGET detected OK.

 

- Downloading the files from the server ....

/tmp/httpd.conf.centos.patch:                          150.00 B     1.53 kB/s 

 

- Installing tools needed to run IRLP ADMIN system ....

Setting up Install Process

Setting up repositories

not using ftp, http[s], or file for repos, skipping - Invalid release/repo/arch combination

Cannot find a valid baseurl for repo: update

Error: Cannot find a valid baseurl for repo: update

done.

 

- Patching apache conf to run as user repeater ....

./install-ra: line 98: patch: command not found

 

- Linking IRLP PHP script directory to web tree ....ln: creating symbolic link `/var/www/html/control' to `/home/irlp/scripts/admin_php_scripts': No such file or directory

done.

 

Please select a username and password for your IRLP Remote Admin security.

They are CASE SENSITIVE.

Username: XXXXXXX

Password: XXXXXXXX

  ./install-ra: line 131: htpasswd: command not found

chmod: cannot access `/etc/htpasswd.irlp': No such file or directory

 

- Creating htaccess file in web tree ....done.

 

- (Re)starting HTTP service ....

error reading information on service httpd: No such file or directory

httpd: unrecognized service

 

 

Press ENTER to continue:

 

The IRLP remote admin scripts and service are installed and running.

 

You access the system by browsing to:

http://www.irlp.net/redirect

 

Enter in your node number and port (port default is 80).

 

You also will have to direct TCP port 80 (may already be forwarded) to

your IRLP computer IP if behind a router.