Topics

Speaktime wavplay problem Debian Buster on PiRLP

Rob Vance
 

Greetings,

I recently restored our note (stn3671) from a backup file - apparently the SD card failed.  I followed the instructions here: http://www.irlp.net/pi/directions.txt

This is a PiRLP purchased from irlp.net; so it has the "features" directory with several functions including speaktime.  The speaktime function does not output any audio.  The function will PTT the repeater, but no audio is played.  Research on the topic led me to investigate permissions, file locations, etc. as this the most likely problem (e.g. wavplay can't find the audio file).  I have done this manually at the command line:

key
play/$AUDIO/stn3671
unkey

And the audio output performs as intended.

Also, speakdate works just as it's supposed to.

I've checked permissions, the symlink (from $AUDIO/custom/speaktime -> to features/speaktime/audio)

When running wavplay from the command line; it doesn't produce any audio, either. Such as...

repeater@stn3671:~/scripts$ ./wavplay ref9990
repeater@stn3671:~/scripts$ ./wavplay /custom/speaktime/the_time_is
 

From Dave Parks' instructions on another post (, I did this 

repeater@stn3671:~/features/speaktime$ bash -x ./speaktime

and received this (std) output...
+ SDIR=custom/speaktime
+ SAYFILES=
+ '[' -z /home/irlp/custom ']'
+ source /home/irlp/custom/irlp_common.sh
+++ /usr/bin/whoami
++ '[' repeater '!=' repeater ']'
++ '[' TRUE '!=' TRUE ']'
+ say the_time_is
+ file=custom/speaktime/the_time_is
+ '[' '!' -f /home/irlp/audio/custom/speaktime/the_time_is.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is'
++ /bin/date '+%H %M %S %p'
+ set -hxB 08 55 31 AM
+ h=08
+ m=55
+ s=31
+ p=AM
+ case $h in
+ saynumber 08 n
+ num=08
+ zero=n
++ expr 08 / 10
++ expr 08 % 10
+ set -hxB 0 8
+ tens=0
+ unit=8
+ case $tens in
+ case $zero in
+ saydigit 8
+ case $1 in
+ say 8
+ file=custom/speaktime/8
+ '[' '!' -f /home/irlp/audio/custom/speaktime/8.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8'
+ case $m in
+ saynumber 55 y
+ num=55
+ zero=y
++ expr 55 / 10
++ expr 55 % 10
+ set -hxB 5 5
+ tens=5
+ unit=5
+ case $tens in
+ say 50
+ file=custom/speaktime/50
+ '[' '!' -f /home/irlp/audio/custom/speaktime/50.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50'
+ saydigit 5
+ case $1 in
+ say 5
+ file=custom/speaktime/5
+ '[' '!' -f /home/irlp/audio/custom/speaktime/5.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5'
+ case $p in
+ p=am
+ say am
+ file=custom/speaktime/am
+ '[' '!' -f /home/irlp/audio/custom/speaktime/am.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ saytime ' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ /home/irlp/bin/cosstate
+ cd /home/irlp/custom
+ speak ' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ /home/irlp/scripts/wavplay custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am
+ exit 0

But there was no audio played over the node repeater; just a key-up and unkey.

I am not very skilled at bash scripts; I've attempted some diagnosis with the files, but with no results.

I have not modified the speaktime or wavplay scripts; I copied them from the backup files, as-is.

Any diagnostic, troubleshooting, or previous experiences on how I should proceed are most appreciated.

Thank you.

Rob, N6ROB
(stn3671, K6SA)

 

Hi Rob,

Lets try something simple...

You said it seems to do everything except play the wav files.

Edit the script and change either play or wavplay (whichever is in the script) to aplay and see if that helps.


>< Dave Parks ><
WB8ODF@...
http://wb8odf.com



On Friday, November 22, 2019, 12:49:58 PM EST, Rob Vance <n6rob.rob@...> wrote:


Greetings,

I recently restored our note (stn3671) from a backup file - apparently the SD card failed.  I followed the instructions here: http://www.irlp.net/pi/directions.txt

This is a PiRLP purchased from irlp.net; so it has the "features" directory with several functions including speaktime.  The speaktime function does not output any audio.  The function will PTT the repeater, but no audio is played.  Research on the topic led me to investigate permissions, file locations, etc. as this the most likely problem (e.g. wavplay can't find the audio file).  I have done this manually at the command line:

key
play/$AUDIO/stn3671
unkey

And the audio output performs as intended.

Also, speakdate works just as it's supposed to.

I've checked permissions, the symlink (from $AUDIO/custom/speaktime -> to features/speaktime/audio)

When running wavplay from the command line; it doesn't produce any audio, either. Such as...

repeater@stn3671:~/scripts$ ./wavplay ref9990
repeater@stn3671:~/scripts$ ./wavplay /custom/speaktime/the_time_is
 

From Dave Parks' instructions on another post (#65745), I did this 

repeater@stn3671:~/features/speaktime$ bash -x ./speaktime

and received this (std) output...
+ SDIR=custom/speaktime
+ SAYFILES=
+ '[' -z /home/irlp/custom ']'
+ source /home/irlp/custom/irlp_common.sh
+++ /usr/bin/whoami
++ '[' repeater '!=' repeater ']'
++ '[' TRUE '!=' TRUE ']'
+ say the_time_is
+ file=custom/speaktime/the_time_is
+ '[' '!' -f /home/irlp/audio/custom/speaktime/the_time_is.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is'
++ /bin/date '+%H %M %S %p'
+ set -hxB 08 55 31 AM
+ h=08
+ m=55
+ s=31
+ p=AM
+ case $h in
+ saynumber 08 n
+ num=08
+ zero=n
++ expr 08 / 10
++ expr 08 % 10
+ set -hxB 0 8
+ tens=0
+ unit=8
+ case $tens in
+ case $zero in
+ saydigit 8
+ case $1 in
+ say 8
+ file=custom/speaktime/8
+ '[' '!' -f /home/irlp/audio/custom/speaktime/8.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8'
+ case $m in
+ saynumber 55 y
+ num=55
+ zero=y
++ expr 55 / 10
++ expr 55 % 10
+ set -hxB 5 5
+ tens=5
+ unit=5
+ case $tens in
+ say 50
+ file=custom/speaktime/50
+ '[' '!' -f /home/irlp/audio/custom/speaktime/50.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50'
+ saydigit 5
+ case $1 in
+ say 5
+ file=custom/speaktime/5
+ '[' '!' -f /home/irlp/audio/custom/speaktime/5.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5'
+ case $p in
+ p=am
+ say am
+ file=custom/speaktime/am
+ '[' '!' -f /home/irlp/audio/custom/speaktime/am.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ saytime ' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ /home/irlp/bin/cosstate
+ cd /home/irlp/custom
+ speak ' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ /home/irlp/scripts/wavplay custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am
+ exit 0

But there was no audio played over the node repeater; just a key-up and unkey.

I am not very skilled at bash scripts; I've attempted some diagnosis with the files, but with no results.

I have not modified the speaktime or wavplay scripts; I copied them from the backup files, as-is.

Any diagnostic, troubleshooting, or previous experiences on how I should proceed are most appreciated.

Thank you.

Rob, N6ROB
(stn3671, K6SA)

Rob Vance
 

Hi Dave,

Thanks for the help.  Here is the change I made to the speaktime script:

# Function to play the audio files
#
function speak () {
#  ${SCRIPT}/wavplay ${1}
    aplay ${1}
}

and the output...
repeater@stn3671:~/features/speaktime$ ./speaktime
custom/speaktime/the_time_is: No such file or directory

Here is the symlink from $AUDIO/custom back to features/speaktime/audio
lrwxrwxrwx 1 repeater repeater      33 Jan  8  2013 S69 -> /home/irlp/features/star69/audio/
lrwxrwxrwx 1 repeater repeater      36 Jan 10  2013 speakdate -> /home/irlp/features/speakdate/audio/
lrwxrwxrwx 1 repeater repeater      36 Nov 21 21:45 speaktime -> /home/irlp/features/speaktime/audio/

Here is the file list for audio...
repeater@stn3671:~/features/speaktime/audio$ ls -l | grep the_time_is
-rwxrwxrwx 1 repeater repeater   12244 Feb 23  2004 the_time_is_aus.wav
-rwxrwxrwx 1 repeater repeater    7818 Aug  8  2006 the_time_is.ul
-rwxrwxrwx 1 repeater repeater    5748 May 14  2003 the_time_is.wav

Also, I should have mentioned before that I checked the script and it's starts with #!/bin/bash.  Some threads mention this as a potential problem.
#!/bin/bash
########################################################################
# filename:     speaktime

The speaktime script I am using originates from KC6HUR.

This just feels like I am doing something wrong; I tried your scripts as well - still, no joy.  ... like there will be a big face-palm in the near future.

Thank you!

Rob, N6ROB
(stn3671, K6SA)


On Fri, Nov 22, 2019 at 10:28 AM Dave Parks - WB8ODF via Groups.Io <wb8odf=yahoo.com@groups.io> wrote:
Hi Rob,

Lets try something simple...

You said it seems to do everything except play the wav files.

Edit the script and change either play or wavplay (whichever is in the script) to aplay and see if that helps.



On Friday, November 22, 2019, 12:49:58 PM EST, Rob Vance <n6rob.rob@...> wrote:


Greetings,

I recently restored our note (stn3671) from a backup file - apparently the SD card failed.  I followed the instructions here: http://www.irlp.net/pi/directions.txt

This is a PiRLP purchased from irlp.net; so it has the "features" directory with several functions including speaktime.  The speaktime function does not output any audio.  The function will PTT the repeater, but no audio is played.  Research on the topic led me to investigate permissions, file locations, etc. as this the most likely problem (e.g. wavplay can't find the audio file).  I have done this manually at the command line:

key
play/$AUDIO/stn3671
unkey

And the audio output performs as intended.

Also, speakdate works just as it's supposed to.

I've checked permissions, the symlink (from $AUDIO/custom/speaktime -> to features/speaktime/audio)

When running wavplay from the command line; it doesn't produce any audio, either. Such as...

repeater@stn3671:~/scripts$ ./wavplay ref9990
repeater@stn3671:~/scripts$ ./wavplay /custom/speaktime/the_time_is
 

From Dave Parks' instructions on another post (#65745), I did this 

repeater@stn3671:~/features/speaktime$ bash -x ./speaktime

and received this (std) output...
+ SDIR=custom/speaktime
+ SAYFILES=
+ '[' -z /home/irlp/custom ']'
+ source /home/irlp/custom/irlp_common.sh
+++ /usr/bin/whoami
++ '[' repeater '!=' repeater ']'
++ '[' TRUE '!=' TRUE ']'
+ say the_time_is
+ file=custom/speaktime/the_time_is
+ '[' '!' -f /home/irlp/audio/custom/speaktime/the_time_is.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is'
++ /bin/date '+%H %M %S %p'
+ set -hxB 08 55 31 AM
+ h=08
+ m=55
+ s=31
+ p=AM
+ case $h in
+ saynumber 08 n
+ num=08
+ zero=n
++ expr 08 / 10
++ expr 08 % 10
+ set -hxB 0 8
+ tens=0
+ unit=8
+ case $tens in
+ case $zero in
+ saydigit 8
+ case $1 in
+ say 8
+ file=custom/speaktime/8
+ '[' '!' -f /home/irlp/audio/custom/speaktime/8.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8'
+ case $m in
+ saynumber 55 y
+ num=55
+ zero=y
++ expr 55 / 10
++ expr 55 % 10
+ set -hxB 5 5
+ tens=5
+ unit=5
+ case $tens in
+ say 50
+ file=custom/speaktime/50
+ '[' '!' -f /home/irlp/audio/custom/speaktime/50.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50'
+ saydigit 5
+ case $1 in
+ say 5
+ file=custom/speaktime/5
+ '[' '!' -f /home/irlp/audio/custom/speaktime/5.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5'
+ case $p in
+ p=am
+ say am
+ file=custom/speaktime/am
+ '[' '!' -f /home/irlp/audio/custom/speaktime/am.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ saytime ' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ /home/irlp/bin/cosstate
+ cd /home/irlp/custom
+ speak ' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ /home/irlp/scripts/wavplay custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am
+ exit 0

But there was no audio played over the node repeater; just a key-up and unkey.

I am not very skilled at bash scripts; I've attempted some diagnosis with the files, but with no results.

I have not modified the speaktime or wavplay scripts; I copied them from the backup files, as-is.

Any diagnostic, troubleshooting, or previous experiences on how I should proceed are most appreciated.

Thank you.

Rob, N6ROB
(stn3671, K6SA)

Rob Vance
 

One more thing, we have also noticed that the connect/disconnect messages for EchoIRLP are not working.  I hadn't taken the time to investigate that issue.  The connect/disconnect messages for IRLP work fine.

Rob Vance
408.221.5728


On Fri, Nov 22, 2019 at 11:07 AM Rob Vance <n6rob.rob@...> wrote:
Hi Dave,

Thanks for the help.  Here is the change I made to the speaktime script:

# Function to play the audio files
#
function speak () {
#  ${SCRIPT}/wavplay ${1}
    aplay ${1}
}

and the output...
repeater@stn3671:~/features/speaktime$ ./speaktime
custom/speaktime/the_time_is: No such file or directory

Here is the symlink from $AUDIO/custom back to features/speaktime/audio
lrwxrwxrwx 1 repeater repeater      33 Jan  8  2013 S69 -> /home/irlp/features/star69/audio/
lrwxrwxrwx 1 repeater repeater      36 Jan 10  2013 speakdate -> /home/irlp/features/speakdate/audio/
lrwxrwxrwx 1 repeater repeater      36 Nov 21 21:45 speaktime -> /home/irlp/features/speaktime/audio/

Here is the file list for audio...
repeater@stn3671:~/features/speaktime/audio$ ls -l | grep the_time_is
-rwxrwxrwx 1 repeater repeater   12244 Feb 23  2004 the_time_is_aus.wav
-rwxrwxrwx 1 repeater repeater    7818 Aug  8  2006 the_time_is.ul
-rwxrwxrwx 1 repeater repeater    5748 May 14  2003 the_time_is.wav

Also, I should have mentioned before that I checked the script and it's starts with #!/bin/bash.  Some threads mention this as a potential problem.
#!/bin/bash
########################################################################
# filename:     speaktime

The speaktime script I am using originates from KC6HUR.

This just feels like I am doing something wrong; I tried your scripts as well - still, no joy.  ... like there will be a big face-palm in the near future.

Thank you!

Rob, N6ROB
(stn3671, K6SA)


On Fri, Nov 22, 2019 at 10:28 AM Dave Parks - WB8ODF via Groups.Io <wb8odf=yahoo.com@groups.io> wrote:
Hi Rob,

Lets try something simple...

You said it seems to do everything except play the wav files.

Edit the script and change either play or wavplay (whichever is in the script) to aplay and see if that helps.



On Friday, November 22, 2019, 12:49:58 PM EST, Rob Vance <n6rob.rob@...> wrote:


Greetings,

I recently restored our note (stn3671) from a backup file - apparently the SD card failed.  I followed the instructions here: http://www.irlp.net/pi/directions.txt

This is a PiRLP purchased from irlp.net; so it has the "features" directory with several functions including speaktime.  The speaktime function does not output any audio.  The function will PTT the repeater, but no audio is played.  Research on the topic led me to investigate permissions, file locations, etc. as this the most likely problem (e.g. wavplay can't find the audio file).  I have done this manually at the command line:

key
play/$AUDIO/stn3671
unkey

And the audio output performs as intended.

Also, speakdate works just as it's supposed to.

I've checked permissions, the symlink (from $AUDIO/custom/speaktime -> to features/speaktime/audio)

When running wavplay from the command line; it doesn't produce any audio, either. Such as...

repeater@stn3671:~/scripts$ ./wavplay ref9990
repeater@stn3671:~/scripts$ ./wavplay /custom/speaktime/the_time_is
 

From Dave Parks' instructions on another post (#65745), I did this 

repeater@stn3671:~/features/speaktime$ bash -x ./speaktime

and received this (std) output...
+ SDIR=custom/speaktime
+ SAYFILES=
+ '[' -z /home/irlp/custom ']'
+ source /home/irlp/custom/irlp_common.sh
+++ /usr/bin/whoami
++ '[' repeater '!=' repeater ']'
++ '[' TRUE '!=' TRUE ']'
+ say the_time_is
+ file=custom/speaktime/the_time_is
+ '[' '!' -f /home/irlp/audio/custom/speaktime/the_time_is.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is'
++ /bin/date '+%H %M %S %p'
+ set -hxB 08 55 31 AM
+ h=08
+ m=55
+ s=31
+ p=AM
+ case $h in
+ saynumber 08 n
+ num=08
+ zero=n
++ expr 08 / 10
++ expr 08 % 10
+ set -hxB 0 8
+ tens=0
+ unit=8
+ case $tens in
+ case $zero in
+ saydigit 8
+ case $1 in
+ say 8
+ file=custom/speaktime/8
+ '[' '!' -f /home/irlp/audio/custom/speaktime/8.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8'
+ case $m in
+ saynumber 55 y
+ num=55
+ zero=y
++ expr 55 / 10
++ expr 55 % 10
+ set -hxB 5 5
+ tens=5
+ unit=5
+ case $tens in
+ say 50
+ file=custom/speaktime/50
+ '[' '!' -f /home/irlp/audio/custom/speaktime/50.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50'
+ saydigit 5
+ case $1 in
+ say 5
+ file=custom/speaktime/5
+ '[' '!' -f /home/irlp/audio/custom/speaktime/5.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5'
+ case $p in
+ p=am
+ say am
+ file=custom/speaktime/am
+ '[' '!' -f /home/irlp/audio/custom/speaktime/am.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ saytime ' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ /home/irlp/bin/cosstate
+ cd /home/irlp/custom
+ speak ' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ /home/irlp/scripts/wavplay custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am
+ exit 0

But there was no audio played over the node repeater; just a key-up and unkey.

I am not very skilled at bash scripts; I've attempted some diagnosis with the files, but with no results.

I have not modified the speaktime or wavplay scripts; I copied them from the backup files, as-is.

Any diagnostic, troubleshooting, or previous experiences on how I should proceed are most appreciated.

Thank you.

Rob, N6ROB
(stn3671, K6SA)

 

Ron,

What happens if you manually run a wav file?

key
aplay whateverfile.wav
unkey

Since you said it does everything except play the files

And good idea to change from bin/sh to bin/bash


>< Dave Parks ><
WB8ODF@...
http://wb8odf.com



On Friday, November 22, 2019, 2:08:20 PM EST, Rob Vance <n6rob.rob@...> wrote:


Hi Dave,

Thanks for the help.  Here is the change I made to the speaktime script:

# Function to play the audio files
#
function speak () {
#  ${SCRIPT}/wavplay ${1}
    aplay ${1}
}

and the output...
repeater@stn3671:~/features/speaktime$ ./speaktime
custom/speaktime/the_time_is: No such file or directory

Here is the symlink from $AUDIO/custom back to features/speaktime/audio
lrwxrwxrwx 1 repeater repeater      33 Jan  8  2013 S69 -> /home/irlp/features/star69/audio/
lrwxrwxrwx 1 repeater repeater      36 Jan 10  2013 speakdate -> /home/irlp/features/speakdate/audio/
lrwxrwxrwx 1 repeater repeater      36 Nov 21 21:45 speaktime -> /home/irlp/features/speaktime/audio/

Here is the file list for audio...
repeater@stn3671:~/features/speaktime/audio$ ls -l | grep the_time_is
-rwxrwxrwx 1 repeater repeater   12244 Feb 23  2004 the_time_is_aus.wav
-rwxrwxrwx 1 repeater repeater    7818 Aug  8  2006 the_time_is.ul
-rwxrwxrwx 1 repeater repeater    5748 May 14  2003 the_time_is.wav

Also, I should have mentioned before that I checked the script and it's starts with #!/bin/bash.  Some threads mention this as a potential problem.
#!/bin/bash
########################################################################
# filename:     speaktime

The speaktime script I am using originates from KC6HUR.

This just feels like I am doing something wrong; I tried your scripts as well - still, no joy.  ... like there will be a big face-palm in the near future.

Thank you!

Rob, N6ROB
(stn3671, K6SA)


On Fri, Nov 22, 2019 at 10:28 AM Dave Parks - WB8ODF via Groups.Io <wb8odf=yahoo.com@groups.io> wrote:
Hi Rob,

Lets try something simple...

You said it seems to do everything except play the wav files.

Edit the script and change either play or wavplay (whichever is in the script) to aplay and see if that helps.



On Friday, November 22, 2019, 12:49:58 PM EST, Rob Vance <n6rob.rob@...> wrote:


Greetings,

I recently restored our note (stn3671) from a backup file - apparently the SD card failed.  I followed the instructions here: http://www.irlp.net/pi/directions.txt

This is a PiRLP purchased from irlp.net; so it has the "features" directory with several functions including speaktime.  The speaktime function does not output any audio.  The function will PTT the repeater, but no audio is played.  Research on the topic led me to investigate permissions, file locations, etc. as this the most likely problem (e.g. wavplay can't find the audio file).  I have done this manually at the command line:

key
play/$AUDIO/stn3671
unkey

And the audio output performs as intended.

Also, speakdate works just as it's supposed to.

I've checked permissions, the symlink (from $AUDIO/custom/speaktime -> to features/speaktime/audio)

When running wavplay from the command line; it doesn't produce any audio, either. Such as...

repeater@stn3671:~/scripts$ ./wavplay ref9990
repeater@stn3671:~/scripts$ ./wavplay /custom/speaktime/the_time_is
 

From Dave Parks' instructions on another post (#65745), I did this 

repeater@stn3671:~/features/speaktime$ bash -x ./speaktime

and received this (std) output...
+ SDIR=custom/speaktime
+ SAYFILES=
+ '[' -z /home/irlp/custom ']'
+ source /home/irlp/custom/irlp_common.sh
+++ /usr/bin/whoami
++ '[' repeater '!=' repeater ']'
++ '[' TRUE '!=' TRUE ']'
+ say the_time_is
+ file=custom/speaktime/the_time_is
+ '[' '!' -f /home/irlp/audio/custom/speaktime/the_time_is.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is'
++ /bin/date '+%H %M %S %p'
+ set -hxB 08 55 31 AM
+ h=08
+ m=55
+ s=31
+ p=AM
+ case $h in
+ saynumber 08 n
+ num=08
+ zero=n
++ expr 08 / 10
++ expr 08 % 10
+ set -hxB 0 8
+ tens=0
+ unit=8
+ case $tens in
+ case $zero in
+ saydigit 8
+ case $1 in
+ say 8
+ file=custom/speaktime/8
+ '[' '!' -f /home/irlp/audio/custom/speaktime/8.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8'
+ case $m in
+ saynumber 55 y
+ num=55
+ zero=y
++ expr 55 / 10
++ expr 55 % 10
+ set -hxB 5 5
+ tens=5
+ unit=5
+ case $tens in
+ say 50
+ file=custom/speaktime/50
+ '[' '!' -f /home/irlp/audio/custom/speaktime/50.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50'
+ saydigit 5
+ case $1 in
+ say 5
+ file=custom/speaktime/5
+ '[' '!' -f /home/irlp/audio/custom/speaktime/5.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5'
+ case $p in
+ p=am
+ say am
+ file=custom/speaktime/am
+ '[' '!' -f /home/irlp/audio/custom/speaktime/am.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ saytime ' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ /home/irlp/bin/cosstate
+ cd /home/irlp/custom
+ speak ' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ /home/irlp/scripts/wavplay custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am
+ exit 0

But there was no audio played over the node repeater; just a key-up and unkey.

I am not very skilled at bash scripts; I've attempted some diagnosis with the files, but with no results.

I have not modified the speaktime or wavplay scripts; I copied them from the backup files, as-is.

Any diagnostic, troubleshooting, or previous experiences on how I should proceed are most appreciated.

Thank you.

Rob, N6ROB
(stn3671, K6SA)

Rob Vance
 

Hi Dave,

Yes, did that...

I have done this manually at the command line:
key
play/$AUDIO/stn3671
unkey
And the audio output performs as intended.

However, doing this did NOT work...
repeater@stn3671:~$ key
repeater@stn3671:~$ aplay /home/irlp/features/speaktime/audio/the_time_is.wav
aplay: test_wavefile:1054: can't play WAVE-file format 0x0007 which is not PCM or FLOAT encoded
repeater@stn3671:~$ unkey

Rob Vance
408.221.5728


On Fri, Nov 22, 2019 at 11:16 AM Dave Parks - WB8ODF via Groups.Io <wb8odf=yahoo.com@groups.io> wrote:
Ron,

What happens if you manually run a wav file?

key
aplay whateverfile.wav
unkey

Since you said it does everything except play the files

And good idea to change from bin/sh to bin/bash



On Friday, November 22, 2019, 2:08:20 PM EST, Rob Vance <n6rob.rob@...> wrote:


Hi Dave,

Thanks for the help.  Here is the change I made to the speaktime script:

# Function to play the audio files
#
function speak () {
#  ${SCRIPT}/wavplay ${1}
    aplay ${1}
}

and the output...
repeater@stn3671:~/features/speaktime$ ./speaktime
custom/speaktime/the_time_is: No such file or directory

Here is the symlink from $AUDIO/custom back to features/speaktime/audio
lrwxrwxrwx 1 repeater repeater      33 Jan  8  2013 S69 -> /home/irlp/features/star69/audio/
lrwxrwxrwx 1 repeater repeater      36 Jan 10  2013 speakdate -> /home/irlp/features/speakdate/audio/
lrwxrwxrwx 1 repeater repeater      36 Nov 21 21:45 speaktime -> /home/irlp/features/speaktime/audio/

Here is the file list for audio...
repeater@stn3671:~/features/speaktime/audio$ ls -l | grep the_time_is
-rwxrwxrwx 1 repeater repeater   12244 Feb 23  2004 the_time_is_aus.wav
-rwxrwxrwx 1 repeater repeater    7818 Aug  8  2006 the_time_is.ul
-rwxrwxrwx 1 repeater repeater    5748 May 14  2003 the_time_is.wav

Also, I should have mentioned before that I checked the script and it's starts with #!/bin/bash.  Some threads mention this as a potential problem.
#!/bin/bash
########################################################################
# filename:     speaktime

The speaktime script I am using originates from KC6HUR.

This just feels like I am doing something wrong; I tried your scripts as well - still, no joy.  ... like there will be a big face-palm in the near future.

Thank you!

Rob, N6ROB
(stn3671, K6SA)


On Fri, Nov 22, 2019 at 10:28 AM Dave Parks - WB8ODF via Groups.Io <wb8odf=yahoo.com@groups.io> wrote:
Hi Rob,

Lets try something simple...

You said it seems to do everything except play the wav files.

Edit the script and change either play or wavplay (whichever is in the script) to aplay and see if that helps.



On Friday, November 22, 2019, 12:49:58 PM EST, Rob Vance <n6rob.rob@...> wrote:


Greetings,

I recently restored our note (stn3671) from a backup file - apparently the SD card failed.  I followed the instructions here: http://www.irlp.net/pi/directions.txt

This is a PiRLP purchased from irlp.net; so it has the "features" directory with several functions including speaktime.  The speaktime function does not output any audio.  The function will PTT the repeater, but no audio is played.  Research on the topic led me to investigate permissions, file locations, etc. as this the most likely problem (e.g. wavplay can't find the audio file).  I have done this manually at the command line:

key
play/$AUDIO/stn3671
unkey

And the audio output performs as intended.

Also, speakdate works just as it's supposed to.

I've checked permissions, the symlink (from $AUDIO/custom/speaktime -> to features/speaktime/audio)

When running wavplay from the command line; it doesn't produce any audio, either. Such as...

repeater@stn3671:~/scripts$ ./wavplay ref9990
repeater@stn3671:~/scripts$ ./wavplay /custom/speaktime/the_time_is
 

From Dave Parks' instructions on another post (#65745), I did this 

repeater@stn3671:~/features/speaktime$ bash -x ./speaktime

and received this (std) output...
+ SDIR=custom/speaktime
+ SAYFILES=
+ '[' -z /home/irlp/custom ']'
+ source /home/irlp/custom/irlp_common.sh
+++ /usr/bin/whoami
++ '[' repeater '!=' repeater ']'
++ '[' TRUE '!=' TRUE ']'
+ say the_time_is
+ file=custom/speaktime/the_time_is
+ '[' '!' -f /home/irlp/audio/custom/speaktime/the_time_is.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is'
++ /bin/date '+%H %M %S %p'
+ set -hxB 08 55 31 AM
+ h=08
+ m=55
+ s=31
+ p=AM
+ case $h in
+ saynumber 08 n
+ num=08
+ zero=n
++ expr 08 / 10
++ expr 08 % 10
+ set -hxB 0 8
+ tens=0
+ unit=8
+ case $tens in
+ case $zero in
+ saydigit 8
+ case $1 in
+ say 8
+ file=custom/speaktime/8
+ '[' '!' -f /home/irlp/audio/custom/speaktime/8.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8'
+ case $m in
+ saynumber 55 y
+ num=55
+ zero=y
++ expr 55 / 10
++ expr 55 % 10
+ set -hxB 5 5
+ tens=5
+ unit=5
+ case $tens in
+ say 50
+ file=custom/speaktime/50
+ '[' '!' -f /home/irlp/audio/custom/speaktime/50.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50'
+ saydigit 5
+ case $1 in
+ say 5
+ file=custom/speaktime/5
+ '[' '!' -f /home/irlp/audio/custom/speaktime/5.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5'
+ case $p in
+ p=am
+ say am
+ file=custom/speaktime/am
+ '[' '!' -f /home/irlp/audio/custom/speaktime/am.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ saytime ' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ /home/irlp/bin/cosstate
+ cd /home/irlp/custom
+ speak ' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ /home/irlp/scripts/wavplay custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am
+ exit 0

But there was no audio played over the node repeater; just a key-up and unkey.

I am not very skilled at bash scripts; I've attempted some diagnosis with the files, but with no results.

I have not modified the speaktime or wavplay scripts; I copied them from the backup files, as-is.

Any diagnostic, troubleshooting, or previous experiences on how I should proceed are most appreciated.

Thank you.

Rob, N6ROB
(stn3671, K6SA)

 

You're still showing that you used play and not aplay, was that a typo?


>< Dave Parks ><
WB8ODF@...
http://wb8odf.com



On Friday, November 22, 2019, 2:23:42 PM EST, Rob Vance <n6rob.rob@...> wrote:


Hi Dave,

Yes, did that...

I have done this manually at the command line:
key
play/$AUDIO/stn3671
unkey
And the audio output performs as intended.

However, doing this did NOT work...
repeater@stn3671:~$ key
repeater@stn3671:~$ aplay /home/irlp/features/speaktime/audio/the_time_is.wav
aplay: test_wavefile:1054: can't play WAVE-file format 0x0007 which is not PCM or FLOAT encoded
repeater@stn3671:~$ unkey

Rob Vance
408.221.5728


On Fri, Nov 22, 2019 at 11:16 AM Dave Parks - WB8ODF via Groups.Io <wb8odf=yahoo.com@groups.io> wrote:
Ron,

What happens if you manually run a wav file?

key
aplay whateverfile.wav
unkey

Since you said it does everything except play the files

And good idea to change from bin/sh to bin/bash



On Friday, November 22, 2019, 2:08:20 PM EST, Rob Vance <n6rob.rob@...> wrote:


Hi Dave,

Thanks for the help.  Here is the change I made to the speaktime script:

# Function to play the audio files
#
function speak () {
#  ${SCRIPT}/wavplay ${1}
    aplay ${1}
}

and the output...
repeater@stn3671:~/features/speaktime$ ./speaktime
custom/speaktime/the_time_is: No such file or directory

Here is the symlink from $AUDIO/custom back to features/speaktime/audio
lrwxrwxrwx 1 repeater repeater      33 Jan  8  2013 S69 -> /home/irlp/features/star69/audio/
lrwxrwxrwx 1 repeater repeater      36 Jan 10  2013 speakdate -> /home/irlp/features/speakdate/audio/
lrwxrwxrwx 1 repeater repeater      36 Nov 21 21:45 speaktime -> /home/irlp/features/speaktime/audio/

Here is the file list for audio...
repeater@stn3671:~/features/speaktime/audio$ ls -l | grep the_time_is
-rwxrwxrwx 1 repeater repeater   12244 Feb 23  2004 the_time_is_aus.wav
-rwxrwxrwx 1 repeater repeater    7818 Aug  8  2006 the_time_is.ul
-rwxrwxrwx 1 repeater repeater    5748 May 14  2003 the_time_is.wav

Also, I should have mentioned before that I checked the script and it's starts with #!/bin/bash.  Some threads mention this as a potential problem.
#!/bin/bash
########################################################################
# filename:     speaktime

The speaktime script I am using originates from KC6HUR.

This just feels like I am doing something wrong; I tried your scripts as well - still, no joy.  ... like there will be a big face-palm in the near future.

Thank you!

Rob, N6ROB
(stn3671, K6SA)


On Fri, Nov 22, 2019 at 10:28 AM Dave Parks - WB8ODF via Groups.Io <wb8odf=yahoo.com@groups.io> wrote:
Hi Rob,

Lets try something simple...

You said it seems to do everything except play the wav files.

Edit the script and change either play or wavplay (whichever is in the script) to aplay and see if that helps.



On Friday, November 22, 2019, 12:49:58 PM EST, Rob Vance <n6rob.rob@...> wrote:


Greetings,

I recently restored our note (stn3671) from a backup file - apparently the SD card failed.  I followed the instructions here: http://www.irlp.net/pi/directions.txt

This is a PiRLP purchased from irlp.net; so it has the "features" directory with several functions including speaktime.  The speaktime function does not output any audio.  The function will PTT the repeater, but no audio is played.  Research on the topic led me to investigate permissions, file locations, etc. as this the most likely problem (e.g. wavplay can't find the audio file).  I have done this manually at the command line:

key
play/$AUDIO/stn3671
unkey

And the audio output performs as intended.

Also, speakdate works just as it's supposed to.

I've checked permissions, the symlink (from $AUDIO/custom/speaktime -> to features/speaktime/audio)

When running wavplay from the command line; it doesn't produce any audio, either. Such as...

repeater@stn3671:~/scripts$ ./wavplay ref9990
repeater@stn3671:~/scripts$ ./wavplay /custom/speaktime/the_time_is
 

From Dave Parks' instructions on another post (#65745), I did this 

repeater@stn3671:~/features/speaktime$ bash -x ./speaktime

and received this (std) output...
+ SDIR=custom/speaktime
+ SAYFILES=
+ '[' -z /home/irlp/custom ']'
+ source /home/irlp/custom/irlp_common.sh
+++ /usr/bin/whoami
++ '[' repeater '!=' repeater ']'
++ '[' TRUE '!=' TRUE ']'
+ say the_time_is
+ file=custom/speaktime/the_time_is
+ '[' '!' -f /home/irlp/audio/custom/speaktime/the_time_is.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is'
++ /bin/date '+%H %M %S %p'
+ set -hxB 08 55 31 AM
+ h=08
+ m=55
+ s=31
+ p=AM
+ case $h in
+ saynumber 08 n
+ num=08
+ zero=n
++ expr 08 / 10
++ expr 08 % 10
+ set -hxB 0 8
+ tens=0
+ unit=8
+ case $tens in
+ case $zero in
+ saydigit 8
+ case $1 in
+ say 8
+ file=custom/speaktime/8
+ '[' '!' -f /home/irlp/audio/custom/speaktime/8.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8'
+ case $m in
+ saynumber 55 y
+ num=55
+ zero=y
++ expr 55 / 10
++ expr 55 % 10
+ set -hxB 5 5
+ tens=5
+ unit=5
+ case $tens in
+ say 50
+ file=custom/speaktime/50
+ '[' '!' -f /home/irlp/audio/custom/speaktime/50.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50'
+ saydigit 5
+ case $1 in
+ say 5
+ file=custom/speaktime/5
+ '[' '!' -f /home/irlp/audio/custom/speaktime/5.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5'
+ case $p in
+ p=am
+ say am
+ file=custom/speaktime/am
+ '[' '!' -f /home/irlp/audio/custom/speaktime/am.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ saytime ' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ /home/irlp/bin/cosstate
+ cd /home/irlp/custom
+ speak ' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ /home/irlp/scripts/wavplay custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am
+ exit 0

But there was no audio played over the node repeater; just a key-up and unkey.

I am not very skilled at bash scripts; I've attempted some diagnosis with the files, but with no results.

I have not modified the speaktime or wavplay scripts; I copied them from the backup files, as-is.

Any diagnostic, troubleshooting, or previous experiences on how I should proceed are most appreciated.

Thank you.

Rob, N6ROB
(stn3671, K6SA)

 

OH that's my "I can't read" fault, I see you said it played as intended LOL


>< Dave Parks ><
WB8ODF@...
http://wb8odf.com



On Friday, November 22, 2019, 2:28:31 PM EST, Dave Parks - WB8ODF via Groups.Io <wb8odf@...> wrote:


You're still showing that you used play and not aplay, was that a typo?


>< Dave Parks ><
WB8ODF@...
http://wb8odf.com



On Friday, November 22, 2019, 2:23:42 PM EST, Rob Vance <n6rob.rob@...> wrote:


Hi Dave,

Yes, did that...

I have done this manually at the command line:
key
play/$AUDIO/stn3671
unkey
And the audio output performs as intended.

However, doing this did NOT work...
repeater@stn3671:~$ key
repeater@stn3671:~$ aplay /home/irlp/features/speaktime/audio/the_time_is.wav
aplay: test_wavefile:1054: can't play WAVE-file format 0x0007 which is not PCM or FLOAT encoded
repeater@stn3671:~$ unkey

Rob Vance
408.221.5728


On Fri, Nov 22, 2019 at 11:16 AM Dave Parks - WB8ODF via Groups.Io <wb8odf=yahoo.com@groups.io> wrote:
Ron,

What happens if you manually run a wav file?

key
aplay whateverfile.wav
unkey

Since you said it does everything except play the files

And good idea to change from bin/sh to bin/bash



On Friday, November 22, 2019, 2:08:20 PM EST, Rob Vance <n6rob.rob@...> wrote:


Hi Dave,

Thanks for the help.  Here is the change I made to the speaktime script:

# Function to play the audio files
#
function speak () {
#  ${SCRIPT}/wavplay ${1}
    aplay ${1}
}

and the output...
repeater@stn3671:~/features/speaktime$ ./speaktime
custom/speaktime/the_time_is: No such file or directory

Here is the symlink from $AUDIO/custom back to features/speaktime/audio
lrwxrwxrwx 1 repeater repeater      33 Jan  8  2013 S69 -> /home/irlp/features/star69/audio/
lrwxrwxrwx 1 repeater repeater      36 Jan 10  2013 speakdate -> /home/irlp/features/speakdate/audio/
lrwxrwxrwx 1 repeater repeater      36 Nov 21 21:45 speaktime -> /home/irlp/features/speaktime/audio/

Here is the file list for audio...
repeater@stn3671:~/features/speaktime/audio$ ls -l | grep the_time_is
-rwxrwxrwx 1 repeater repeater   12244 Feb 23  2004 the_time_is_aus.wav
-rwxrwxrwx 1 repeater repeater    7818 Aug  8  2006 the_time_is.ul
-rwxrwxrwx 1 repeater repeater    5748 May 14  2003 the_time_is.wav

Also, I should have mentioned before that I checked the script and it's starts with #!/bin/bash.  Some threads mention this as a potential problem.
#!/bin/bash
########################################################################
# filename:     speaktime

The speaktime script I am using originates from KC6HUR.

This just feels like I am doing something wrong; I tried your scripts as well - still, no joy.  ... like there will be a big face-palm in the near future.

Thank you!

Rob, N6ROB
(stn3671, K6SA)


On Fri, Nov 22, 2019 at 10:28 AM Dave Parks - WB8ODF via Groups.Io <wb8odf=yahoo.com@groups.io> wrote:
Hi Rob,

Lets try something simple...

You said it seems to do everything except play the wav files.

Edit the script and change either play or wavplay (whichever is in the script) to aplay and see if that helps.



On Friday, November 22, 2019, 12:49:58 PM EST, Rob Vance <n6rob.rob@...> wrote:


Greetings,

I recently restored our note (stn3671) from a backup file - apparently the SD card failed.  I followed the instructions here: http://www.irlp.net/pi/directions.txt

This is a PiRLP purchased from irlp.net; so it has the "features" directory with several functions including speaktime.  The speaktime function does not output any audio.  The function will PTT the repeater, but no audio is played.  Research on the topic led me to investigate permissions, file locations, etc. as this the most likely problem (e.g. wavplay can't find the audio file).  I have done this manually at the command line:

key
play/$AUDIO/stn3671
unkey

And the audio output performs as intended.

Also, speakdate works just as it's supposed to.

I've checked permissions, the symlink (from $AUDIO/custom/speaktime -> to features/speaktime/audio)

When running wavplay from the command line; it doesn't produce any audio, either. Such as...

repeater@stn3671:~/scripts$ ./wavplay ref9990
repeater@stn3671:~/scripts$ ./wavplay /custom/speaktime/the_time_is
 

From Dave Parks' instructions on another post (#65745), I did this 

repeater@stn3671:~/features/speaktime$ bash -x ./speaktime

and received this (std) output...
+ SDIR=custom/speaktime
+ SAYFILES=
+ '[' -z /home/irlp/custom ']'
+ source /home/irlp/custom/irlp_common.sh
+++ /usr/bin/whoami
++ '[' repeater '!=' repeater ']'
++ '[' TRUE '!=' TRUE ']'
+ say the_time_is
+ file=custom/speaktime/the_time_is
+ '[' '!' -f /home/irlp/audio/custom/speaktime/the_time_is.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is'
++ /bin/date '+%H %M %S %p'
+ set -hxB 08 55 31 AM
+ h=08
+ m=55
+ s=31
+ p=AM
+ case $h in
+ saynumber 08 n
+ num=08
+ zero=n
++ expr 08 / 10
++ expr 08 % 10
+ set -hxB 0 8
+ tens=0
+ unit=8
+ case $tens in
+ case $zero in
+ saydigit 8
+ case $1 in
+ say 8
+ file=custom/speaktime/8
+ '[' '!' -f /home/irlp/audio/custom/speaktime/8.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8'
+ case $m in
+ saynumber 55 y
+ num=55
+ zero=y
++ expr 55 / 10
++ expr 55 % 10
+ set -hxB 5 5
+ tens=5
+ unit=5
+ case $tens in
+ say 50
+ file=custom/speaktime/50
+ '[' '!' -f /home/irlp/audio/custom/speaktime/50.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50'
+ saydigit 5
+ case $1 in
+ say 5
+ file=custom/speaktime/5
+ '[' '!' -f /home/irlp/audio/custom/speaktime/5.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5'
+ case $p in
+ p=am
+ say am
+ file=custom/speaktime/am
+ '[' '!' -f /home/irlp/audio/custom/speaktime/am.ul ']'
+ SAYFILES=' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ saytime ' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ /home/irlp/bin/cosstate
+ cd /home/irlp/custom
+ speak ' custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am'
+ /home/irlp/scripts/wavplay custom/speaktime/the_time_is custom/speaktime/8 custom/speaktime/50 custom/speaktime/5 custom/speaktime/am
+ exit 0

But there was no audio played over the node repeater; just a key-up and unkey.

I am not very skilled at bash scripts; I've attempted some diagnosis with the files, but with no results.

I have not modified the speaktime or wavplay scripts; I copied them from the backup files, as-is.

Any diagnostic, troubleshooting, or previous experiences on how I should proceed are most appreciated.

Thank you.

Rob, N6ROB
(stn3671, K6SA)

David Cameron - IRLP
 

This whole issue was discussed a while ago, and it all pertains to the use of the sox program, specifically two flags that are deprecated.

I made updates to the systems that I build, but since I am not the writer of the original scripts, I was not able to update them.

The problems extend to EchoIRLP as well - same issue - sox is using arguments that are no longer supported.

I am not in a place that I can pull up the details, sorry.

Dave Cameron

On 2019-11-22 11:29, Dave Parks - WB8ODF via Groups.Io wrote:
OH that's my "I can't read" fault, I see you said it played as
intended LOL

< Dave Parks ><
@WB8ODF
http://wb8odf.com
Node: 8139
On Friday, November 22, 2019, 2:28:31 PM EST, Dave Parks - WB8ODF via
Groups.Io <wb8odf=yahoo.com@groups.io> wrote:
You're still showing that you used play and not aplay, was that a
typo?

Rob Vance
 

Thank you Dave & Dave.

@Dave C.  when you have the chance if you can let me know what my options are for getting it to work, or for further diagnostics, I would appreciate it.

@Dave Parks:  to your point I decided to try it another way, interesting results...

repeater@stn3671:~$ key
repeater@stn3671:~$ play /home/irlp/features/speaktime/audio/the_time_is.wav
play WARN alsa: can't encode 0-bit Unknown or not applicable
/home/irlp/features/speaktime/audio/the_time_is.wav:
 File Size: 5.75k     Bit Rate: 64.7k
  Encoding: u-law        
  Channels: 1 @ 14-bit  
Samplerate: 8000Hz      
Replaygain: off        
  Duration: 00:00:00.71  
In:100%  00:00:00.71 [00:00:00.00] Out:34.1k [      |      ] Hd:1.8 Clip:0    
Done.
repeater@stn3671:~$ unkey

So, "play" works but "aplay" doesn't.  Even though "play" just calls "aplay".  Hmmm.

Rob Vance



On Fri, Nov 22, 2019 at 11:54 AM David Cameron - IRLP <dcameron@...> wrote:
This whole issue was discussed a while ago, and it all pertains to the
use of the sox program, specifically two flags that are deprecated.

I made updates to the systems that I build, but since I am not the
writer of the original scripts, I was not able to update them.

The problems extend to EchoIRLP as well - same issue - sox is using
arguments that are no longer supported.

I am not in a place that I can pull up the details, sorry.

Dave Cameron


On 2019-11-22 11:29, Dave Parks - WB8ODF via Groups.Io wrote:
> OH that's my "I can't read" fault, I see you said it played as
> intended LOL
>
>> < Dave Parks ><
> WB8ODF@...
> http://wb8odf.com
>
> Node: 8139
>
>  On Friday, November 22, 2019, 2:28:31 PM EST, Dave Parks - WB8ODF via
> Groups.Io <wb8odf=yahoo.com@groups.io> wrote:
>
> You're still showing that you used play and not aplay, was that a
> typo?
>




 

Rob,

I'll bet Dave C will get you squared away, if not... I'll help ya out, please keep the group informed.

I know Dave C's feeling on this, through the years programmers of "Linux" and it's programs seem to change their flags with no rhyme or reason.

They first broke some of my scripts by deciding that the play program no longer needed the -V flag (volume) so the people using my scripts no longer had control of the scripts volume.

Grrrrrrr lol


>< Dave Parks ><
WB8ODF@...
http://wb8odf.com



On Friday, November 22, 2019, 5:00:22 PM EST, Rob Vance <n6rob.rob@...> wrote:


Thank you Dave & Dave.

@Dave C.  when you have the chance if you can let me know what my options are for getting it to work, or for further diagnostics, I would appreciate it.

@Dave Parks:  to your point I decided to try it another way, interesting results...

repeater@stn3671:~$ key
repeater@stn3671:~$ play /home/irlp/features/speaktime/audio/the_time_is.wav
play WARN alsa: can't encode 0-bit Unknown or not applicable
/home/irlp/features/speaktime/audio/the_time_is.wav:
 File Size: 5.75k     Bit Rate: 64.7k
  Encoding: u-law        
  Channels: 1 @ 14-bit  
Samplerate: 8000Hz      
Replaygain: off        
  Duration: 00:00:00.71  
In:100%  00:00:00.71 [00:00:00.00] Out:34.1k [      |      ] Hd:1.8 Clip:0    
Done.
repeater@stn3671:~$ unkey

So, "play" works but "aplay" doesn't.  Even though "play" just calls "aplay".  Hmmm.

Rob Vance



On Fri, Nov 22, 2019 at 11:54 AM David Cameron - IRLP <dcameron@...> wrote:
This whole issue was discussed a while ago, and it all pertains to the
use of the sox program, specifically two flags that are deprecated.

I made updates to the systems that I build, but since I am not the
writer of the original scripts, I was not able to update them.

The problems extend to EchoIRLP as well - same issue - sox is using
arguments that are no longer supported.

I am not in a place that I can pull up the details, sorry.

Dave Cameron


On 2019-11-22 11:29, Dave Parks - WB8ODF via Groups.Io wrote:
> OH that's my "I can't read" fault, I see you said it played as
> intended LOL
>
>> < Dave Parks ><
> WB8ODF@...
> http://wb8odf.com
>
> Node: 8139
>
>  On Friday, November 22, 2019, 2:28:31 PM EST, Dave Parks - WB8ODF via
> Groups.Io <wb8odf=yahoo.com@groups.io> wrote:
>
> You're still showing that you used play and not aplay, was that a
> typo?
>




Nosey Nick VA3NNW
 

Dave Parks - WB8ODF via Groups.Io wrote:
I know Dave C's feeling on this, through the years programmers of "Linux" and it's programs seem to change their flags with no rhyme or reason.

Whereas all the programmers of, say, "Microsoft Windows" and all it's 3rd-party programs, they have NEVER changed a thing? Yuh, sure   :-D

I *THINK* the problem here is that scripts/wavplay has at least 2 or 3 modes of operation:

Mode 1: USE_APLAY=YES ? Convert any FILE.ul to FILE.wav and aplay all the WAVs

Mode 1b: USE_APLAY=YES, and they are already all FILE.wav, and there's NO FILE.ul, no conversion required, simply aplay all the (existing) WAVs.

Mode 2: Otherwise if there IS NO FILE.ul, convert each FILE.wav to a temporary FILE.ul, join all the .ul files together into one big ul file, convert that back to a .wav, and $PLAY that.

You follow? Good so far EXCEPT neither of the conversions work with recent versions of "sox" (which is totally sox's fault, regardless of whether you choose to run sox on Linux, Windows, Mac, NetBSD or Commodore 64). This removes the usefulness of mode 1 and mode 2. The only mode that can still work is 1b, when USE_APLAY=YES, and when they are ALREADY FILE.wav. Luckily USE_APLAY=YES by default these days, and ALMOST every part of IRLP uses WAVs not .ul any longer, so you're ALMOST always using 1b and everything just works.

... except saytime uses audio/custom/*.ul which have not been converted to WAVs yet, so that takes mode 1b off the table too.

Possible solution A:

edit scripts/wavplay and fix the "sox" commands that are used for the conversions.

Assuming "sox --version" is quite new (mine is 14.4.2), everywhere it says "sox BLAH.ul -s -u BLAH.wav" (it MUST be a ul to a wav, and it must have the -s -u) ... change it to "sox BLAH.ul -e un BLAH.wav" (basically ONLY replace "-s -u" with "-e un" and leave the rest of the lines intact). There are at least 2 places to make this edit.

*AND* make sure your fixed scripts/wavplay doesn't get "fixed" back again every night when your machine updates itself, because you're not supposed to touch scripts/stuff, only custom/stuff. This is left as an exercise for the reader, your two hints are to read the "rsync" manpage, and to (ab)use this:

scripts/update:    UPDATEFILELIST="`cat ${CUSTOM}/update-file-list`"

*AND* make sure you DO eventually "fix" it to a new updated scripts/wavplay sometime if/after this problem is fixed, if ever. This is also left as an exercise for the reader, because really I'm not happy with any of "possible solution A" because of these last 2 points. I think I'd prefer you go for something like...

Possible solution B:

Make sure you have the aplay command. Try just typing "aplay" and see if you get a big help text (good) not "command not found" (bad).

Make sure you export USE_APLAY=YES in custom/environment

Convert all remaining FILE.ul to FILE.wav, as that appears to be the current IRLP standard anyway.

A script to TEST this conversion would be:

find audio -name '*.ul' | sed -E 's/(.*)\.ul/sox "&" -e un "\1.wav" \&\& mv "&" "&-OLD"/'

Be *EXTREMELY* careful with quotes, punctuation, spacing, and word-wrap when copying the above command. Cut+paste would be MUCH safer.

The above should output a list of conversion commands but NOT run them. If they look safe and you're happy to run them, you could copy+paste them into the same terminal, or alternatively:

find audio -name '*.ul' | sed -E 's/(.*)\.ul/sox "&" -e un "\1.wav" \&\& mv "&" "&-OLD"/' | sh

... which is exactly the same except with | sh on the end. You can almost certainly up-cursor, | (that's a pipe, probably shift-\, not a1, i, I, l, nor L), sh, return.

HOWEVER, that's not the whole story either, because some/many old versions of "saytime" are ignoring the very nice scripts/wavplay, INSISTING on the .ul files being present, and ignoring USE_APLAY=YES and writing direct to /dev/audio which you can't safely do any more unless you're running a dangerously old Linux.

So ALSO edit your "saytime". First, make a backup copy of this file in case you make things worse, then replace:

say () {
        file=$SDIR/$1.ul
        if [ ! -f $file ] ; then
                echo "`basename $0`: cannot find $file"
                exit 1
        fi
        SAYFILES="$SAYFILES $file"
}

... with just:

say () {
        SAYFILES="$SAYFILES custom/$1"
}

... and at the end, if it says:

cat $SAYFILES > /dev/audio

replace the line completely with:

$SCRIPT/wavplay  $SAYFILES

I *THINK* saytime will then work. I make no promises. I'll admit I've done NEITHER of the above Solution A/B, I've gone for Possible Solution C:

Rewrite saytime completely. Have it use a nice new clean set of synthesized WAVs, use IRLP-standard wavplay properly (and hence support USE_APLAY), support UTC or local time or both, add an optional voice ID/call, hey why not optionally read a short local weather forecast too?   :-D

... however I'm unfortunately not yet able to share my scripts for Solution C. Partly because the "local" weather is only local to Canada at the moment.   :-/

I might be talked into releasing a straight simple replacement for saytime if Solution B doesn't work for you.

Nick VA3NNW

-- 
"Nosey" Nick Waterman, VA3NNW/G7RZQ, K2 #5209.
use Std::Disclaimer;    sig@...
Numeric stability is probably not all that important when you're guessing.


 

WOW Nick,

That was a whole lot of stuff I can't wrap my head around.

There is NO REASON to use sox in any of the IRLP scripts, I never understood why Dave C used it.... EVER

I'm sure Dave C is going to fix his script for Rob (he's good that way)... HOWEVER, I'll suggest we use my script (when I say *MY* script I mean the one I have for download on my server), I didn't write it, but I did edit it to work with Debian without the use of sox. It has worked for me since the very first version of Debian used by IRLP.

I'll step back here and let Dave C chime in with his fix for the sox problems since it actually was one of his "FEATURES" if/when purchasing one of the IRLP nodes.

We can go from there.... :)


>< Dave Parks ><
WB8ODF@...
http://wb8odf.com



On Friday, November 22, 2019, 11:21:20 PM EST, Nosey Nick VA3NNW <irlp@...> wrote:


Dave Parks - WB8ODF via Groups.Io wrote:
I know Dave C's feeling on this, through the years programmers of "Linux" and it's programs seem to change their flags with no rhyme or reason.

Whereas all the programmers of, say, "Microsoft Windows" and all it's 3rd-party programs, they have NEVER changed a thing? Yuh, sure   :-D

I *THINK* the problem here is that scripts/wavplay has at least 2 or 3 modes of operation:

Mode 1: USE_APLAY=YES ? Convert any FILE.ul to FILE.wav and aplay all the WAVs

Mode 1b: USE_APLAY=YES, and they are already all FILE.wav, and there's NO FILE.ul, no conversion required, simply aplay all the (existing) WAVs.

Mode 2: Otherwise if there IS NO FILE.ul, convert each FILE.wav to a temporary FILE.ul, join all the .ul files together into one big ul file, convert that back to a .wav, and $PLAY that.

You follow? Good so far EXCEPT neither of the conversions work with recent versions of "sox" (which is totally sox's fault, regardless of whether you choose to run sox on Linux, Windows, Mac, NetBSD or Commodore 64). This removes the usefulness of mode 1 and mode 2. The only mode that can still work is 1b, when USE_APLAY=YES, and when they are ALREADY FILE.wav. Luckily USE_APLAY=YES by default these days, and ALMOST every part of IRLP uses WAVs not .ul any longer, so you're ALMOST always using 1b and everything just works.

... except saytime uses audio/custom/*.ul which have not been converted to WAVs yet, so that takes mode 1b off the table too.

Possible solution A:

edit scripts/wavplay and fix the "sox" commands that are used for the conversions.

Assuming "sox --version" is quite new (mine is 14.4.2), everywhere it says "sox BLAH.ul -s -u BLAH.wav" (it MUST be a ul to a wav, and it must have the -s -u) ... change it to "sox BLAH.ul -e un BLAH.wav" (basically ONLY replace "-s -u" with "-e un" and leave the rest of the lines intact). There are at least 2 places to make this edit.

*AND* make sure your fixed scripts/wavplay doesn't get "fixed" back again every night when your machine updates itself, because you're not supposed to touch scripts/stuff, only custom/stuff. This is left as an exercise for the reader, your two hints are to read the "rsync" manpage, and to (ab)use this:

scripts/update:    UPDATEFILELIST="`cat ${CUSTOM}/update-file-list`"

*AND* make sure you DO eventually "fix" it to a new updated scripts/wavplay sometime if/after this problem is fixed, if ever. This is also left as an exercise for the reader, because really I'm not happy with any of "possible solution A" because of these last 2 points. I think I'd prefer you go for something like...

Possible solution B:

Make sure you have the aplay command. Try just typing "aplay" and see if you get a big help text (good) not "command not found" (bad).

Make sure you export USE_APLAY=YES in custom/environment

Convert all remaining FILE.ul to FILE.wav, as that appears to be the current IRLP standard anyway.

A script to TEST this conversion would be:

find audio -name '*.ul' | sed -E 's/(.*)\.ul/sox "&" -e un "\1.wav" \&\& mv "&" "&-OLD"/'

Be *EXTREMELY* careful with quotes, punctuation, spacing, and word-wrap when copying the above command. Cut+paste would be MUCH safer.

The above should output a list of conversion commands but NOT run them. If they look safe and you're happy to run them, you could copy+paste them into the same terminal, or alternatively:

find audio -name '*.ul' | sed -E 's/(.*)\.ul/sox "&" -e un "\1.wav" \&\& mv "&" "&-OLD"/' | sh

... which is exactly the same except with | sh on the end. You can almost certainly up-cursor, | (that's a pipe, probably shift-\, not a1, i, I, l, nor L), sh, return.

HOWEVER, that's not the whole story either, because some/many old versions of "saytime" are ignoring the very nice scripts/wavplay, INSISTING on the .ul files being present, and ignoring USE_APLAY=YES and writing direct to /dev/audio which you can't safely do any more unless you're running a dangerously old Linux.

So ALSO edit your "saytime". First, make a backup copy of this file in case you make things worse, then replace:

say () {
        file=$SDIR/$1.ul
        if [ ! -f $file ] ; then
                echo "`basename $0`: cannot find $file"
                exit 1
        fi
        SAYFILES="$SAYFILES $file"
}

... with just:

say () {
        SAYFILES="$SAYFILES custom/$1"
}

... and at the end, if it says:

cat $SAYFILES > /dev/audio

replace the line completely with:

$SCRIPT/wavplay  $SAYFILES

I *THINK* saytime will then work. I make no promises. I'll admit I've done NEITHER of the above Solution A/B, I've gone for Possible Solution C:

Rewrite saytime completely. Have it use a nice new clean set of synthesized WAVs, use IRLP-standard wavplay properly (and hence support USE_APLAY), support UTC or local time or both, add an optional voice ID/call, hey why not optionally read a short local weather forecast too?   :-D

... however I'm unfortunately not yet able to share my scripts for Solution C. Partly because the "local" weather is only local to Canada at the moment.   :-/

I might be talked into releasing a straight simple replacement for saytime if Solution B doesn't work for you.

Nick VA3NNW

-- 
"Nosey" Nick Waterman, VA3NNW/G7RZQ, K2 #5209.
use Std::Disclaimer;    sig@...
Numeric stability is probably not all that important when you're guessing.


 

I should have mentioned... This script uses $CUSTOM/wavplay_nice so there is no need to worry about $SCRIPT/wavplay being over written.

I also noticed that Rob had tried my script too but didn't say what the problem was/is using it.


>< Dave Parks ><
WB8ODF@...
http://wb8odf.com



On Friday, November 22, 2019, 11:40:35 PM EST, Dave Parks - WB8ODF via Groups.Io <wb8odf@...> wrote:


WOW Nick,

That was a whole lot of stuff I can't wrap my head around.

There is NO REASON to use sox in any of the IRLP scripts, I never understood why Dave C used it.... EVER

I'm sure Dave C is going to fix his script for Rob (he's good that way)... HOWEVER, I'll suggest we use my script (when I say *MY* script I mean the one I have for download on my server), I didn't write it, but I did edit it to work with Debian without the use of sox. It has worked for me since the very first version of Debian used by IRLP.

I'll step back here and let Dave C chime in with his fix for the sox problems since it actually was one of his "FEATURES" if/when purchasing one of the IRLP nodes.

We can go from there.... :)


>< Dave Parks ><
WB8ODF@...
http://wb8odf.com



On Friday, November 22, 2019, 11:21:20 PM EST, Nosey Nick VA3NNW <irlp@...> wrote:


Dave Parks - WB8ODF via Groups.Io wrote:
I know Dave C's feeling on this, through the years programmers of "Linux" and it's programs seem to change their flags with no rhyme or reason.

Whereas all the programmers of, say, "Microsoft Windows" and all it's 3rd-party programs, they have NEVER changed a thing? Yuh, sure   :-D

I *THINK* the problem here is that scripts/wavplay has at least 2 or 3 modes of operation:

Mode 1: USE_APLAY=YES ? Convert any FILE.ul to FILE.wav and aplay all the WAVs

Mode 1b: USE_APLAY=YES, and they are already all FILE.wav, and there's NO FILE.ul, no conversion required, simply aplay all the (existing) WAVs.

Mode 2: Otherwise if there IS NO FILE.ul, convert each FILE.wav to a temporary FILE.ul, join all the .ul files together into one big ul file, convert that back to a .wav, and $PLAY that.

You follow? Good so far EXCEPT neither of the conversions work with recent versions of "sox" (which is totally sox's fault, regardless of whether you choose to run sox on Linux, Windows, Mac, NetBSD or Commodore 64). This removes the usefulness of mode 1 and mode 2. The only mode that can still work is 1b, when USE_APLAY=YES, and when they are ALREADY FILE.wav. Luckily USE_APLAY=YES by default these days, and ALMOST every part of IRLP uses WAVs not .ul any longer, so you're ALMOST always using 1b and everything just works.

... except saytime uses audio/custom/*.ul which have not been converted to WAVs yet, so that takes mode 1b off the table too.

Possible solution A:

edit scripts/wavplay and fix the "sox" commands that are used for the conversions.

Assuming "sox --version" is quite new (mine is 14.4.2), everywhere it says "sox BLAH.ul -s -u BLAH.wav" (it MUST be a ul to a wav, and it must have the -s -u) ... change it to "sox BLAH.ul -e un BLAH.wav" (basically ONLY replace "-s -u" with "-e un" and leave the rest of the lines intact). There are at least 2 places to make this edit.

*AND* make sure your fixed scripts/wavplay doesn't get "fixed" back again every night when your machine updates itself, because you're not supposed to touch scripts/stuff, only custom/stuff. This is left as an exercise for the reader, your two hints are to read the "rsync" manpage, and to (ab)use this:

scripts/update:    UPDATEFILELIST="`cat ${CUSTOM}/update-file-list`"

*AND* make sure you DO eventually "fix" it to a new updated scripts/wavplay sometime if/after this problem is fixed, if ever. This is also left as an exercise for the reader, because really I'm not happy with any of "possible solution A" because of these last 2 points. I think I'd prefer you go for something like...

Possible solution B:

Make sure you have the aplay command. Try just typing "aplay" and see if you get a big help text (good) not "command not found" (bad).

Make sure you export USE_APLAY=YES in custom/environment

Convert all remaining FILE.ul to FILE.wav, as that appears to be the current IRLP standard anyway.

A script to TEST this conversion would be:

find audio -name '*.ul' | sed -E 's/(.*)\.ul/sox "&" -e un "\1.wav" \&\& mv "&" "&-OLD"/'

Be *EXTREMELY* careful with quotes, punctuation, spacing, and word-wrap when copying the above command. Cut+paste would be MUCH safer.

The above should output a list of conversion commands but NOT run them. If they look safe and you're happy to run them, you could copy+paste them into the same terminal, or alternatively:

find audio -name '*.ul' | sed -E 's/(.*)\.ul/sox "&" -e un "\1.wav" \&\& mv "&" "&-OLD"/' | sh

... which is exactly the same except with | sh on the end. You can almost certainly up-cursor, | (that's a pipe, probably shift-\, not a1, i, I, l, nor L), sh, return.

HOWEVER, that's not the whole story either, because some/many old versions of "saytime" are ignoring the very nice scripts/wavplay, INSISTING on the .ul files being present, and ignoring USE_APLAY=YES and writing direct to /dev/audio which you can't safely do any more unless you're running a dangerously old Linux.

So ALSO edit your "saytime". First, make a backup copy of this file in case you make things worse, then replace:

say () {
        file=$SDIR/$1.ul
        if [ ! -f $file ] ; then
                echo "`basename $0`: cannot find $file"
                exit 1
        fi
        SAYFILES="$SAYFILES $file"
}

... with just:

say () {
        SAYFILES="$SAYFILES custom/$1"
}

... and at the end, if it says:

cat $SAYFILES > /dev/audio

replace the line completely with:

$SCRIPT/wavplay  $SAYFILES

I *THINK* saytime will then work. I make no promises. I'll admit I've done NEITHER of the above Solution A/B, I've gone for Possible Solution C:

Rewrite saytime completely. Have it use a nice new clean set of synthesized WAVs, use IRLP-standard wavplay properly (and hence support USE_APLAY), support UTC or local time or both, add an optional voice ID/call, hey why not optionally read a short local weather forecast too?   :-D

... however I'm unfortunately not yet able to share my scripts for Solution C. Partly because the "local" weather is only local to Canada at the moment.   :-/

I might be talked into releasing a straight simple replacement for saytime if Solution B doesn't work for you.

Nick VA3NNW

-- 
"Nosey" Nick Waterman, VA3NNW/G7RZQ, K2 #5209.
use Std::Disclaimer;    sig@...
Numeric stability is probably not all that important when you're guessing.


Nosey Nick VA3NNW
 

Dave Parks - WB8ODF via Groups.Io wrote:
There is NO REASON to use sox in any of the IRLP scripts, I never understood why Dave C used it.... EVER

sox is a really good tool for converting between various audio formats. If .ul used to be an IRLP standard, but .wav was a later one, I can see why sox would be the obvious way to convert between them.

... or if .wav was always an IRLP standard, but the previous wavplayer left awkward gaps between samples, I can see why "convert them to raw/ul, join them together, convert them back, play as one file" might have seemed like a good idea at the time too.

Meh... See what Dave C suggests

-- 
"Nosey" Nick Waterman, VA3NNW/G7RZQ, K2 #5209.
use Std::Disclaimer;    sig@...
All those who believe in psychokinesis raise my hand.

 

Nick,

I agree with you here but I just don't see the need to make a .ul file convert it to .wav, play it then delete it... but that's just me.

For wave files we have play - alpay - wavplay & wavplay_nice.

For MP3 we have mpg321 which as of Debian WHEEZY is easy to find and install via apt-get, no fuss no muss!

If you're still using FC3 or CentOS 4.9 there is a mpg321 archive on my web site (wb8odf.com) that if installed in the order I have listed there, it has never let me down.


>< Dave Parks ><
WB8ODF@...
http://wb8odf.com



On Saturday, November 23, 2019, 5:38:58 PM EST, Nosey Nick VA3NNW <irlp@...> wrote:


Dave Parks - WB8ODF via Groups.Io wrote:
There is NO REASON to use sox in any of the IRLP scripts, I never understood why Dave C used it.... EVER

sox is a really good tool for converting between various audio formats. If .ul used to be an IRLP standard, but .wav was a later one, I can see why sox would be the obvious way to convert between them.

... or if .wav was always an IRLP standard, but the previous wavplayer left awkward gaps between samples, I can see why "convert them to raw/ul, join them together, convert them back, play as one file" might have seemed like a good idea at the time too.

Meh... See what Dave C suggests

-- 
"Nosey" Nick Waterman, VA3NNW/G7RZQ, K2 #5209.
use Std::Disclaimer;    sig@...
All those who believe in psychokinesis raise my hand.

David Cameron - IRLP
 

Well, when those scripts were made, if you typed

play 1.wav 2.wav 3.wav

The gap between 1 2 and 3 was in the order of two seconds, and it would vary based on processor load, etc. The solution was to convert the wav files to .au file (headerless, raw), concatenate them together, then convert back to a wav file for playing. Really not a big deal, and it worked well, UNTIL, the sox format changed to remove the -u flag for the WAV file format. So, what happened is anything that called sox with a -u flag was then broken.

With aplay, this is no longer required.

These scripts were not written my IRLP, and they are not maintained. If someone wants to write updated scripts to either remove sox, or fix the scripts that use sox, then this problem will go away. I fixed the scripts for the PiRLP and Embedded nodes, but they are very specific, and do not install well onto nodes that are not set up for them. The same error exists in EchoIRLP as well - use of sox with the -u or -s flags.

If you take your existing directories and look in the scripts for all use of "sox" with a -u or -s flag, and change them to -e unsigned-integer, they should work as they used to.

David Cameron
VE7LTD

On 23/11/2019 2:38 p.m., Nosey Nick VA3NNW wrote:
Dave Parks - WB8ODF via Groups.Io wrote:

There is NO REASON to use sox in any of the IRLP scripts, I never understood why Dave C used it.... EVER
sox is a really good tool for converting between various audio formats. If .ul used to be an IRLP standard, but .wav was a later one, I can see why sox would be the obvious way to convert between them.

... or if .wav was always an IRLP standard, but the previous wavplayer left awkward gaps between samples, I can see why "convert them to raw/ul, join them together, convert them back, play as one file" might have seemed like a good idea at the time too.

Meh... See what Dave C suggests

--
"Nosey" Nick Waterman, VA3NNW/G7RZQ, K2 #5209.
use Std::Disclaimer;sig@...
All those who believe in psychokinesis raise my hand.

 

Well... all I can say is, "that's as good an explanation as any"

Nick, try changing the -u and/or -s to -e and let us know if it fixes things... If not, I'll take a look and see if we can/should just remove sox and use aplay.


>< Dave Parks ><
WB8ODF@...
http://wb8odf.com



On Sunday, November 24, 2019, 2:04:55 PM EST, David Cameron - IRLP <dcameron@...> wrote:


Well, when those scripts were made, if you typed

play 1.wav 2.wav 3.wav

The gap between 1 2 and 3 was in the order of two seconds, and it would
vary based on processor load, etc. The solution was to convert the wav
files to .au file (headerless, raw), concatenate them together, then
convert back to a wav file for playing. Really not a big deal, and it
worked well, UNTIL, the sox format changed to remove the -u flag for the
WAV file format. So, what happened is anything that called sox with a -u
flag was then broken.

With aplay, this is no longer required.

These scripts were not written my IRLP, and they are not maintained. If
someone wants to write updated scripts to either remove sox, or fix the
scripts that use sox, then this problem will go away. I fixed the
scripts for the PiRLP and Embedded nodes, but they are very specific,
and do not install well onto nodes that are not set up for them. The
same error exists in EchoIRLP as well - use of sox with the -u or -s flags.

If you take your existing directories and look in the scripts for all
use of "sox" with a -u or -s flag, and change them to -e
unsigned-integer, they should work as they used to.

David Cameron
VE7LTD

On 23/11/2019 2:38 p.m., Nosey Nick VA3NNW wrote:
> Dave Parks - WB8ODF via Groups.Io wrote:
>
>> There is NO REASON to use sox in any of the IRLP scripts, I never
>> understood why Dave C used it.... EVER
>
> sox is a really good tool for converting between various audio
> formats. If .ul used to be an IRLP standard, but .wav was a later one,
> I can see why sox would be the obvious way to convert between them.
>
> ... or if .wav was always an IRLP standard, but the previous wavplayer
> left awkward gaps between samples, I can see why "convert them to
> raw/ul, join them together, convert them back, play as one file" might
> have seemed like a good idea at the time too.
>
> Meh... See what Dave C suggests
>
> --
> "Nosey" Nick Waterman, VA3NNW/G7RZQ, K2 #5209.
> use Std::Disclaimer;sig@...
> All those who believe in psychokinesis raise my hand.
>




Ken Pokigo
 

Hello
Does anyone have any information how to go about making a custom connect & disconnect message that people connecting into our node will hear instead of the basic "connected to node  xxxx"?
Thank you

Ken 
KC2AYK
node 8029

On Sunday, November 24, 2019, 06:34:33 PM EST, Dave Parks - WB8ODF via Groups.Io <wb8odf@...> wrote:


Well... all I can say is, "that's as good an explanation as any"

Nick, try changing the -u and/or -s to -e and let us know if it fixes things... If not, I'll take a look and see if we can/should just remove sox and use aplay.


>< Dave Parks ><
WB8ODF@...
http://wb8odf.com



On Sunday, November 24, 2019, 2:04:55 PM EST, David Cameron - IRLP <dcameron@...> wrote:


Well, when those scripts were made, if you typed

play 1.wav 2.wav 3.wav

The gap between 1 2 and 3 was in the order of two seconds, and it would
vary based on processor load, etc. The solution was to convert the wav
files to .au file (headerless, raw), concatenate them together, then
convert back to a wav file for playing. Really not a big deal, and it
worked well, UNTIL, the sox format changed to remove the -u flag for the
WAV file format. So, what happened is anything that called sox with a -u
flag was then broken.

With aplay, this is no longer required.

These scripts were not written my IRLP, and they are not maintained. If
someone wants to write updated scripts to either remove sox, or fix the
scripts that use sox, then this problem will go away. I fixed the
scripts for the PiRLP and Embedded nodes, but they are very specific,
and do not install well onto nodes that are not set up for them. The
same error exists in EchoIRLP as well - use of sox with the -u or -s flags.

If you take your existing directories and look in the scripts for all
use of "sox" with a -u or -s flag, and change them to -e
unsigned-integer, they should work as they used to.

David Cameron
VE7LTD

On 23/11/2019 2:38 p.m., Nosey Nick VA3NNW wrote:
> Dave Parks - WB8ODF via Groups.Io wrote:
>
>> There is NO REASON to use sox in any of the IRLP scripts, I never
>> understood why Dave C used it.... EVER
>
> sox is a really good tool for converting between various audio
> formats. If .ul used to be an IRLP standard, but .wav was a later one,
> I can see why sox would be the obvious way to convert between them.
>
> ... or if .wav was always an IRLP standard, but the previous wavplayer
> left awkward gaps between samples, I can see why "convert them to
> raw/ul, join them together, convert them back, play as one file" might
> have seemed like a good idea at the time too.
>
> Meh... See what Dave C suggests
>
> --
> "Nosey" Nick Waterman, VA3NNW/G7RZQ, K2 #5209.
> use Std::Disclaimer;sig@...
> All those who believe in psychokinesis raise my hand.
>




k9dc
 

Part of the problem is that you “Replied” to a previous thread, rather than starting a new one with your unrelated question. It would be more productive if you started a new thread.

To answer your question, the process is described in the After the Installation documents on the documentation page. http://www.irlp.net/new-install

There is also a related video on the youtube page https://www.youtube.com/user/IRLPhelp/videos

-k9dc

On Nov 25, 2019, at 22:24, Ken Pokigo via Groups.Io <kenpokigo101=yahoo.com@groups.io> wrote:

Hello
Does anyone have any information how to go about making a custom connect & disconnect message that people connecting into our node will hear instead of the basic "connected to node xxxx"?
Thank you

Ken
KC2AYK
node 8029