Topics

WWAN configuration and 4G Dongles on node 6370

Peter Chaplin <peter@...>
 

Thanks for the great service you provide to amateurs.
This is my first post and I'm only just learning Linux. I hope these aren't questions that can't be answered here.
I've just received a new node for Scouts in Australia and am trying to set it up ready for JOTA.
I'm wanting to plug a 4G modem direct into the Raspberry Pi USB port for the internet connection.
I've already acquired and installed the IRLP VPN and tested it with the 4G dongle plugged into a Cisco RV320 router, and it works fine, but I would like to do away with the need for the router and plug the 4G modem directly into the node.
I've found instructions for confirming drivers ect, but when I run the command ifconfig, I don't see a WWAN0. I do see eth0, lo and tun0.
The modem I'm trying to use is a Sierra 320U on Telstra
My questions;
How do I get WWAN0 installed as an interface?
Can the Raspberry Pi 4 IRLP Node operate with a 4G dongle plugged directly into a USB?
If so, how do I get it enabled.
Thanks in advance for any assistance.
regards,
Peter
VK3AJ
Nodes 6372,6373 and 6374 and administrator for Node 6370 on behalf of the Victorian Scout Radio and Electronics Service Unit in Australia.

k9dc
 

There is nothing wrong with your question. But I don’t know that you are going to get much of an answer here. A better choice might be to generically search for Raspberry Pi cellular solutions in Australia using Telstra.

Unfortunately plugging in a USB Cellular modem is not like using a Wifi USB stick, which is a world wide standard. 4G wireless devices depend on the Country you are in, the carrier you choose and the device and plan you are on. Each combination has unique requirements.

I was once able to get a Pantech Modem on Verizon Wireless to install directly on an IRLP node. But it was a real bear to get working, and after I did, I had very little knowledge of the modem status. When it connected (which often took several minutes) it worked. But when it died, there was no notification, nor any way to interrogate the modem status. The node was headless, and I had no access to it when the cellular link was down. This was a number of years ago, when there was only a single LTE band in use. Now there are dozens.

Bottom line is, I gave up and decided to let the router vendors handle the cellular implementations, and ethernet attach to the node. The RV320 is a rather expensive router to use just for IRLP though. I run an RV325 (same, but more ports) at home. Even though the router supports directly USB Cellular modems, I chose to connect an external Netgear router with ethernet, as a backup to my fiber feed. The Netgear is AT&T specific, supports all the bands that AT&T wireless uses here in .US. It has loads of idiot lights and its own web interface. Plus you can configure all the carrier and device proprietary parameters needed to get get it working.

Maybe someone else here has had better luck.

-k9dc

On Oct 1, 2019, at 23:29, Peter Chaplin <peter@...> wrote:

Thanks for the great service you provide to amateurs.
This is my first post and I'm only just learning Linux. I hope these aren't questions that can't be answered here.
I've just received a new node for Scouts in Australia and am trying to set it up ready for JOTA.
I'm wanting to plug a 4G modem direct into the Raspberry Pi USB port for the internet connection.
I've already acquired and installed the IRLP VPN and tested it with the 4G dongle plugged into a Cisco RV320 router, and it works fine, but I would like to do away with the need for the router and plug the 4G modem directly into the node.
I've found instructions for confirming drivers ect, but when I run the command ifconfig, I don't see a WWAN0. I do see eth0, lo and tun0.
The modem I'm trying to use is a Sierra 320U on Telstra
My questions;
How do I get WWAN0 installed as an interface?
Can the Raspberry Pi 4 IRLP Node operate with a 4G dongle plugged directly into a USB?
If so, how do I get it enabled.
Thanks in advance for any assistance.
regards,
Peter
VK3AJ
Nodes 6372,6373 and 6374 and administrator for Node 6370 on behalf of the Victorian Scout Radio and Electronics Service Unit in Australia.

Mike Alsop
 

Peter

I have my Debian 9 node running here on an Optus Huawei Dongle with 100% reliability. It is one of Dave's embedded nodes. If you like to email me direct, I will see if I can dig up the links for how I got mine going. Only problem is, it runs on 3G, so not getting the full benefit, but 3G works fine. I believe Debian 10 might have that sorted.

Cheers
Mike VK8MA

On Wed, 2019-10-02 at 09:16 -0500, k9dc wrote:
There is nothing wrong with your question.  But I don’t know that you are going to get much of an answer here. A better choice might be to generically search for Raspberry Pi cellular solutions in Australia using Telstra.  

Unfortunately plugging in a USB Cellular modem is not like using a Wifi USB stick, which is a world wide standard.  4G wireless devices depend on the Country you are in, the carrier you choose and the device and plan you are on. Each combination has unique requirements.  

I was once able to get a Pantech Modem on Verizon Wireless to install directly on an IRLP node.  But it was a real bear to get working, and after I did, I had very little knowledge of the modem status.  When it connected (which often took several minutes) it worked. But when it died, there was no notification, nor any way to interrogate the modem status. The node was headless, and I had no access to it when the cellular link was down.  This was a number of years ago, when there was only a single LTE band in use. Now there are dozens.

Bottom line is, I gave up and decided to let the router vendors handle the cellular implementations, and ethernet attach to the node. The RV320 is a rather expensive router to use just for IRLP though. I run an RV325 (same, but more ports) at home. Even though the router supports directly USB Cellular modems, I chose to connect an external Netgear router with ethernet, as a backup to my fiber feed. The Netgear is AT&T specific, supports all the bands that AT&T wireless uses here in .US. It has loads of idiot lights and its own web interface. Plus you can configure all the carrier and device proprietary parameters needed to get get it working.

Maybe someone else here has had better luck.

-k9dc


On Oct 1, 2019, at 23:29, Peter Chaplin <
peter@...
> wrote:

Thanks for the great service you provide to amateurs.
This is my first post and I'm only just learning Linux. I hope these aren't questions that can't be answered here.
I've just received a new node for Scouts in Australia and am trying to set it up ready for JOTA.
I'm wanting to plug a 4G modem direct into the Raspberry Pi USB port for the internet connection.
I've already acquired and installed the IRLP VPN and tested it with the 4G dongle plugged into a Cisco RV320 router, and it works fine, but I would like to do away with the need for the router and plug the 4G modem directly into the node.
I've found instructions for confirming drivers ect, but when I run the command ifconfig, I don't see a WWAN0. I do see eth0, lo and tun0.
The modem I'm trying to use is a Sierra 320U on Telstra
My questions;
How do I get WWAN0 installed as an interface?
Can the Raspberry Pi 4 IRLP Node operate with a 4G dongle plugged directly into a USB?
If so, how do I get it enabled.
Thanks in advance for any assistance.
regards,
Peter
VK3AJ
Nodes 6372,6373 and 6374 and administrator for Node 6370 on behalf of the Victorian Scout Radio and Electronics Service Unit in Australia.






Ramon Gandia
 

On 10/2/19 10:22 PM, Mike Alsop wrote:
Peter
I have my Debian 9 node running here on an Optus Huawei Dongle with 100% reliability. It is one of Dave's embedded nodes. If you like to email me direct, I will see if I can dig up the links for how I got mine going. Only problem is, it runs on 3G, so not getting the full benefit, but 3G works fine. I believe Debian 10 might have that sorted.
Cheers
Mike VK8MA
Mike, what model Optus Huawei dongle is this?
I see the E3131 for 3G,
and the E5377 for 4G,
There could be others. Which is it?

--
/|\
Ramon Gandia AL7X, 7827
Nome, Alaska USA

Peter Chaplin <peter@...>
 

Thanks to everyone who has provided tips for this.
From these tips, I have been able to get wwan0 showing up when i run ifconfig
This has led to getting the 4G dongle working and showing up an IP address in the netconfig application, but IRLP want's to use eth0 instead of wwan0 as it's interface, which of course eth0 is unplugged.
How do I get the IRLP node to use wwan0 instead of eth0.
I've tried changing the adaptor in /etc/network/interfaces but that doesn't seem to make a difference.

k9dc
 

IRLP will use whatever interface is chosen by the Linux routing table. What does the command ‘ip route show' reveal?

-k9dc

On Oct 3, 2019, at 07:04, Peter Chaplin <peter@...> wrote:

Thanks to everyone who has provided tips for this.
From these tips, I have been able to get wwan0 showing up when i run ifconfig
This has led to getting the 4G dongle working and showing up an IP address in the netconfig application, but IRLP want's to use eth0 instead of wwan0 as it's interface, which of course eth0 is unplugged.
How do I get the IRLP node to use wwan0 instead of eth0.
I've tried changing the adaptor in /etc/network/interfaces but that doesn't seem to make a difference.

Mike Alsop
 

Doing lsusb, the Huawei model is E33372 with a product code of 12d1:14dc

Mike
VK8MA

On Thu, 2019-10-03 at 01:38 -0800, Ramon Gandia wrote:
On 10/2/19 10:22 PM, Mike Alsop wrote:
Peter

I have my Debian 9 node running here on an Optus Huawei Dongle with 100% 
reliability. It is one of Dave's embedded nodes. If you like to email me 
direct, I will see if I can dig up the links for how I got mine going. 
Only problem is, it runs on 3G, so not getting the full benefit, but 3G 
works fine. I believe Debian 10 might have that sorted.

Cheers
Mike VK8MA

Mike, what model Optus Huawei dongle is this?
I see the E3131 for 3G,
and the  E5377 for 4G,
There could be others.  Which is it?

Mike Alsop
 

I am pretty sure if you comment out any entries in /etc/network/interfaces relating to eth0 and then reboot, you should be on the dongle.

Mike

On Thu, 2019-10-03 at 09:00 -0500, k9dc wrote:
IRLP will use whatever interface is chosen by the Linux routing table.  What does the command ‘ip route show' reveal?  

-k9dc

On Oct 3, 2019, at 07:04, Peter Chaplin <
peter@...
> wrote:

Thanks to everyone who has provided tips for this.
From these tips, I have been able to get wwan0 showing up when i run ifconfig
This has led to getting the 4G dongle working and showing up an IP address in the netconfig application, but IRLP want's to use eth0 instead of wwan0 as it's interface, which of course eth0 is unplugged.
How do I get the IRLP node to use wwan0 instead of eth0.
I've tried changing the adaptor in /etc/network/interfaces but that doesn't seem to make a difference.



Peter Chaplin <peter@...>
 

Well, I finally have everything working.

Thanks Mike, commenting out the eth0 lines brought the dongle up.

What I found is if I put the wwan0 ahead of the eth0 in the interfaces file, it will try for the wwan0 and if it’s not there, move on to the eth0.

 

The node (6370) is now showing up in the IRLP active node list. – That’s a win.

However, when on the 4G dongle, the node VK3RSR-R wasn’t showing up in EchoLINK.

Swap back to eth0 and VK3RSR-R comes straight up in EchoLINK.

I wouldn’t have thought that how the Pi is getting internet would have mattered.

 

While connected on the 4G dongle, I ran the Troubleshooting script in the node and it passed everything except Test 1 – DNS and Test 10 which it’s not expected to pass with EchoIRLP enabled.

I swapped back to eth0 and re-ran the Troubleshoot, it passed Test 1.

This would suggest there is something stopping the DNS service from running when wwan0 is selected.

This is confirmed by NOT being able to Ping any domain name but being able to Ping the IP address for the domain when connected to wwan0.

I’m able to ping both Domain name and IP address when connected to eth0.

 

During bootup, I see a message “A start job is running for Raise network interfaces”

Then I get a “Failed to start Raise network interfaces” when booting up with wwan0.

 

I tried adding dns-nameservers and the IP addresses of my carriers DNS servers to the /etc/network/interfaces file after the WWAN0 interface, but that didn’t make any difference.

I also enabled static DNS addresses in the dongle with my carriers DNS servers to no avail.

I then tried to Ping my carriers DNS servers and found I could not do so.

I changed the static DNS servers in my dongle to 8.8.8.8 and 8.8.4.4 (Google’s public DNS servers) and hey presto, My node comes up in EchoLINK and works fine.

Doing this doesn’t stop the “Failed to start” message, however, I noticed the Google DNS addresses have been inserted into the resolve.conf file from the 4G dongle’s static DNS or elsewhere.

I then went back and added the Google DNS servers into the /etc/network/interfaces file (dns-nameservers 8.8.8.8 8.8.4.4) for the wwan0 interface and tested it. All worked fine.

So, there must be something in Debian or IRLP scripts that causes the Telstra DNS addresses to be blocked.

 

So, in summary, to get it working all I had to do was add a wwan0 interface into the /etc/network/interfaces file and include a line dns-nameservers 8.8.8.8 8.8.4.4 for the wwan0 interface and place the wwan0 interface ahead of the eth0 interface.

 

Either way, I’ve resolved my problem.

Next, just because I like putting myself through mental pain, I’ll try the same with some other model 4G dongles I have laying around and see if they have the same symptoms.

 

Thanks again to all those that offered tips and hints that led me down the learning path of Unix/Linux/Debian/Raspbian/etc

 

Yours gratefully and 73’s for now,

Peter

VK3AJ

 

From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of Mike Alsop
Sent: Friday, 4 October 2019 11:02
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] WWAN configuration and 4G Dongles on node 6370

 

I am pretty sure if you comment out any entries in /etc/network/interfaces relating to eth0 and then reboot, you should be on the dongle.

 

Mike

 

On Thu, 2019-10-03 at 09:00 -0500, k9dc wrote:

IRLP will use whatever interface is chosen by the Linux routing table.  What does the command ‘ip route show' reveal?  
 
-k9dc
 
On Oct 3, 2019, at 07:04, Peter Chaplin <

peter@...

 

> wrote:
 
Thanks to everyone who has provided tips for this.
From these tips, I have been able to get wwan0 showing up when i run ifconfig
This has led to getting the 4G dongle working and showing up an IP address in the netconfig application, but IRLP want's to use eth0 instead of wwan0 as it's interface, which of course eth0 is unplugged.
How do I get the IRLP node to use wwan0 instead of eth0.
I've tried changing the adaptor in /etc/network/interfaces but that doesn't seem to make a difference.
 
 
 

Mike Alsop
 

Ah, yes I had the same problem. Peter what are you seeing in /etc/resolv.conf when you are using the dongle??

Mike
VK8MA

On Sat, 2019-10-05 at 09:37 +1000, Peter Chaplin wrote:

Well, I finally have everything working.

Thanks Mike, commenting out the eth0 lines brought the dongle up.

What I found is if I put the wwan0 ahead of the eth0 in the interfaces file, it will try for the wwan0 and if it’s not there, move on to the eth0.

 

The node (6370) is now showing up in the IRLP active node list. – That’s a win.

However, when on the 4G dongle, the node VK3RSR-R wasn’t showing up in EchoLINK.

Swap back to eth0 and VK3RSR-R comes straight up in EchoLINK.

I wouldn’t have thought that how the Pi is getting internet would have mattered.

 

While connected on the 4G dongle, I ran the Troubleshooting script in the node and it passed everything except Test 1 – DNS and Test 10 which it’s not expected to pass with EchoIRLP enabled.

I swapped back to eth0 and re-ran the Troubleshoot, it passed Test 1.

This would suggest there is something stopping the DNS service from running when wwan0 is selected.

This is confirmed by NOT being able to Ping any domain name but being able to Ping the IP address for the domain when connected to wwan0.

I’m able to ping both Domain name and IP address when connected to eth0.

 

During bootup, I see a message “A start job is running for Raise network interfaces”

Then I get a “Failed to start Raise network interfaces” when booting up with wwan0.

 

I tried adding dns-nameservers and the IP addresses of my carriers DNS servers to the /etc/network/interfaces file after the WWAN0 interface, but that didn’t make any difference.

I also enabled static DNS addresses in the dongle with my carriers DNS servers to no avail.

I then tried to Ping my carriers DNS servers and found I could not do so.

I changed the static DNS servers in my dongle to 8.8.8.8 and 8.8.4.4 (Google’s public DNS servers) and hey presto, My node comes up in EchoLINK and works fine.

Doing this doesn’t stop the “Failed to start” message, however, I noticed the Google DNS addresses have been inserted into the resolve.conf file from the 4G dongle’s static DNS or elsewhere.

I then went back and added the Google DNS servers into the /etc/network/interfaces file (dns-nameservers 8.8.8.8 8.8.4.4) for the wwan0 interface and tested it. All worked fine.

So, there must be something in Debian or IRLP scripts that causes the Telstra DNS addresses to be blocked.

 

So, in summary, to get it working all I had to do was add a wwan0 interface into the /etc/network/interfaces file and include a line dns-nameservers 8.8.8.8 8.8.4.4 for the wwan0 interface and place the wwan0 interface ahead of the eth0 interface.

 

Either way, I’ve resolved my problem.

Next, just because I like putting myself through mental pain, I’ll try the same with some other model 4G dongles I have laying around and see if they have the same symptoms.

 

Thanks again to all those that offered tips and hints that led me down the learning path of Unix/Linux/Debian/Raspbian/etc

 

Yours gratefully and 73’s for now,

Peter

VK3AJ

 

From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of Mike Alsop
Sent: Friday, 4 October 2019 11:02
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] WWAN configuration and 4G Dongles on node 6370

 

I am pretty sure if you comment out any entries in /etc/network/interfaces relating to eth0 and then reboot, you should be on the dongle.

 

Mike

 

On Thu, 2019-10-03 at 09:00 -0500, k9dc wrote:

IRLP will use whatever interface is chosen by the Linux routing table.  What does the command ‘ip route show' reveal?  
 
-k9dc
 
On Oct 3, 2019, at 07:04, Peter Chaplin <

peter@...

 

> wrote:
 
Thanks to everyone who has provided tips for this.
From these tips, I have been able to get wwan0 showing up when i run ifconfig
This has led to getting the 4G dongle working and showing up an IP address in the netconfig application, but IRLP want's to use eth0 instead of wwan0 as it's interface, which of course eth0 is unplugged.
How do I get the IRLP node to use wwan0 instead of eth0.
I've tried changing the adaptor in /etc/network/interfaces but that doesn't seem to make a difference.
 
 
 

Peter Chaplin <peter@...>
 

Hi Mike,

 

If I don’t enable Static DNS, then the default Telstra DNS servers IP addresses are passed through to the /etc/resolv.conf file. For Victoria, the IP addresses are 61.9.133.193 and 61.9.133.49. They are different for each state.

 

Peter

VK3AJ

 

 

From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of Mike Alsop
Sent: Saturday, 5 October 2019 11:13
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] WWAN configuration and 4G Dongles on node 6370

 

Ah, yes I had the same problem. Peter what are you seeing in /etc/resolv.conf when you are using the dongle??

 

Mike

VK8MA

 

On Sat, 2019-10-05 at 09:37 +1000, Peter Chaplin wrote:

Well, I finally have everything working.

Thanks Mike, commenting out the eth0 lines brought the dongle up.

What I found is if I put the wwan0 ahead of the eth0 in the interfaces file, it will try for the wwan0 and if it’s not there, move on to the eth0.

 

The node (6370) is now showing up in the IRLP active node list. – That’s a win.

However, when on the 4G dongle, the node VK3RSR-R wasn’t showing up in EchoLINK.

Swap back to eth0 and VK3RSR-R comes straight up in EchoLINK.

I wouldn’t have thought that how the Pi is getting internet would have mattered.

 

While connected on the 4G dongle, I ran the Troubleshooting script in the node and it passed everything except Test 1 – DNS and Test 10 which it’s not expected to pass with EchoIRLP enabled.

I swapped back to eth0 and re-ran the Troubleshoot, it passed Test 1.

This would suggest there is something stopping the DNS service from running when wwan0 is selected.

This is confirmed by NOT being able to Ping any domain name but being able to Ping the IP address for the domain when connected to wwan0.

I’m able to ping both Domain name and IP address when connected to eth0.

 

During bootup, I see a message “A start job is running for Raise network interfaces”

Then I get a “Failed to start Raise network interfaces” when booting up with wwan0.

 

I tried adding dns-nameservers and the IP addresses of my carriers DNS servers to the /etc/network/interfaces file after the WWAN0 interface, but that didn’t make any difference.

I also enabled static DNS addresses in the dongle with my carriers DNS servers to no avail.

I then tried to Ping my carriers DNS servers and found I could not do so.

I changed the static DNS servers in my dongle to 8.8.8.8 and 8.8.4.4 (Google’s public DNS servers) and hey presto, My node comes up in EchoLINK and works fine.

Doing this doesn’t stop the “Failed to start” message, however, I noticed the Google DNS addresses have been inserted into the resolve.conf file from the 4G dongle’s static DNS or elsewhere.

I then went back and added the Google DNS servers into the /etc/network/interfaces file (dns-nameservers 8.8.8.8 8.8.4.4) for the wwan0 interface and tested it. All worked fine.

So, there must be something in Debian or IRLP scripts that causes the Telstra DNS addresses to be blocked.

 

So, in summary, to get it working all I had to do was add a wwan0 interface into the /etc/network/interfaces file and include a line dns-nameservers 8.8.8.8 8.8.4.4 for the wwan0 interface and place the wwan0 interface ahead of the eth0 interface.

 

Either way, I’ve resolved my problem.

Next, just because I like putting myself through mental pain, I’ll try the same with some other model 4G dongles I have laying around and see if they have the same symptoms.

 

Thanks again to all those that offered tips and hints that led me down the learning path of Unix/Linux/Debian/Raspbian/etc

 

Yours gratefully and 73’s for now,

Peter

VK3AJ

 

From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of Mike Alsop
Sent: Friday, 4 October 2019 11:02
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] WWAN configuration and 4G Dongles on node 6370

 

I am pretty sure if you comment out any entries in /etc/network/interfaces relating to eth0 and then reboot, you should be on the dongle.

 

Mike

 

On Thu, 2019-10-03 at 09:00 -0500, k9dc wrote:

IRLP will use whatever interface is chosen by the Linux routing table.  What does the command ‘ip route show' reveal?  

 

-k9dc

 

On Oct 3, 2019, at 07:04, Peter Chaplin <

 

peter@...

 

 

> wrote:

 

Thanks to everyone who has provided tips for this.

 

From these tips, I have been able to get wwan0 showing up when i run ifconfig

 

This has led to getting the 4G dongle working and showing up an IP address in the netconfig application, but IRLP want's to use eth0 instead of wwan0 as it's interface, which of course eth0 is unplugged.

 

How do I get the IRLP node to use wwan0 instead of eth0.

 

I've tried changing the adaptor in /etc/network/interfaces but that doesn't seem to make a difference.

 

 

 

 

Mike Alsop
 

Peter

Interested to know how you actually got 4G to work?? I have tried everything I know under Debian 9, but just can't get past 3G

Mike
VK8MA

On Sat, 2019-10-05 at 09:37 +1000, Peter Chaplin wrote:

Well, I finally have everything working.

Thanks Mike, commenting out the eth0 lines brought the dongle up.

What I found is if I put the wwan0 ahead of the eth0 in the interfaces file, it will try for the wwan0 and if it’s not there, move on to the eth0.

 

The node (6370) is now showing up in the IRLP active node list. – That’s a win.

However, when on the 4G dongle, the node VK3RSR-R wasn’t showing up in EchoLINK.

Swap back to eth0 and VK3RSR-R comes straight up in EchoLINK.

I wouldn’t have thought that how the Pi is getting internet would have mattered.

 

While connected on the 4G dongle, I ran the Troubleshooting script in the node and it passed everything except Test 1 – DNS and Test 10 which it’s not expected to pass with EchoIRLP enabled.

I swapped back to eth0 and re-ran the Troubleshoot, it passed Test 1.

This would suggest there is something stopping the DNS service from running when wwan0 is selected.

This is confirmed by NOT being able to Ping any domain name but being able to Ping the IP address for the domain when connected to wwan0.

I’m able to ping both Domain name and IP address when connected to eth0.

 

During bootup, I see a message “A start job is running for Raise network interfaces”

Then I get a “Failed to start Raise network interfaces” when booting up with wwan0.

 

I tried adding dns-nameservers and the IP addresses of my carriers DNS servers to the /etc/network/interfaces file after the WWAN0 interface, but that didn’t make any difference.

I also enabled static DNS addresses in the dongle with my carriers DNS servers to no avail.

I then tried to Ping my carriers DNS servers and found I could not do so.

I changed the static DNS servers in my dongle to 8.8.8.8 and 8.8.4.4 (Google’s public DNS servers) and hey presto, My node comes up in EchoLINK and works fine.

Doing this doesn’t stop the “Failed to start” message, however, I noticed the Google DNS addresses have been inserted into the resolve.conf file from the 4G dongle’s static DNS or elsewhere.

I then went back and added the Google DNS servers into the /etc/network/interfaces file (dns-nameservers 8.8.8.8 8.8.4.4) for the wwan0 interface and tested it. All worked fine.

So, there must be something in Debian or IRLP scripts that causes the Telstra DNS addresses to be blocked.

 

So, in summary, to get it working all I had to do was add a wwan0 interface into the /etc/network/interfaces file and include a line dns-nameservers 8.8.8.8 8.8.4.4 for the wwan0 interface and place the wwan0 interface ahead of the eth0 interface.

 

Either way, I’ve resolved my problem.

Next, just because I like putting myself through mental pain, I’ll try the same with some other model 4G dongles I have laying around and see if they have the same symptoms.

 

Thanks again to all those that offered tips and hints that led me down the learning path of Unix/Linux/Debian/Raspbian/etc

 

Yours gratefully and 73’s for now,

Peter

VK3AJ

 

From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of Mike Alsop
Sent: Friday, 4 October 2019 11:02
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] WWAN configuration and 4G Dongles on node 6370

 

I am pretty sure if you comment out any entries in /etc/network/interfaces relating to eth0 and then reboot, you should be on the dongle.

 

Mike

 

On Thu, 2019-10-03 at 09:00 -0500, k9dc wrote:

IRLP will use whatever interface is chosen by the Linux routing table.  What does the command ‘ip route show' reveal?  
 
-k9dc
 
On Oct 3, 2019, at 07:04, Peter Chaplin <

peter@...

 

> wrote:
 
Thanks to everyone who has provided tips for this.
From these tips, I have been able to get wwan0 showing up when i run ifconfig
This has led to getting the 4G dongle working and showing up an IP address in the netconfig application, but IRLP want's to use eth0 instead of wwan0 as it's interface, which of course eth0 is unplugged.
How do I get the IRLP node to use wwan0 instead of eth0.
I've tried changing the adaptor in /etc/network/interfaces but that doesn't seem to make a difference.
 
 
 

Peter Chaplin <peter@...>
 

Hi Mike/et al,

 

I’ve deployed the node for JOTA, so don’t have access to it at the moment to review the files.

 

Basically, in the  /etc/network/interfaces file I added the below wwan0 interface before the eth0 interface.

 

auto wwan0

allow-hotplug wwan0

iface wwan0 inet dhcp

               dns-nameservers 8.8.8.8 8.8.4.4

 

I swapped the SIM between a couple of different model 4G dongles, Telstra Sierra 320U and another that I don’t have the model at hand and it worked with both.

I can’t say I specifically looked to confirm 4G operation. I will when I get the unit back after JOTA in November.

 

Regards,

Peter

VK3AJ

 

From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of Mike Alsop
Sent: Thursday, 10 October 2019 21:18
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] WWAN configuration and 4G Dongles on node 6370

 

Peter

 

Interested to know how you actually got 4G to work?? I have tried everything I know under Debian 9, but just can't get past 3G

 

Mike

VK8MA

 

On Sat, 2019-10-05 at 09:37 +1000, Peter Chaplin wrote:

Well, I finally have everything working.

Thanks Mike, commenting out the eth0 lines brought the dongle up.

What I found is if I put the wwan0 ahead of the eth0 in the interfaces file, it will try for the wwan0 and if it’s not there, move on to the eth0.

 

The node (6370) is now showing up in the IRLP active node list. – That’s a win.

However, when on the 4G dongle, the node VK3RSR-R wasn’t showing up in EchoLINK.

Swap back to eth0 and VK3RSR-R comes straight up in EchoLINK.

I wouldn’t have thought that how the Pi is getting internet would have mattered.

 

While connected on the 4G dongle, I ran the Troubleshooting script in the node and it passed everything except Test 1 – DNS and Test 10 which it’s not expected to pass with EchoIRLP enabled.

I swapped back to eth0 and re-ran the Troubleshoot, it passed Test 1.

This would suggest there is something stopping the DNS service from running when wwan0 is selected.

This is confirmed by NOT being able to Ping any domain name but being able to Ping the IP address for the domain when connected to wwan0.

I’m able to ping both Domain name and IP address when connected to eth0.

 

During bootup, I see a message “A start job is running for Raise network interfaces”

Then I get a “Failed to start Raise network interfaces” when booting up with wwan0.

 

I tried adding dns-nameservers and the IP addresses of my carriers DNS servers to the /etc/network/interfaces file after the WWAN0 interface, but that didn’t make any difference.

I also enabled static DNS addresses in the dongle with my carriers DNS servers to no avail.

I then tried to Ping my carriers DNS servers and found I could not do so.

I changed the static DNS servers in my dongle to 8.8.8.8 and 8.8.4.4 (Google’s public DNS servers) and hey presto, My node comes up in EchoLINK and works fine.

Doing this doesn’t stop the “Failed to start” message, however, I noticed the Google DNS addresses have been inserted into the resolve.conf file from the 4G dongle’s static DNS or elsewhere.

I then went back and added the Google DNS servers into the /etc/network/interfaces file (dns-nameservers 8.8.8.8 8.8.4.4) for the wwan0 interface and tested it. All worked fine.

So, there must be something in Debian or IRLP scripts that causes the Telstra DNS addresses to be blocked.

 

So, in summary, to get it working all I had to do was add a wwan0 interface into the /etc/network/interfaces file and include a line dns-nameservers 8.8.8.8 8.8.4.4 for the wwan0 interface and place the wwan0 interface ahead of the eth0 interface.

 

Either way, I’ve resolved my problem.

Next, just because I like putting myself through mental pain, I’ll try the same with some other model 4G dongles I have laying around and see if they have the same symptoms.

 

Thanks again to all those that offered tips and hints that led me down the learning path of Unix/Linux/Debian/Raspbian/etc

 

Yours gratefully and 73’s for now,

Peter

VK3AJ

 

From: IRLP@irlp.groups.io <IRLP@irlp.groups.io> On Behalf Of Mike Alsop
Sent: Friday, 4 October 2019 11:02
To: IRLP@irlp.groups.io
Subject: Re: [IRLP] WWAN configuration and 4G Dongles on node 6370

 

I am pretty sure if you comment out any entries in /etc/network/interfaces relating to eth0 and then reboot, you should be on the dongle.

 

Mike

 

On Thu, 2019-10-03 at 09:00 -0500, k9dc wrote:

IRLP will use whatever interface is chosen by the Linux routing table.  What does the command ‘ip route show' reveal?  

 

-k9dc

 

On Oct 3, 2019, at 07:04, Peter Chaplin <

 

peter@...

 

 

> wrote:

 

Thanks to everyone who has provided tips for this.

 

From these tips, I have been able to get wwan0 showing up when i run ifconfig

 

This has led to getting the 4G dongle working and showing up an IP address in the netconfig application, but IRLP want's to use eth0 instead of wwan0 as it's interface, which of course eth0 is unplugged.

 

How do I get the IRLP node to use wwan0 instead of eth0.

 

I've tried changing the adaptor in /etc/network/interfaces but that doesn't seem to make a difference.